Notices

DIY: RB Gauge Pod + Nordskog Digital Gauges

Old 02-17-2008, 03:04 PM
  #51  
Registered User
 
Join Date: Jul 2007
Location: new jersey U.S.A
Posts: 705
Likes: 0
Liked 0 Times in 0 Posts
jedi i need the force where are u......... pmme
nelsonrx8 is offline  
Old 03-08-2008, 07:19 PM
  #52  
Jedi Master
Thread Starter
iTrader: (7)
 
Jedi54's Avatar
 
Join Date: Mar 2004
Location: The Dark Side
Posts: 21,192
Liked 563 Times in 381 Posts
added 2 new night time pics courtesy of PhotoChick.
Jedi54 is online now  
Old 03-10-2008, 05:57 PM
  #53  
Registered User
 
Join Date: Mar 2008
Location: Rancho Cucamonga CA
Posts: 3
Likes: 0
Liked 0 Times in 0 Posts
that is sexy
Incorigible is offline  
Old 03-31-2008, 04:03 PM
  #54  
Bigus Rotus
iTrader: (3)
 
Nemesis8's Avatar
 
Join Date: Jun 2004
Location: Banks of The Muddy Wishkah
Posts: 8,573
Likes: 0
Liked 0 Times in 0 Posts
OK, I have read this post back when you published - nice mod. I'm curious of the dimmer function. You said you used the ashtray light circuit? Is that what RB does also with there mech gauges? I'm curious about a complete dimming function I guess. Seems you said either 100% with lights off, and 50% with lights on, correct?
Nemesis8 is offline  
Old 03-31-2008, 04:15 PM
  #55  
Jedi Master
Thread Starter
iTrader: (7)
 
Jedi54's Avatar
 
Join Date: Mar 2004
Location: The Dark Side
Posts: 21,192
Liked 563 Times in 381 Posts
Yup, Racing Beat recommends tapping into the ashtray light on their insturctions. (Nordskog had similar instructions)

I remember reading that my guagues were not intended to have full dimming options (as our gauge cluster) has but I'm pretty sure that if wired properly it might work. Not sure exactly how to pull that off though.
What guages are you trying to get to dim?
Jedi54 is online now  
Old 03-31-2008, 04:20 PM
  #56  
Bigus Rotus
iTrader: (3)
 
Nemesis8's Avatar
 
Join Date: Jun 2004
Location: Banks of The Muddy Wishkah
Posts: 8,573
Likes: 0
Liked 0 Times in 0 Posts
Have not decided on them yet, but you are persuading me to join you.
Nemesis8 is offline  
Old 03-31-2008, 04:21 PM
  #57  
Jedi Master
Thread Starter
iTrader: (7)
 
Jedi54's Avatar
 
Join Date: Mar 2004
Location: The Dark Side
Posts: 21,192
Liked 563 Times in 381 Posts
come over to the Dark Side...
Jedi54 is online now  
Old 03-31-2008, 05:14 PM
  #58  
the bukkake master!
 
snipaz2420's Avatar
 
Join Date: Apr 2005
Location: Staten Island, NY
Posts: 1,972
Likes: 0
Liked 0 Times in 0 Posts
jedi imo this is the sexiest gauge setup i've ever seen
snipaz2420 is offline  
Old 03-31-2008, 05:23 PM
  #59  
Jedi Master
Thread Starter
iTrader: (7)
 
Jedi54's Avatar
 
Join Date: Mar 2004
Location: The Dark Side
Posts: 21,192
Liked 563 Times in 381 Posts
Originally Posted by snipaz2420 View Post
jedi imo this is the sexiest gauge setup i've ever seen
Thanks Snipaz!!!
Jedi54 is online now  
Old 05-12-2008, 11:34 AM
  #60  
Registered User
 
Join Date: May 2008
Posts: 6
Likes: 0
Liked 0 Times in 0 Posts
Racing beat question

hey im trying to buy the RB pod but cant find a place to buy it could u help me out? thank you
drjw211 is offline  
Old 05-12-2008, 11:42 AM
  #61  
Jedi Master
Thread Starter
iTrader: (7)
 
Jedi54's Avatar
 
Join Date: Mar 2004
Location: The Dark Side
Posts: 21,192
Liked 563 Times in 381 Posts
drjw211: where are you located?
Did you call Racing Beat directly?
Jedi54 is online now  
Old 05-15-2008, 03:30 AM
  #62  
Registered User
 
Join Date: May 2008
Posts: 6
Likes: 0
Liked 0 Times in 0 Posts
i live in maryland, no but ill try that
drjw211 is offline  
Old 05-16-2008, 10:33 PM
  #63  
Moderator
iTrader: (2)
 
BoosTED's Avatar
 
Join Date: Dec 2004
Location: Minneapolis, MN
Posts: 2,896
Likes: 0
Liked 1 Time in 1 Post
Mmmm I'm likin' the look of those numeric gauges. Didn't think I would ever like digital readout gauges but these are stealth looking.
BoosTED is offline  
Old 07-10-2008, 12:17 PM
  #64  
Jedi Master
Thread Starter
iTrader: (7)
 
Jedi54's Avatar
 
Join Date: Mar 2004
Location: The Dark Side
Posts: 21,192
Liked 563 Times in 381 Posts
Just wanted to update everyone on these guages. I finally ran into a problem with them. Here's a crappy cell phone video I took while trying to drive.

As you can see, the temp readings are all over the place!





Now the question is: What's causing the false readings? Is it the gauge itself, a connection, or a bad sending unit?
In order to try and rule out the gauge as faulty, I swapped the sending lines from my water temp and my oil temp. ie; the water temp would now show oil readings and vice versa
This was super easy to do, simply unscrew the gauge pod and swap the BLUE wires for the two gauges.

Here's a video of what happened:



That pretty much ruled out the Oil Temp gauge as now the Water temp gauge is doing the same thing.

Next step was to check all my connections. Again, this is fairly easy as the ground wires are easy to spot in the engine bay and all the gauges share the same ground wire. (post 1 talks about soldering 3 wires off the main ground)


Conclusion: must be a bad sending unit.


Since I've had the gauges for a few months, I decided it was best to contact Nordskog directly about the problem. I sent them an email and they were VERY quick to respond. The Manager at Nordskog agreed that the symptoms all pointed to a bad sending unit and all they needed was an address to ship out a replacement. now THAT'S great service!! I had the replacement part 2 days later.

Happy to report that after swapping out the sending unit this past weekend, the gauges are now working PERFECTLY! A big thanks to Nordskog for stepping up and being helpful.

Removing the RB adaptor to replace the sending unit is not all that tough but is is made more difficult since all your connections are already in place. (as opposed to when you installed it) This is where I was glad I had left plenty of extra slack when I originally installed everything. (the extra slack was zip tied underneath the dash, not in the engine bay)

Hope this helps...
Jedi54 is online now  
Old 07-10-2008, 12:38 PM
  #65  
Registered
iTrader: (1)
 
NgoRX8's Avatar
 
Join Date: Oct 2004
Location: CA, Rowland Hts.
Posts: 10,238
Likes: 0
Liked 0 Times in 0 Posts
good news! glad ya got it fixed.
NgoRX8 is offline  
Old 07-10-2008, 12:44 PM
  #66  
Jedi Master
Thread Starter
iTrader: (7)
 
Jedi54's Avatar
 
Join Date: Mar 2004
Location: The Dark Side
Posts: 21,192
Liked 563 Times in 381 Posts
yup, although ignorance was BLISS!!! I loved it when it was 105F outside and my oil temps were only at 115
Jedi54 is online now  
Old 07-17-2008, 05:50 AM
  #67  
Registered User
 
Join Date: Jun 2005
Location: Dayton, Ohio
Posts: 128
Likes: 0
Liked 0 Times in 0 Posts
I'm still dreaming of this setup on my car...
Glad everything worked out and it's great that they sent you a replacement, sounds like a good company!
V1.0 is offline  
Old 07-18-2008, 08:10 PM
  #68  
elf
What pointy ears?
 
elf's Avatar
 
Join Date: Jul 2006
Location: California
Posts: 301
Likes: 0
Liked 1 Time in 1 Post
Good to hear you got the problem fixed! I remembered speaking with Nordskog support (for information) and they were quite responsive.

No problems with my gauges --- still work like a champ! But, yeah, I agree with your "ignorance is bliss" statement about temps --- it's amazing how hot this engine gets in the summer in the deserts of the southwest US
elf is offline  
Old 09-07-2008, 09:34 PM
  #69  
Registered User
iTrader: (1)
 
Join Date: Jun 2008
Posts: 13
Likes: 0
Liked 0 Times in 0 Posts
Hi Jedi,great write up. You inspired me to do the same so now i have all items purchased and ready to install. I've noticed that the gauges do not sit flush on the Racing Beat pod,due to the curvature of it. Is this the same with yours?
irx08t is offline  
Old 09-07-2008, 09:48 PM
  #70  
Jedi Master
Thread Starter
iTrader: (7)
 
Jedi54's Avatar
 
Join Date: Mar 2004
Location: The Dark Side
Posts: 21,192
Liked 563 Times in 381 Posts
hey irx: glad to hear you've been inspired!
yeah, due to the natural curvature of the pod, there will be areas where it does not sit flush but because the side of the gauges are also black, you will not notice this once it's installed.
Jedi54 is online now  
Old 09-08-2008, 12:31 AM
  #71  
Registered
iTrader: (1)
 
NgoRX8's Avatar
 
Join Date: Oct 2004
Location: CA, Rowland Hts.
Posts: 10,238
Likes: 0
Liked 0 Times in 0 Posts
lol, damn my gauges have a titanium finish on the sides. that's not gonna look right...
NgoRX8 is offline  
Old 09-08-2008, 12:34 AM
  #72  
Jedi Master
Thread Starter
iTrader: (7)
 
Jedi54's Avatar
 
Join Date: Mar 2004
Location: The Dark Side
Posts: 21,192
Liked 563 Times in 381 Posts
paint is your new best friend.
Jedi54 is online now  
Old 12-01-2008, 06:37 PM
  #73  
Registered
iTrader: (2)
 
djcharlee's Avatar
 
Join Date: Aug 2008
Location: San Diego, Ca
Posts: 180
Likes: 0
Liked 0 Times in 0 Posts
Question

How come this Oil Pressure sending unit in Pic 1


Is not the same as the one in the wiring picture?


I purchased the one in the top picture, will it work, and what is that copper clamp around it? Mine did not come with one.

Thanks in Advance.
djcharlee is offline  
Old 12-01-2008, 07:01 PM
  #74  
Jedi Master
Thread Starter
iTrader: (7)
 
Jedi54's Avatar
 
Join Date: Mar 2004
Location: The Dark Side
Posts: 21,192
Liked 563 Times in 381 Posts
never fear, Jedi is here!

dj: I'll call you.
Jedi54 is online now  
Old 12-01-2008, 07:07 PM
  #75  
Registered
iTrader: (2)
 
djcharlee's Avatar
 
Join Date: Aug 2008
Location: San Diego, Ca
Posts: 180
Likes: 0
Liked 0 Times in 0 Posts
LOL thanks man...
djcharlee is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: DIY: RB Gauge Pod + Nordskog Digital Gauges


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.