Notices
Series I Trouble Shooting This is the place to learn more about or discuss any issues you're having with your RX-8

Help! Is it my clutch bracket or a fluid leak? *Video*

Old 10-26-2012, 10:48 PM
  #1  
:D
Thread Starter
 
dwdgsi04's Avatar
 
Join Date: Feb 2008
Location: Seoul, South Korea
Posts: 115
Likes: 0
Received 0 Likes on 0 Posts
Unhappy Help! Is it my clutch bracket or a fluid leak? *Video*

So over the past few months my clutch pedal has been acting funny. It would be soft but fully functional, then after a random shift, the pedal would be super stiff. Then it would go back to being soft again. It did this for a few months until Monday when I started the car and the pedal stuck to the floor. I also couldn't get into gear. There is only pressure at the bottom inch or so of pedal travel. Doesn't want to disengage the clutch.

I tried turning the car off and putting it into gear and restarting. But even with the pedal fully depressed, the car wants to go forward as if I was easing off the clutch. It will do this until I've driving slowly in first gear for a few blocks, then I can drive normally, but the clutch pedal still sticks right above that inch or so of pressure.

After driving it for a few miles, the pedal will pop back up, but still have no resistance (as you can see in the video). Once I park and the car cools off, it's back to square one again.

I recorded what the pedal is doing after the car has been driven for a few miles. You can see how the pedal just drops with minimal pressure (I used my index finger to push it). But there is still that inch of pressure at the bottom. I didn't see any cracks or anything, but I did notice the clutch piston is wet. Not leaks around it or on the floor though. The brake fluid reservoir looks like it's between max and min, although it was kind of hard to be sure.

What do you guys think?


RX8 Clutch pedal issue - YouTube

Last edited by dwdgsi04; 10-26-2012 at 10:55 PM.
dwdgsi04 is offline  
Old 10-28-2012, 07:16 PM
  #2  
:D
Thread Starter
 
dwdgsi04's Avatar
 
Join Date: Feb 2008
Location: Seoul, South Korea
Posts: 115
Likes: 0
Received 0 Likes on 0 Posts
Ttt
dwdgsi04 is offline  
Old 10-28-2012, 09:10 PM
  #3  
Made in England
iTrader: (5)
 
wrightcomputing's Avatar
 
Join Date: Oct 2010
Location: Sarasota
Posts: 738
Likes: 0
Received 1 Like on 1 Post
Bleed the clutch line it sounds like you have a lot of air in the system also check the reservoir is near the max line. If it gets too low you will pump air in the clutch line and it will not work.
wrightcomputing is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
RXFEVER
RX-8 Parts For Sale/Wanted
38
08-29-2018 10:14 AM
Carbon8
RX-8's For Sale/Wanted
41
04-04-2016 04:05 PM
GARCIAC951
Series I Tech Garage
8
09-10-2015 07:17 PM
Anthony Kevin
New Member Forum
1
09-07-2015 07:36 PM
WranglerFan
New Member Forum
0
09-05-2015 06:24 PM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Help! Is it my clutch bracket or a fluid leak? *Video*


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.