rx8 won't start - RX8Club.com



New Member Forum A place for new members to get their feet wet

Reply
 
 
 
Thread Tools Search this Thread Rate Thread
Old 09-07-2015, 07:42 PM   #1
New Member
Thread Starter
 
Join Date: Sep 2015
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
rx8 won't start

Just changed the flywheel/clutch on my 04 rx8. 100k miles on it, the throw out bearing went bad and caused the front transmission cover to practically peel the metal off. I replaced that part, the cltuch, throw out bearing, new flywheel. Now the cars sat for about two weeks without being startedso the battery is weak pretty much junk at this point but I had a truck jumping while I tried to turn it over. So I finally get to turning this piece of **** car on and all it does is try to start with no end. I got some starter fluid and like a charm it started up right away but to my despair it turned off 4-5 seconds after being on. Seems like it only turned on whenever I sprayed the starter fluid into it. Also my clutch pedal does not fully engage the switch behind it. I had to press it in manually and turn the key to the on position to get anythi ng out of it. Can someone please give me advice on what I should do next before I take a sledge hammer to the car? Ive been carless for 1 month now, poured 1,500 into parts and now it's not even the cluck anymore god ******* knows wha yhe problem is. Im seriously contemplating just selling it for 1,000.
Anthony Kevin is offline   Reply With Quote
Old 09-07-2015, 08:36 PM   #2
Modulated Moderator
iTrader: (3)
 
dannobre's Avatar
 
Join Date: Feb 2004
Location: Smallville
Posts: 12,391
Thanked 30 Times in 28 Posts
Whoa.....did it start before the clutch Re/Re?

If it did it is likely something that you did while you had it apart...so check the connections on the tranny...and the starter

Did the throwout/clutch fork etc all go back together properly? If not that would account for your pedal issue
dannobre is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Help Wantingtoknow New Member Forum 24 12-15-2016 03:25 PM
Still shutting off after 1 to 2 hrs. of driving. Audio Concepts ATL New Member Forum 10 08-13-2016 02:58 PM
Rebuilt Engine Installed, Won't Start Davey's RX-8 Series I Trouble Shooting 0 07-28-2015 01:13 PM
RX-8 Won't start if drive hard- harithac New Member Forum 8 07-25-2015 05:21 PM
Is this the car for me? Peanutbuttertruffle New Member Forum 6 07-24-2015 08:49 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:32 PM.


All content Copyright 2017 by Internet Brands, Inc. We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.