2 SparkPlug Defoulers in O2 sensor and STILL have CEL! - RX8Club.com



Series I Tech Garage The place to discuss anything technical about the RX-8 that doesn't fit into any of the categories below.

Reply
 
 
 
Thread Tools Search this Thread Rate Thread
Old 11-13-2005, 05:34 PM   #1
Registered
Thread Starter
 
RX8SpdDmn's Avatar
 
Join Date: Oct 2004
Location: Florence, KY
Posts: 329
Thanks: 0
Thanked 0 Times in 0 Posts
2 SparkPlug Defoulers in O2 sensor and STILL have CEL!

I've added a second Spark Plug Defouler to my O2 sensor to bring it out of the exhaust stream, since I don't have a cat, and I STILL have a Check Engine Light!

I disconnected my battery for a while to reset the computer, but in about 19 miles, the CEL came back on.

Does anyone have any other suggestions???
This is really frustrating.
RX8SpdDmn is offline   Reply With Quote
Old 11-13-2005, 06:19 PM   #2
Ex- member.
 
adrian-1's Avatar
 
Join Date: Jan 2004
Location: Austin, TX
Posts: 1,694
Thanks: 0
Thanked 0 Times in 0 Posts
The O2 foolers don't work on our cars. A couple of members have had success with an O2 sim like the one sold here.
adrian-1 is offline   Reply With Quote
Old 11-13-2005, 06:28 PM   #3
Mod is as Mod does.
iTrader: (1)
 
StealthTL's Avatar
 
Join Date: Mar 2003
Location: WAAaaay North....
Posts: 7,084
Thanked 20 Times in 18 Posts
What made you think it would work......

The Casper foolers won't work, and the little extender pieces had NO chance of ever working in the first place.

The ECU tests the secondary sensor by sending a pattern of rich/lean pulses - if the pulsed results don't show up in the secondary data, it's CEL time.
Casper foolers can send a fake stream of "OK" data, but obviously can't relay any test pulses.
Plug extenders, (no matter how many used!) would have no effect, except possibly to trigger a "sensor heater failure" CEL.

S
StealthTL is online now   Reply With Quote
Old 11-13-2005, 06:31 PM   #4
Ex- member.
 
adrian-1's Avatar
 
Join Date: Jan 2004
Location: Austin, TX
Posts: 1,694
Thanks: 0
Thanked 0 Times in 0 Posts
Has anyone ever read what CEL is thrown up?
adrian-1 is offline   Reply With Quote
Old 11-13-2005, 10:01 PM   #5
Rotary Lover
 
RX8 Brunei's Avatar
 
Join Date: Nov 2004
Location: Brunei: Where Ricers show off their fugly rides
Posts: 467
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by RX8SpdDmn
I've added a second Spark Plug Defouler to my O2 sensor to bring it out of the exhaust stream, since I don't have a cat, and I STILL have a Check Engine Light!

I disconnected my battery for a while to reset the computer, but in about 19 miles, the CEL came back on.

Does anyone have any other suggestions???
This is really frustrating.
U better ask Rotarygod & other members about this. I afraid sooner or later u'll be encountering the problem that i had right now. be4 u replace with the catless pipe, did u ever reset ECU & KAM?? disconnecting the battery won't reset those two things. Juz my 2 cents.
RX8 Brunei is offline   Reply With Quote
Old 11-14-2005, 07:55 AM   #6
Registered
Thread Starter
 
RX8SpdDmn's Avatar
 
Join Date: Oct 2004
Location: Florence, KY
Posts: 329
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by RX8 Brunei
U better ask Rotarygod & other members about this. I afraid sooner or later u'll be encountering the problem that i had right now. be4 u replace with the catless pipe, did u ever reset ECU & KAM?? disconnecting the battery won't reset those two things. Juz my 2 cents.
No, I didn't reset those things. What would that have done and how could I do it?

Other people have had success with the spark plug defoulers, but, now I'm hearing it won't work? Is there NO way around this?
RX8SpdDmn is offline   Reply With Quote
Old 11-15-2005, 03:13 AM   #7
Koi no Ousama
iTrader: (25)
 
TeamRX8's Avatar
 
Join Date: Apr 2005
Posts: 19,699
Thanks: 0
Thanked 128 Times in 113 Posts
TeamRX8 is online now   Reply With Quote
Old 11-15-2005, 08:45 AM   #8
Registered
Thread Starter
 
RX8SpdDmn's Avatar
 
Join Date: Oct 2004
Location: Florence, KY
Posts: 329
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by TeamRX8
Mine does the same thing, except it brings the O2 sensor out even furthur. Can you rationalize why this one would be better?
Also, the one you showed doesn't have any flats on it to tighten up to the O2 sensor with. I could see you wrenching it in (via the flats on the O2 sensor) and then trying to take it out, only to have the adapter stuck in the midpipe, at which time you'd have to grind flats on it for a wrench to grab onto.
RX8SpdDmn is offline   Reply With Quote
Old 11-15-2005, 11:22 AM   #9
Koi no Ousama
iTrader: (25)
 
TeamRX8's Avatar
 
Join Date: Apr 2005
Posts: 19,699
Thanks: 0
Thanked 128 Times in 113 Posts
Quote:
Originally Posted by RX8SpdDmn
Mine does the same thing, except it brings the O2 sensor out even furthur. .

well apparently it doesn't and isn't. Did you follow the link to the original thread, it's not actually a positioning issue, PM the people who claim it works and see what they say, none of the naysayers have actually tried it

https://www.rx8club.com/series-i-tech-garage-22/solution-cel-midpipes-racepipes-64222/

Last edited by TeamRX8; 11-15-2005 at 11:29 AM.
TeamRX8 is online now   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Possible engine light fix for catless exhaust masonflint44 New Member Forum 6 11-30-2014 05:14 PM
Rough Idle Problem patrick_andraste NW RX-8 Forum 15 05-09-2012 10:06 AM
Spark Plug Wires Pinhy Series I Tech Garage 40 01-21-2010 06:58 AM
cat-less midpipe CEL trouble RX8SpdDmn Series I Tech Garage 2 10-24-2005 10:32 AM


Tags
battery, bmw, buy, change, defouler, defoulers, disconnect, engine, o2, plug, rx8, sale, sensor, spark, work

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:39 AM.


All content Copyright 2017 by Internet Brands, Inc.