Notices
Series I Trouble Shooting This is the place to learn more about or discuss any issues you're having with your RX-8

Radio won't turn on/ LCD wont light up/ AC won't work

Old 05-14-2014, 10:33 AM
  #51  
Registered
 
cnaude's Avatar
 
Join Date: Sep 2006
Posts: 33
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by TBOSE2GP View Post
Push the radio using both your thumbs under the volume control and everything should be back on.

I made sure the connection of the faceplate to the head unit was really tight. When I'm driving it will randomly shut off. I have to press on the faceplate exactly as you described to make it work.
cnaude is offline  
Old 01-26-2015, 04:53 AM
  #52  
Registered
 
Join Date: May 2005
Posts: 23
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by Phalkhan View Post
Then you''ll have to pull the whole unit out (at least a little) like cfm251 suggests. The problem with the radio is, that face plate and the radio are two seperate units. The face has little connections (almost like pins) that connect directly the the radio. If the radio isn't sucured properly, it can actually side back and disconnect from the face. You'd be surprised how little movement it takes for them to loose contact. Honestly, it seems like more of a hassel then it actually is to pull the radio.

I feel your frustration tho, it took me more than 2 hours to find the problem, but only took 10 mins to fix.
I did the no heat DIY as well and the radio didn't power on when I replaced it...this did the trick...thank you!
Steve-O is offline  
Old 04-21-2015, 03:12 PM
  #53  
New Member
 
Join Date: Apr 2015
Location: Palm Desert
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
I'm having the same problem too. Previous owner tried doing the ipod integration and it all got messed up. A/C works fine, but no radio, and no screen.


Originally Posted by WhiteCross View Post
Has anyone had an issue with the electronics in the faceplate going bad and causing just the stereo and LCD to go out but not the heating/ac controls?
brannjoe13b is offline  
Old 10-04-2015, 12:17 PM
  #54  
weeeeeeeeee
iTrader: (12)
 
ShellDude's Avatar
 
Join Date: Jun 2008
Location: Outside Philadelphia
Posts: 4,155
Received 18 Likes on 15 Posts
Man I'm going to miss this site. Pulled my grom ipd3+BT module today and no display / stereo.

Sure enough, one of the gold anchors for the placeplate screws had creeped out about 4-5 mm.

Re-recessed it and back in business.
ShellDude is offline  
Old 11-29-2015, 09:06 AM
  #55  
New Member
 
Join Date: Nov 2015
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
No a/c radio , Fans.

I have started my rx8 with jump leads but friend conncted leads wrong way. It runs, but lost a/c, radio, fans. HELP PLEASE
riddla1 is offline  
Old 12-16-2015, 06:44 PM
  #56  
New Member
 
Join Date: Dec 2015
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Radio wont work

Man ive tried every single thing everybody is saying here but nothing does anybody knows a tutorial video link i really need help with my radio
Pedro Lopez is offline  
Old 04-12-2016, 01:28 PM
  #57  
New Member
 
Join Date: Apr 2016
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
CA Thanks alot everyone

Originally Posted by TBOSE2GP View Post
Push the radio using both your thumbs under the volume control and everything should be back on.
So I bought this car '04. About 2 weeks ago, low miles but many little things. The AC/Radio would not work, I did as the above quote said to do. The radio and AC became functional. Albeit, I will need to take the faceplate off and reconnect the faceplate so it becomes permanent, but at least I know that I am not having to buy a new stereo and have an electrician inspect the issue since it is no longer a problem. You guys have thought of everything, and you guys rock
Now it's time for some tint in sunny So.Cal.
sgudino is offline  
Old 08-20-2016, 04:05 PM
  #58  
New Member
 
Join Date: Feb 2007
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Radio wont work
Man ive tried every single thing everybody is saying here but nothing does anybody knows a tutorial video link i really need help with my radio.

My faceplate was all broken, screen was out, but ac was working but no heat and radio was working with steering wheel controls, all the screws fell since all the plastic behind it broke, then i bought this aux (link below) that you connect behind the radio then all of a sudden miracle happened. Radio start to work with the screen on, aux was working fine, ac came back heater too. why? how? I don't know but i bought an extra faceplate too just in case I have to change it later.


https://www.amazon.com/Moonet-Interf...ywords=rx8+aux
XclR8 is offline  
Old 07-01-2017, 10:37 PM
  #59  
Registered
 
Join Date: Jul 2017
Posts: 11
Likes: 0
Received 1 Like on 1 Post
Radio A/C possessed

Hi everyone,

Just bought a 04 RX-8. The radio and A/C do not work right. The fan will blow when you turn it on, but nothing else. I activated the cruise control while driving and this turned the fan on somehow. Turned the cruise off, the fan went off. The LCD lights up but doesn't show anything. I push the rail power know, nothing. The A/C controls seem to light up randomly but don't do anything. When I push those buttons, no response. The car only vents in heat from the engine.

So in short, I have no A/C and no radio. This is a necessity to fix as I live in Florida and it's summertime, I need cold air and tunes! I have not removed anything.

Any idea what the cause is and how to fix it?
Zeiogage is offline  
Old 07-02-2017, 10:50 AM
  #60  
Mod is as Mod does.
iTrader: (1)
 
StealthTL's Avatar
 
Join Date: Mar 2003
Location: A Pacific Island.
Posts: 7,150
Received 33 Likes on 29 Posts
Why would anyone buy a car with no heat or radio, and no a/c in Florida?

Sounds like it has serious problems, best to sell it.
StealthTL is offline  
Old 07-02-2017, 10:53 AM
  #61  
Registered
 
Join Date: Jul 2017
Posts: 11
Likes: 0
Received 1 Like on 1 Post
Originally Posted by StealthTL View Post
Why would anyone buy a car with no heat or radio, and no a/c in Florida?

Sounds like it has serious problems, best to sell it.

The A/C works, there's just some type of glitch in the electronics. It turned on randomly but then turned off again. The car is great other than that.
Zeiogage is offline  
Old 07-02-2017, 06:32 PM
  #62  
Mod is as Mod does.
iTrader: (1)
 
StealthTL's Avatar
 
Join Date: Mar 2003
Location: A Pacific Island.
Posts: 7,150
Received 33 Likes on 29 Posts
Start lookin`....

Electrical.pdf
StealthTL is offline  
Old 07-04-2017, 12:16 PM
  #63  
Registered
 
Join Date: Jul 2017
Posts: 11
Likes: 0
Received 1 Like on 1 Post
Update:

Originally Posted by StealthTL View Post
Start lookin`....

Electrical.pdf
So to update: took the radio bezel off to figure out what was wrong. Turns out whatever idiot owned the car before me literally tried to rip to bezel off by hand, breaking the four screw bases that secure the bezel to the radio unit. This caused a bad connection.

I pulled all the broken pieces out, reconnected the wires and gently replace the face. Everything works fine now.

Now if I could only get the starting issue resolved
Zeiogage is offline  
Old 08-19-2017, 05:17 PM
  #64  
New Member
 
Join Date: Jul 2017
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Bumping this since I can't seem to post new threads yet.

My Rx8 is having an issue with the air conditioning where the lights on the climate control unit don't light up and the ambient temp section on the main display won't light either. The buttons still beep when you press them, but don't light up or function.

Already did the ac ac position test and it functions and reads 1-16 positions. I also took the whole panel apart and nothing seems loose.

I'm wondering if I need to replace the whole climate control unit or if a fuse I may not have checked could be the culprit.
mdc017 is offline  
Old 08-19-2017, 05:42 PM
  #65  
Registered
 
Join Date: Jul 2017
Posts: 11
Likes: 0
Received 1 Like on 1 Post
Originally Posted by mdc017 View Post
Bumping this since I can't seem to post new threads yet.

My Rx8 is having an issue with the air conditioning where the lights on the climate control unit don't light up and the ambient temp section on the main display won't light either. The buttons still beep when you press them, but don't light up or function.

Already did the ac ac position test and it functions and reads 1-16 positions. I also took the whole panel apart and nothing seems loose.

I'm wondering if I need to replace the whole climate control unit or if a fuse I may not have checked could be the culprit.
Is it only that light bar? Have you removed the bezel recently?
Zeiogage is offline  
Old 08-19-2017, 07:51 PM
  #66  
New Member
 
Join Date: Jul 2017
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by Zeiogage View Post
Is it only that light bar? Have you removed the bezel recently?
I guess I completely forgot to mention that the ac and front and rear defroster are not working. So it's not just a light problem.
mdc017 is offline  
Old 08-19-2017, 07:55 PM
  #67  
Registered
 
Join Date: Jul 2017
Posts: 11
Likes: 0
Received 1 Like on 1 Post
Originally Posted by mdc017 View Post
I guess I completely forgot to mention that the ac and front and rear defroster are not working. So it's not just a light problem.

Could be a fuse like you say or the main relay itself. Check the relay as well, it could have gone out.
Zeiogage is offline  
Old 08-19-2017, 10:56 PM
  #68  
New Member
 
Join Date: Jul 2017
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by Zeiogage View Post
Could be a fuse like you say or the main relay itself. Check the relay as well, it could have gone out.
Which fuses and relays should I check?
mdc017 is offline  
Old 08-20-2017, 01:30 AM
  #69  
Mod is as Mod does.
iTrader: (1)
 
StealthTL's Avatar
 
Join Date: Mar 2003
Location: A Pacific Island.
Posts: 7,150
Received 33 Likes on 29 Posts
The 'room' fuse, in the footwell, controls most of that kit.

A major cause of the Room fuse blowing is a short in the wiring to the vanity mirror, in the sunshade.
StealthTL is offline  
Old 08-20-2017, 01:00 PM
  #70  
New Member
 
Join Date: Jul 2017
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Checked all the fuses in the footwell with a multimeter. They all seem to be good. Could it be the actual climate control unit?
mdc017 is offline  
Old 08-22-2017, 11:58 AM
  #71  
New Member
 
Join Date: Jul 2017
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Any suggestions?
mdc017 is offline  
Old 09-05-2017, 03:43 PM
  #72  
New Member
 
Join Date: Jul 2017
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
I'm getting desperate. Louisiana isn't exactly a pleasant temperature this time of year
mdc017 is offline  
Old 09-17-2017, 01:15 PM
  #73  
New Member
 
Join Date: Jul 2017
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Made a little video to show you guys exactly what's going on. Fan speed is adjustable, the hvac section itself beeps, but the ambient temp and buttons do nothing. I've now replaced the climate control section of the unit and have the same issues. I'm completely lost as to what could be going on here.

https://youtu.be/KlXrzKRNXr8
mdc017 is offline  
Old 03-31-2019, 03:01 PM
  #74  
New Member
 
Join Date: Mar 2019
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
UK Aftermarket stereo install help needed

Hi guys so I've just bought a 06 rx8 I have been trying to install a aftermarket screen instead 9f the radio unit I've read a lot about needing a metra kit is this true ?
I have power and the screen works but I have no sound and I'm wondering if there is a way around this as I have the harness and the fascia ect that comes in the metra kit so don't want to spend silly money for just the extention cables and the Interface module I may need to mention I have the Bose speakers in there aswell
Loveday5371 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Audio Concepts ATL
New Member Forum
20
12-06-2018 07:32 AM
Crazy.8
Series I Interior, Audio, and Electronics
3
04-18-2017 03:17 PM
Nisaja
New Member Forum
2
08-06-2015 01:27 AM
MolecularConcept
New Member Forum
15
08-05-2015 04:43 PM
MarkX
New Member Forum
3
07-31-2015 07:50 AM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Radio won't turn on/ LCD wont light up/ AC won't work


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.