Notices
Series I Trouble Shooting This is the place to learn more about or discuss any issues you're having with your RX-8

Engine Misfire on NEW ENGINE

Old 07-13-2011, 01:13 PM
  #1  
Brillant Black Pilot
Thread Starter
 
Join Date: Oct 2007
Location: Lewisville, TX
Posts: 103
Likes: 0
Received 0 Likes on 0 Posts
TX Engine Misfire on NEW ENGINE

Some of you might have been in my thread last month where I got my engine replaced under warranty within 18 miles of the warranty expiring. Anyway - now, for the last two days, the engine has been misfiring BADLY. It just happened out of nowhere. I've tried octane booster, different gas, etc. It's been getting worse and worse and now the car can't idle without stalling. On top of that, it's smoking really bad. Going to park it and take it to the shop possibly when I get some cash, but does anyone have any idea what might be causing it? Do they replace the plugs and wires when they give you a new engine ?
coilback is offline  
Old 07-13-2011, 01:50 PM
  #2  
Time for boost...
iTrader: (24)
 
RX8Soldier's Avatar
 
Join Date: Jun 2010
Location: Canada
Posts: 5,413
Likes: 0
Received 13 Likes on 12 Posts
No, they don't replace plugs and coils.
Maybe bring it back to the shop that replaced the engine for diagnosis?
RX8Soldier is offline  
Old 07-13-2011, 03:14 PM
  #3  
Registered
 
lycanthrope's Avatar
 
Join Date: Dec 2008
Location: mason
Posts: 51
Likes: 0
Received 0 Likes on 0 Posts
wait so they DONT replace your plugs when you get a new engine? ive got to say im a little shocked. also it might be worth while checking to see if all of the plug wires are connected to the plugs and coils right. i had a problem where one of mine was a little loose and was making the car stall and misfire alot. just an idea.
lycanthrope is offline  
Old 07-13-2011, 03:26 PM
  #4  
Verbose SuperMod
iTrader: (2)
 
Join Date: Oct 2007
Location: Pacific Northwest
Posts: 16,683
Likes: 0
Received 137 Likes on 76 Posts
If you are within the 60k powertrain warranty, typically the dealer will replace the plugs, wires, coils along with the engine and other gaskets and stuff. Typically, but not always.

If you are outside the 60k powertrain warranty, but within the 100k engine core warranty, they will typically NOT replace coils, plugs, and wires, just reusing your old stuff. They may insist that you change them, but will charge you for them. The other items that HAVE to get changed with the engine, but are not part of the engine itself (gaskets and fluids and stuff), you will normally get charged for. The warranty only covers the engine and the labor.

That being said, I'd recommend putting in new coils, wires, and plugs either right before or right after an engine change, and not paying the dealer's crazy costs to do it.


OP, I'd agree that it's probably a disconnected plug wire. Park the car, turn the wheel completely to the right, then reach in behind the driver side front wheel. The plugs are right there in the side of the engine. Just make sure the plug wires are all seated on the plugs firmly. Should 'pop' on.
RIWWP is offline  
Old 07-13-2011, 03:55 PM
  #5  
Registered
iTrader: (2)
 
Easy_E1's Avatar
 
Join Date: Sep 2005
Location: Bellevue WA
Posts: 7,675
Likes: 0
Received 4 Likes on 2 Posts
Is the check engine light on?

If this engine is only a month old. Take it back to the dealer and see what's going on.

If they suggest plugs and coils. Buy them some where and install them your self.

Do what RIWWP suggested and at least check the plug connections.
Easy_E1 is offline  
Old 07-13-2011, 04:15 PM
  #6  
Official Post Whore
iTrader: (2)
 
pdxhak's Avatar
 
Join Date: Jan 2003
Location: Portland,OR
Posts: 10,459
Received 26 Likes on 22 Posts
Take it back to the dealership and have them take a look. The reman motor is under warranty.

FYI

Some dealership will provide new plugs and some will not. My dealership said I needed new plugs and wires and they wanted to charge me. I provided both and saved a few hundred dollars.
pdxhak is offline  
Old 07-14-2011, 12:58 AM
  #7  
I HATE SPEEDBUMPS!
 
monchie's Avatar
 
Join Date: Nov 2007
Location: Las Vegas, NV
Posts: 8,549
Likes: 0
Received 0 Likes on 0 Posts
The re-manufactured engine you just got should be warrantied for 1 year (if i'm not mistaken). The smart thing to do is bring it back to the dealership who installed it and have them check out the problem. You might need to replace the plugs, coils, and wires.
monchie is offline  
Old 07-14-2011, 06:48 AM
  #8  
Brillant Black Pilot
Thread Starter
 
Join Date: Oct 2007
Location: Lewisville, TX
Posts: 103
Likes: 0
Received 0 Likes on 0 Posts
I took it to Town North Mazda in Richardson instead of Classic where the work was originally done. If you were part of the original thread when I replaced my engine, you'll understand why (they were CONSTANTLY trying to rip me off). Town North said they would honor any warranties on the engine itself, but I'm thinking it's going to be coils or plugs then since it was just fixed under the 100k warranty. I live in apartment so I have no way to work on the car here (they get really pissy about that), so I'll either have to get the dealer to do it or find somewhere else around here that can do it.
coilback is offline  
Old 07-14-2011, 07:06 AM
  #9  
Verbose SuperMod
iTrader: (2)
 
Join Date: Oct 2007
Location: Pacific Northwest
Posts: 16,683
Likes: 0
Received 137 Likes on 76 Posts
Coils and plugs can be done with no indication that you are working on the car other than a raised hood for half an hour or so. It gets tight getting the plugs without taking off the driver's front wheel, but entirely doable by just turning the wheel to the whole way to the right.

But, check with the Texas people local to you, and see if there is an owner nearby that will assist you, and do it at their place.
RIWWP is offline  
Old 07-14-2011, 05:19 PM
  #10  
Brillant Black Pilot
Thread Starter
 
Join Date: Oct 2007
Location: Lewisville, TX
Posts: 103
Likes: 0
Received 0 Likes on 0 Posts
Got the word back - 3 coils out of 4 were dead. Managed to drive that thing back home on one plug apparently. Anyway, got someone who is going to cover it for me this time as a late bday present, so just letting the dealer deal with it.
coilback is offline  
Old 07-14-2011, 05:24 PM
  #11  
Boosted Kiwi
iTrader: (2)
 
Brettus's Avatar
 
Join Date: Apr 2006
Location: Y-cat-o NZ
Posts: 18,392
Received 251 Likes on 193 Posts
Originally Posted by coilback View Post
Got the word back - 3 coils out of 4 were dead. Managed to drive that thing back home on one plug apparently. Anyway, got someone who is going to cover it for me this time as a late bday present, so just letting the dealer deal with it.
well given your username , I'm surprised you didn't take them back strait away ...
Brettus is offline  
Old 07-14-2011, 05:41 PM
  #12  
Brillant Black Pilot
Thread Starter
 
Join Date: Oct 2007
Location: Lewisville, TX
Posts: 103
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by Brettus View Post
well given your username , I'm surprised you didn't take them back strait away ...
That's a good one, heh. Yeah, it's actually my band's name, but makes sense it should've..ha.
coilback is offline  
Old 07-29-2014, 02:54 PM
  #13  
Registered
 
danielmended's Avatar
 
Join Date: Dec 2011
Location: wilkes barre pa
Posts: 30
Likes: 0
Received 0 Likes on 0 Posts
Need some feedback..

Mine is having the same problem .. My car still in the shop Brand-new coils spark plug wires cat and engine.. I Still get a misfire code.. So now they have a engineer from Japan looking at it.. Thank goodness I'm still under warranty... .. But I'm at a lost.. Any ideas.. Any one.... 2008 rx8 40th anniversary no mods all stock.. 33,600 miles on it..
danielmended is offline  
Old 07-29-2014, 03:07 PM
  #14  
Registered
iTrader: (46)
 
9krpmrx8's Avatar
 
Join Date: Jan 2007
Location: San Antonio, Texas
Posts: 33,743
Received 344 Likes on 277 Posts
Search reset NVRAM.
9krpmrx8 is offline  
Old 07-29-2014, 03:10 PM
  #15  
Registered
iTrader: (1)
 
Join Date: Sep 2013
Posts: 78
Likes: 0
Received 0 Likes on 0 Posts
daniel, have you tried the 20 stomp reset? After I had my new engine in this year i kept getting mis fire codes then I pulled over did the 20 stomp test and boom no more misfires.
westgman is offline  
Old 07-29-2014, 03:20 PM
  #16  
Registered
 
j9fd3s's Avatar
 
Join Date: May 2003
Posts: 1,382
Likes: 0
Received 3 Likes on 3 Posts
Originally Posted by RIWWP View Post
Coils and plugs can be done with no indication that you are working on the car other than a raised hood for half an hour or so. It gets tight getting the plugs without taking off the driver's front wheel, but entirely doable by just turning the wheel to the whole way to the right.

But, check with the Texas people local to you, and see if there is an owner nearby that will assist you, and do it at their place.
i did coils by the side of the road, once, takes under 10minutes.

plugs take longer, maybe you can pretend you got a flat tire or something
j9fd3s is offline  
Old 07-29-2014, 09:03 PM
  #17  
Out of NYC
iTrader: (1)
 
nycgps's Avatar
 
Join Date: Jun 2005
Location: Planet Earth
Posts: 19,866
Received 12 Likes on 12 Posts
Originally Posted by j9fd3s View Post
i did coils by the side of the road, once, takes under 10minutes.

plugs take longer, maybe you can pretend you got a flat tire or something
+1

well, took me longer than 10 mins, maybe 20, simply because a lot of rx8 that i had worked with had some sort of corrosion at the bracket, so I gotta be extremely careful, snapped one of the coil holding bolt once, so I just gave him mine and got myself a S2 bracket

I can replace plugs without removing anything, did it from the top, it's a bitch, but doable.
nycgps is offline  
Old 07-30-2014, 01:20 AM
  #18  
RX8Club.com Sponsor
iTrader: (6)
 
Join Date: Mar 2014
Location: Metuchen, NJ
Posts: 127
Received 1 Like on 1 Post
I recommend new plugs, wires, and coils with each motor job. Every time someone doesn't listen then end up with a problem later down the road. Dealer typically doesn't change anything.
IRPerformance is offline  
Old 07-31-2014, 06:04 AM
  #19  
Registered
 
danielmended's Avatar
 
Join Date: Dec 2011
Location: wilkes barre pa
Posts: 30
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by westgman View Post
daniel, have you tried the 20 stomp reset? After I had my new engine in this year i kept getting mis fire codes then I pulled over did the 20 stomp test and boom no more misfires.
.. Yes... Mazda telling me a magnetic valve is staying open.. Causing the misfire... So they are taking it apart again... An they said it might be the PCM .. Has anyone else had this problem ????
(History) when the car went to Mazda it went for a clogged cat... I had it towed there.. With in the last year I've changed the ignition twice ,coils plugs wires... Was getting a misfire .. . Then it went away.. Haven't seen it since February... then Clogged cat code last month. So I had it towed.. So.. I've read all the forms and haven't encountered anyone with the same problem...
danielmended is offline  
Old 07-31-2014, 10:35 AM
  #20  
RX8Club.com Sponsor
iTrader: (6)
 
Join Date: Mar 2014
Location: Metuchen, NJ
Posts: 127
Received 1 Like on 1 Post
Originally Posted by danielmended View Post
.. Yes... Mazda telling me a magnetic valve is staying open.. Causing the misfire... So they are taking it apart again... An they said it might be the PCM .. Has anyone else had this problem ????
(History) when the car went to Mazda it went for a clogged cat... I had it towed there.. With in the last year I've changed the ignition twice ,coils plugs wires... Was getting a misfire .. . Then it went away.. Haven't seen it since February... then Clogged cat code last month. So I had it towed.. So.. I've read all the forms and haven't encountered anyone with the same problem...
Daniel it sounds like you just need to take it to an independent repair shop that was experience with these cars. Speed 1 is in PA. In NJ you have myself (IRP), JPR, and ARP.
IRPerformance is offline  
Old 07-31-2014, 10:37 AM
  #21  
FULLY SEMI AUTOMATIC
iTrader: (9)
 
200.mph's Avatar
 
Join Date: Aug 2008
Location: BALLS DEEP
Posts: 5,012
Received 627 Likes on 551 Posts
irp, hes still under warranty but i agree most mazda "techs" dont know **** about rotaries
200.mph is offline  
Old 07-31-2014, 10:43 AM
  #22  
Registered
iTrader: (46)
 
9krpmrx8's Avatar
 
Join Date: Jan 2007
Location: San Antonio, Texas
Posts: 33,743
Received 344 Likes on 277 Posts
Magnetic valve?
9krpmrx8 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Jaco Greyling
New Member Forum
3
01-06-2019 08:39 AM
vapor2
West For Sale/Wanted
1
09-15-2015 06:38 PM
madrotor
New Member Forum
2
07-26-2015 12:06 PM
Rx8Lovin
New Member Forum
4
07-25-2015 08:39 PM
dbarber
Series I Trouble Shooting
14
07-25-2015 01:34 PM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Engine Misfire on NEW ENGINE


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.