PAC-SWI PS in 2006? - RX8Club.com

Notices

PAC-SWI PS in 2006?

Reply

 
 
 
Old 01-03-2010, 09:04 AM
  #1  
Registered
Thread Starter
 
Join Date: May 2009
Location: Norcross, GA
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
PAC-SWI PS in 2006?

So after searching the forum to no avail, I decided to ask. According to PAC's website, and Crutchfield, this steering wheel adapter works ONLY in the 2004 8's. Has anyone installed it in a 2006 and if so are there any special install instructions since according to PAC this one is only for the 04's? I did find several instances on the forum of people mentioning an install, but most of them don't have the year of their car in the post or signature, and the ones that did were 04's. Thanks, and Happy 2010!

Last edited by femftal; 01-04-2010 at 10:03 AM.
femftal is offline  
Reply With Quote
Old 01-03-2010, 07:21 PM
  #2  
Registered
iTrader: (4)
 
Join Date: Apr 2008
Location: Boston
Posts: 151
Thanks: 0
Thanked 0 Times in 0 Posts
it's not only for 2004, it should work fine in the 04-08 series (probably in the 09-10 series as well).
bmak is offline  
Reply With Quote
Old 01-03-2010, 09:05 PM
  #3  
The Chief
iTrader: (7)
 
jskup1's Avatar
 
Join Date: Jun 2005
Location: Virginia Beach, VA
Posts: 827
Thanks: 0
Thanked 0 Times in 0 Posts
It works just fine in my '05.
jskup1 is offline  
Reply With Quote
Old 01-03-2010, 10:26 PM
  #4  
User and Abuser
iTrader: (3)
 
firebirdude's Avatar
 
Join Date: Nov 2006
Location: Sunshine State
Posts: 3,099
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by bmak View Post
it's not only for 2004, it should work fine in the 04-08 series (probably in the 09-10 series as well).
QFT
firebirdude is offline  
Reply With Quote
Old 01-04-2010, 04:26 PM
  #5  
Registered User
 
Join Date: Jan 2010
Location: Pensacola, FL
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Works fine in 07

Just installed (1/3/10) in my 07 with an avh3100 dvd. Instructions aren't that great but after reading one too many forums on this topic I finally got it right. Talked with Pac-Audio and the tech said that the pac swi-ps for Mazda works for all Mazda's with the 24 pin connector which should be all RX8's 05 and up. I believe the 04 has a 16 pin connector. Bought the switch (new blue box model) from Crutchfield.

Wiring: White goes to pin 9 (green w/ white stripe), red goes to 12v Switched (should be the only wire on the same row as the large black ground, non-Bose factory harness), black connects with pin 10 wire (red w/ black stripe) and both black and pin 10 wires need to tee in to large black ground wire on the factory harness.

After you get the wiring right, programming takes less than a minute.

Last edited by mikekey; 01-04-2010 at 04:34 PM.
mikekey is offline  
Reply With Quote
Old 01-04-2010, 06:03 PM
  #6  
User and Abuser
iTrader: (3)
 
firebirdude's Avatar
 
Join Date: Nov 2006
Location: Sunshine State
Posts: 3,099
Thanks: 0
Thanked 0 Times in 0 Posts
I didn't find anything tough about it. Wire up power and use the white wire for signal. Done and done.
firebirdude is offline  
Reply With Quote
Old 01-05-2010, 01:08 PM
  #7  
Resident Cool Guy
iTrader: (2)
 
boarderjosh10's Avatar
 
Join Date: Jul 2009
Location: MN and AZ
Posts: 171
Thanks: 0
Thanked 0 Times in 0 Posts
Slightly off topic, but I am trying to do this too. Where is the cable I am supposed to tap into? I didn't see one behind the stereo.
boarderjosh10 is offline  
Reply With Quote
Old 01-05-2010, 04:22 PM
  #8  
Registered User
 
Join Date: Jan 2010
Location: Pensacola, FL
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Not sure I understand what your asking. The only cable to deal with is the wired remote cable on the other side of the pac swi. If this is what you mean, there should be a 3.5mm socket on the back of the aftermarket radio that the cable plugs into.
mikekey is offline  
Reply With Quote
Old 01-05-2010, 11:43 PM
  #9  
Resident Cool Guy
iTrader: (2)
 
boarderjosh10's Avatar
 
Join Date: Jul 2009
Location: MN and AZ
Posts: 171
Thanks: 0
Thanked 0 Times in 0 Posts
I have the PAC device but I cant find what I plug into inside the car, I know where to plug in on the deck but not the part in the car (Ihave an 04 btw)
boarderjosh10 is offline  
Reply With Quote
Old 01-06-2010, 08:22 AM
  #10  
User and Abuser
iTrader: (3)
 
firebirdude's Avatar
 
Join Date: Nov 2006
Location: Sunshine State
Posts: 3,099
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by boarderjosh10 View Post
I have the PAC device but I cant find what I plug into inside the car, I know where to plug in on the deck but not the part in the car (Ihave an 04 btw)
It's color to color with the corksport kit. I could only assume it's the same with the Metra kit. Red to ignition, Black to ground, and white signal wire on the Pac unit to white in the Metra harness. Be sure you're not using the solid white that's next to the white/black. This is the front right speaker + wire. Not what you're looking for.
firebirdude is offline  
Reply With Quote
Old 01-06-2010, 10:30 AM
  #11  
Registered
iTrader: (4)
 
Join Date: Apr 2008
Location: Boston
Posts: 151
Thanks: 0
Thanked 0 Times in 0 Posts
IIRC, the metra kit doesn't have a lead for Pin 9, you'll need to tap this wire on the other side of the connection.
bmak is offline  
Reply With Quote
Old 01-06-2010, 11:15 AM
  #12  
User and Abuser
iTrader: (3)
 
firebirdude's Avatar
 
Join Date: Nov 2006
Location: Sunshine State
Posts: 3,099
Thanks: 0
Thanked 0 Times in 0 Posts
Metra cheaping out once again...
firebirdude is offline  
Reply With Quote
Old 01-06-2010, 03:25 PM
  #13  
Registered User
 
Join Date: Jan 2010
Location: Pensacola, FL
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Kinda disappointed with the metra wiring as well. Throwing in a couple extra wires wouldn't be a tall task. That, and my display freaks out and clock cant keep time even though I supposedly have the latest software.

Getting the pac connected to the factory harness wires was a tedious venture, at least for me. Ended up just cutting pin 9/10 wires and soldering extra wire to them since they aren't connecting to anything on the metra harness. Cringed when I did it, but made it much easier to work with and gave me a few more locations I could mount the pac.

boarderjosh- is your factory harness 14 pin or 24 pin?
mikekey is offline  
Reply With Quote
Old 01-06-2010, 08:32 PM
  #14  
I made some poos
iTrader: (1)
 
Juice's Avatar
 
Join Date: Sep 2005
Location: Pittsburgh, PA
Posts: 841
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by mikekey View Post
Kinda disappointed with the metra wiring as well. Throwing in a couple extra wires wouldn't be a tall task. That, and my display freaks out and clock cant keep time even though I supposedly have the latest software.

Getting the pac connected to the factory harness wires was a tedious venture, at least for me. Ended up just cutting pin 9/10 wires and soldering extra wire to them since they aren't connecting to anything on the metra harness. Cringed when I did it, but made it much easier to work with and gave me a few more locations I could mount the pac.

boarderjosh- is your factory harness 14 pin or 24 pin?
All the RX-8 Harnesses, Bose or base are 24 Pin.

My MX-5 has the same 24 pin connector, luckily the HVAC controls aren't integrated. What I did when I installed my DDX-514 and PAC SWI-JACK was to buy an extra Metra Harness, then take the pins out of one of them giving me a full harness to use. That way I didn't have to cut/splice any factory wiring.
Juice is offline  
Reply With Quote
Old 01-08-2010, 03:25 PM
  #15  
Registered User
 
Join Date: Jan 2010
Location: Pensacola, FL
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by Juice View Post
All the RX-8 Harnesses, Bose or base are 24 Pin.

My MX-5 has the same 24 pin connector, luckily the HVAC controls aren't integrated. What I did when I installed my DDX-514 and PAC SWI-JACK was to buy an extra Metra Harness, then take the pins out of one of them giving me a full harness to use. That way I didn't have to cut/splice any factory wiring.
Good thinking.

For some reason I was under the impression that 04's had the 14 pin. Oh well.
mikekey is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
WranglerFan
New Member Forum
4
11-05-2017 10:35 AM
Shankapotamus3
Series I Trouble Shooting
26
11-06-2016 09:26 AM
JCTaylor
New Member Forum
3
09-30-2015 08:31 PM
Counter_Glockwise
New Member Forum
2
09-21-2015 07:51 PM
Tsurugi
New Member Forum
0
09-07-2015 09:27 PM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: PAC-SWI PS in 2006?


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.