RX8Club.com
Register Photo Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read RX8 Live!Used CarsVendor Directory

Go Back   RX8Club.com > Series I Tech & Performance > Series I Trouble Shooting
Sign in using an external account
Register Forgot Password?

Welcome to RX8Club.com!
Welcome to RX8Club.com,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join RX8Club.com today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 03-05-2008, 07:29 PM   #1
Registered User
 
Trader Score: (0)
Join Date: Jan 2006
Location: DAYTON, OH
Posts: 48
Send a message via AIM to SSRX8NC
Help! Oil smell, smoke, and sputtering!

Over the past couple days I have noticed that my car sputters and shakes a little whenever I try and get on the throttle. There is not a huge power loss, but it does seem to get worse by the day... Anyway, today on my way home I noticed a little bit of smoke coming from the engine and a rough idle. The idle is not rough all the time, more like every 15-20 secs. Also when I inspected the engine, I noticed that there was old oil around the top of the engine (in the black plastic squares) which is strange bc I always try and keep my engine clean...I'm pretty sure that I know what's coming, but does anyone have an idea of what it might be?


Thanks in advance for your help!

Matt
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on RX8Club.com!
__________________
04' Winning Blue - Mazdaspeed CAI (For SALE), Canzoomer 1.1 (For Sale), Greddy E-manage Blue (SOLD), Clear Corners, Tein Springs, Exedy clutch, Turbo XS Catback, SR Motorsports HighFlow Cat, Greddy Turbo, HKS Super SQV BOV, Cobb Accessport.
SSRX8NC is offline   Reply With Quote
Old 03-05-2008, 09:09 PM   #2
Mu ha.. ha...
 
Razz1's Avatar
 
Trader Score: (0)
Join Date: Aug 2004
Location: Cali
Posts: 14,283
if its comming from the engine, sounds like you need a new one.

if its comming from the back its your cat.

check your cat.
__________________


Boy... am I beautiful!
Razz1 is offline   Reply With Quote
Old 03-06-2008, 03:23 PM   #3
Registered User
 
Trader Score: (0)
Join Date: Jan 2006
Location: DAYTON, OH
Posts: 48
Send a message via AIM to SSRX8NC
I don't have a Cat. I'm running Catless at the moment. When I check the oil there is a "white milky substance" which Mazda addressed for me last time with the dip stick fix, but since that has been fixed... I'm assuming this is bad news. Drove great this morning...Just a few stutters at mid RPM. No smoke, but still getting the smell...It seems like it only smokes when I run it really hard. It's definitely coming somewhere from the top of the engine, but I can see the source...Ideas?

MD
__________________
04' Winning Blue - Mazdaspeed CAI (For SALE), Canzoomer 1.1 (For Sale), Greddy E-manage Blue (SOLD), Clear Corners, Tein Springs, Exedy clutch, Turbo XS Catback, SR Motorsports HighFlow Cat, Greddy Turbo, HKS Super SQV BOV, Cobb Accessport.
SSRX8NC is offline   Reply With Quote
Old 03-06-2008, 03:26 PM   #4
One Shot One Kill
 
xsnipersgox's Avatar
 
Trader Score: (0)
Join Date: Jan 2008
Location: Austin, Texas Baby
Posts: 1,427
oil being sucked in through the intake? leak of death? bad coil/spark? no idea XD...
xsnipersgox is offline   Reply With Quote
Old 03-06-2008, 04:03 PM   #5
Run and Tell That...
 
04_Mica Mazda's Avatar
 
Trader Score: (0)
Join Date: Apr 2007
Location: South Coast, Massachusetts
Posts: 236
Send a message via AIM to 04_Mica Mazda Send a message via Yahoo to 04_Mica Mazda
not trying to thread jack, but i have a very similar problem.. i experienced some engine sputtering at ~2000rpms a few days ago, then started to get flashing CEL... went to downshfit the car, but when i pressed down on the clutch, the engine died. wouldnt start for a while.. thought flooded engine... used the techniques here on this site (luckily i had a laptop handy) removed the fuel relay in the fuse box, cranked the car, then replaced the fuse and it started up with an EXTREMELY rough idle... i limped the car home... the car has no get up at all, esp. when its stopped (i.e. red light/stop sign) sounds awful, engine vibrations, steady CEL at idle, flashing CEL when driving.. no codes yet, as i dont have any software or way to get the car to dealership for a few days. ther are no oil leak anywhere... well, that i can see, cat or top of engine look okay.. so i, myslef am quite baffled by this... any suggestions that i can take to the dealership, other than bring my checkbook.
__________________
04 Nordic Green RX-8 6 Speed: AEM CAI, Magnecor KV85 Ignition Plugs, A/P Underdrive Pulley, A/P Exhaust w/Midpipe, TC Sportline Rear Strut Tower Bar, JDM Clear Corners, Front and Rear Rotary Accents, Fog Light Re-Wire. Koni Yellows, H&R Springs
04_Mica Mazda is offline   Reply With Quote
Old 03-06-2008, 04:03 PM
RX8Club
Mazda RX8




Paid Advertisement


 
 
 
Reply

Tags
blinking, blue, burning, car, cel, dies, emanage, engine, idling, oil, rough, rx8, smell, smokes, spuddering, sputtering, sputters

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dark nasty smoke = burning oil ??? (plz help) nez Series I Tech Garage 4 10-29-2006 01:17 PM
Oil on Air filter + Strong fuel smell on oil dipstick!!! Cangri04R8 Series I Trouble Shooting 2 10-11-2006 11:46 AM
Poor MPG/gear oil smell after trans oil change toddman Series I Tech Garage 8 08-27-2006 05:44 PM
Worried: smoke.... and oil consumption toxin440 RX-8 Discussion 24 06-27-2006 09:52 PM


All times are GMT -5. The time now is 09:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
All content Copyright 2007 by Internet Brands, Inc.
Emails Backup