Notices
Series I Trouble Shooting This is the place to learn more about or discuss any issues you're having with your RX-8

2004 RX8 code troubleshooting P0455 + P2096

Old 03-11-2013, 03:42 PM
  #1  
rx8duder55
Thread Starter
 
Join Date: Apr 2011
Location: Oregon
Posts: 1
Likes: 0
Liked 0 Times in 0 Posts
2004 RX8 code troubleshooting P0455 + P2096

2004 RX8, 72,xxx miles w/P0455 (gross leak) and P2096 codes found with my OBDII reader and Torque pro app.

Spark plugs have failed twice in it's life, 1st time due to accidental overfill of oil, which resulted in some "head gasket like" smoke coming out the tail pipe symptoms. Plugs failed again in the fall of 2012, had been about 35,000 miles, so due to replace anyways.

Car is currently experiencing symptoms of delayed acceleration and power loss after extended periods of driving on the freeway (30min-1hr). Symptoms do not fully subside until the car is allowed to completely cool down. Very noticeable whooshing/whirring noise during acceleration after the car has been driven for extended periods of time. The only other time I have noticed this noise is when the car is cold. Otherwise it seems fine around town.

Due to symptoms, I am unsure of what these codes might mean. I have replaced the gas cap as a precaution, but I am thinking I might have a faulty catalytic converter due to my former plug failures, not to mention I may have a solenoid valve problem since my car continually throws P0455 (gross leak) codes at me even after replacing the cap. Other options I have ran through are a possible exhaust leak (whooshing/whirring noise?) but I am unsure.

I will get underneath the car in 2 weeks time (March 23, 2013) to install an aftermarket exhaust and hi-flow cat pipe (turboxs), and will see what happens to symptoms. Thankfully this was a planned upgrade I decided to do sooner to see if this would fix my problem. If it does not help it will only serve to help me further narrow down what the problem may be.

Any knowledge or wisdom on this delayed acceleration/loss of power after driving for prolonged periods would be much appreciated in the meantime! I have scoured forums and can't seem to find much about this issue.

Thanks in advance.
rx8duder55 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dweezil22
NE For Sale/Wanted
12
09-09-2015 10:50 AM
Mr.Durden
RX-8's For Sale/Wanted
4
08-12-2015 02:21 PM
Panthersn
New Member Forum
1
08-03-2015 08:53 PM
RX7.9
New Member Forum
0
07-20-2015 12:01 PM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: 2004 RX8 code troubleshooting P0455 + P2096


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.