Notices
Series I Tech Garage The place to discuss anything technical about the RX-8 that doesn't fit into any of the categories below.

Big problem with my 8! please help me!

Old 04-10-2006, 08:52 PM
  #1  
Registered User
Thread Starter
 
abrahamsaca's Avatar
 
Join Date: Aug 2005
Posts: 28
Likes: 0
Received 0 Likes on 0 Posts
Angry Big problem with my 8! please help me!

i posted a new thread so that the people dont get confused...

i live in el salvador and the mazda dealer here doesnt bring rx8 so i bought it used in the US and brought it here...

....the problem i have, is that the security indicator its on and the car doesnt start, and we have to put the key in start and then turn off and back again several ti?mes to the car finally starts....we have tried with both keys and it doesnt works..... the next day we have to do the same thing.. the mechanics said that the problem is the ECU...

PLEASE HELP ME!


abrahamsaca is offline  
Old 04-10-2006, 09:26 PM
  #2  
RX8 ADDICTED!!!
 
Tigster's Avatar
 
Join Date: Aug 2003
Posts: 1,108
Likes: 0
Received 0 Likes on 0 Posts
Are you pushing the clutch in when you turn the key?
Tigster is offline  
Old 04-10-2006, 09:48 PM
  #3  
Registered User
Thread Starter
 
abrahamsaca's Avatar
 
Join Date: Aug 2005
Posts: 28
Likes: 0
Received 0 Likes on 0 Posts
yes.. the car is totally block..
abrahamsaca is offline  
Old 04-10-2006, 09:49 PM
  #4  
Registered User
Thread Starter
 
abrahamsaca's Avatar
 
Join Date: Aug 2005
Posts: 28
Likes: 0
Received 0 Likes on 0 Posts
the engine doesnt makes sound..
abrahamsaca is offline  
Old 04-10-2006, 10:30 PM
  #5  
Registered User
Thread Starter
 
abrahamsaca's Avatar
 
Join Date: Aug 2005
Posts: 28
Likes: 0
Received 0 Likes on 0 Posts
nobody can help me??
abrahamsaca is offline  
Old 04-10-2006, 10:32 PM
  #6  
The burninator
 
alcimedes's Avatar
 
Join Date: Aug 2005
Posts: 410
Likes: 0
Received 0 Likes on 0 Posts
If your'e describing the problem correctly, then it does sound like the ECU. It sounds like the car's security system isn't being activated properly.
alcimedes is offline  
Old 04-10-2006, 10:42 PM
  #7  
Registered User
Thread Starter
 
abrahamsaca's Avatar
 
Join Date: Aug 2005
Posts: 28
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by alcimedes
If your'e describing the problem correctly, then it does sound like the ECU. It sounds like the car's security system isn't being activated properly.


..and what can i do??
abrahamsaca is offline  
Old 04-10-2006, 11:08 PM
  #8  
The burninator
 
alcimedes's Avatar
 
Join Date: Aug 2005
Posts: 410
Likes: 0
Received 0 Likes on 0 Posts
Normally I'd say take it to a dealer, but it sounds like you don't have any down there. Not sure what you can do. At this point I think you should contact Mazda North America and ask them what next. Not much anyone here can do for you.
alcimedes is offline  
Old 04-12-2006, 09:39 PM
  #9  
Registered User
 
Join Date: Jan 2006
Location: Walnut Grove CA
Posts: 196
Likes: 0
Received 0 Likes on 0 Posts
He didn't say there were no dealers there, just that the dealers there don't sell the RX-8. How similar is our security system to that of other Mazda cars? Does the high-end Mazda 6 have a comparable electronic theft deterrent setup? Somebody has to be able to help him. But I don't know about Mazda North America -- Is there a "Mazda Central America"?
Freddie is offline  
Old 04-13-2006, 12:43 AM
  #10  
Registered User
Thread Starter
 
abrahamsaca's Avatar
 
Join Date: Aug 2005
Posts: 28
Likes: 0
Received 0 Likes on 0 Posts
yes they bring mazda 6 and mazda 3, i went to the mazda dealer and they said that the problem is not the ecu, they have to check the car. before the vacations we have in the country.
abrahamsaca is offline  
Old 04-13-2006, 01:13 AM
  #11  
Hot Pit
 
Winning 8's Avatar
 
Join Date: Jul 2005
Location: Castro Valley, CA
Posts: 658
Likes: 0
Received 0 Likes on 0 Posts
there is a chip inside your keys, the ignition has a sensor that sense the chip to turn off the anti theft device. since both of your key don't work, it should be your sensor that's having problem.
Winning 8 is offline  
Old 04-13-2006, 10:00 AM
  #12  
Registered
 
XRX8X's Avatar
 
Join Date: Jan 2005
Location: VIRGINIA
Posts: 508
Likes: 0
Received 0 Likes on 0 Posts
QUICK NOTE!most ford dealers have a WDS in house that will reprogram all your keys.
should be under warranty and no charge to you also we here at this dealership have some cars and trucks that somehow forget the code somehow than remembers. we always reprogram the keys (three for the rx8)two masters and one valet key.hope this helps
XRX8X is offline  
Old 04-13-2006, 05:49 PM
  #13  
Freedom Costs a Buck o' 5
 
jaguargod's Avatar
 
Join Date: Feb 2005
Location: Texas
Posts: 511
Likes: 0
Received 0 Likes on 0 Posts
Is the Mazda North America warranty valid in El Salvador?
jaguargod is offline  
Old 04-13-2006, 08:07 PM
  #14  
Extraordinary Engineering
 
DarkBrew's Avatar
 
Join Date: Oct 2005
Location: Burls On
Posts: 4,727
Likes: 0
Received 4 Likes on 4 Posts
As stated in the manual, metal key rings can interfer with the operation of the security chips and sensors. Also if two keys are close to each other they will interfer with each other.
DarkBrew is offline  
Old 04-13-2006, 10:01 PM
  #15  
Rotary Wanker
 
Ericok's Avatar
 
Join Date: Sep 2005
Location: Washington, DC
Posts: 413
Likes: 0
Received 0 Likes on 0 Posts
According to the shop manual there are two general types of security system problems:

If the security light is FLASHING, it's giving an error code that corresponds to something being wrong with the Key itself, ignition coil or something is interfering with the key communication to the security system (touching metal, keyring, multiple keys too close together, etc.). You can determine the code by reading the flashes.

If the security light is on STEADY, it's giving an error code for which you need a WDS system to read. The STEADY light means there is a problem of the key communicating with the security module and/or the computer. Almost all the problems associated with the STEADY light can be fixed by reprogramming the key, checking the wiring harness, or replacing the security module. I said ALMOST, the last resort is replacing the computer.

I know this doesn't help you fix your problem but it should give you an idea of what you're up against.
Ericok is offline  
Old 04-17-2006, 11:33 PM
  #16  
Registered User
Thread Starter
 
abrahamsaca's Avatar
 
Join Date: Aug 2005
Posts: 28
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by Ericok
According to the shop manual there are two general types of security system problems:

If the security light is FLASHING, it's giving an error code that corresponds to something being wrong with the Key itself, ignition coil or something is interfering with the key communication to the security system (touching metal, keyring, multiple keys too close together, etc.). You can determine the code by reading the flashes.

If the security light is on STEADY, it's giving an error code for which you need a WDS system to read. The STEADY light means there is a problem of the key communicating with the security module and/or the computer. Almost all the problems associated with the STEADY light can be fixed by reprogramming the key, checking the wiring harness, or replacing the security module. I said ALMOST, the last resort is replacing the computer.

I know this doesn't help you fix your problem but it should give you an idea of what you're up against.


YES THE LIGHT IS FLASHING, AND THE CODE IS 23.
DO YOU HAVE AN IDEA WHAT IT MEANS?
abrahamsaca is offline  
Old 04-17-2006, 11:34 PM
  #17  
Registered User
Thread Starter
 
abrahamsaca's Avatar
 
Join Date: Aug 2005
Posts: 28
Likes: 0
Received 0 Likes on 0 Posts
the security light is "steady" like 2 minutes, then start to flash.
abrahamsaca is offline  
Old 11-15-2007, 03:48 AM
  #18  
Registered User
 
Join Date: Jun 2007
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
so what happened and what was the problem, because mine is flashing too even if i remove the key,
shh125 is offline  
Old 11-15-2007, 04:41 AM
  #19  
Mod is as Mod does.
iTrader: (1)
 
StealthTL's Avatar
 
Join Date: Mar 2003
Location: A Pacific Island.
Posts: 7,153
Received 33 Likes on 29 Posts
It looks like your car has more problems than just the security system, most of those lights should be off.

The bad part is that it WILL start, sometimes after lots of tries, sounds like it's not a loose wire/connector, it's the computer.

Did you disconnect the battery, to reset it? Pull all the computer connectors out and reseat them, check the connectors that run up the steering column, the coil is powered by them.....I'm out of ideas.

If the car behaves itself, except for the security system problem, it can be disabled by Racing Beat - their "race flash" removes the need for the chip recognition - the light still flashes, but the car will start.......only works on '04 manual tranny six-speed model.
StealthTL is online now  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
LB2739
New Member Forum
5
07-09-2019 02:25 AM
JimmyBlack
Series I Major Horsepower Upgrades
270
03-06-2019 10:56 PM
Trancemission
RX-8 Multimedia/Photo Gallery
46
12-02-2015 07:26 PM
juicemantwon
New Member Forum
3
09-26-2015 12:30 PM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Big problem with my 8! please help me!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.