Joes Rew swap - Page 3 - RX8Club.com

Go Back  RX8Club.com > Engine Swap Forum > Rotary Swaps
Reload this Page >

Joes Rew swap

Notices

Joes Rew swap

Old 04-13-2018, 10:48 AM
  #51  
Registered
iTrader: (11)
 
Warrior777's Avatar
 
Join Date: Mar 2010
Location: Oklahoma City
Posts: 179
Thanked 0 Times in 0 Posts
Great thread. Thanks for sharing. Any issues with the nicon rotary mount? I have purchased the same one. Also what led you to upgrade the ecu? I plan to swap my car and have purchased the Adaptronic plug and play ECU.
Warrior777 is offline  
Old 05-10-2018, 05:50 AM
  #52  
Registered
Thread Starter
iTrader: (1)
 
Joe814's Avatar
 
Join Date: Jan 2013
Location: Manhattan,IL
Posts: 125
Thanks: 0
Thanked 4 Times in 4 Posts
Originally Posted by Warrior777 View Post
Great thread. Thanks for sharing. Any issues with the nicon rotary mount? I have purchased the same one. Also what led you to upgrade the ecu? I plan to swap my car and have purchased the Adaptronic plug and play ECU.

Hey man. The Nicon mount and pan are made really nice. The only problem I had was that it made the motor sit a little too high so I trimmed down the rubber mount. I do plan on fabbing up some solid mount for it tho. I also switched to the newer ecu because itís overall a better unit than the first version (faster processor, the need for only 1 ecu, emap tuning, etc) but thereís definitely nothing wrong with the original.
Joe814 is offline  
Old 05-21-2018, 01:23 PM
  #53  
Registered
Thread Starter
iTrader: (1)
 
Joe814's Avatar
 
Join Date: Jan 2013
Location: Manhattan,IL
Posts: 125
Thanks: 0
Thanked 4 Times in 4 Posts
Well Iíve had some time to work on the car so the turbo/mani are back on, itís back on the ground and it moves under its own power again thanks to Shawn at turblown for remote tuning it. We have to still do some logs but itís on it way. I also decided to throw my 2way in my spare diff and replace the bushings, seals and bearings while I had it open. The plan is to swap this one in and take the stock lsd and weld it. Top pic is the stock diff and bottom pic is the Tomei 2 way.
Joe814 is offline  
Old 11-29-2018, 09:18 PM
  #54  
Registered
Thread Starter
iTrader: (1)
 
Joe814's Avatar
 
Join Date: Jan 2013
Location: Manhattan,IL
Posts: 125
Thanks: 0
Thanked 4 Times in 4 Posts
Wow I can't believe I havenít updated this for six months. A lot has changed for better and for worse lol. I ended up buying a forum members rear Panspeed overs, sourced BN sports front fenders, ganador mirrors and an autoexe tower brace. Itís finally starting to look the way Iíve imagined it now. As far as the motor is going, sheís still brapin along! Over last winter I switched to the modular ecu so that meant I needed to retune. I finally set something up with turblown around September and made the drive out there. Everything was going good on the dyno and then one of my pumps decided to go out. We switched that out really quick then started back up again. The next pull we did, the internal map sensor in the ecu decided to take a crap on me 🤬. At that point we had to call it quits since the ecu would need to be fixed. The car did make 400whp before all of that tho so thatís what itís tuned at now, which is fine with me. I just want to drive it! So after getting back from the dyno and getting a replacement ecu, I drove to my buddyís house about 20 mins away and somehow managed to kill the trans lol ( I wasnít beating on it either, I just have the best of luck) sooo I limped it the rest of the way there since I was only 2 mins away. Then picked it up later with my trailer. A couple weeks went by bc I was busy with work and then I was able to toss my back up trans in. Had the old one out and the new one in in only a few hours with the help of a friend. I was actually glad that this happened bc it gave me a reason to switch out my annoying tob also. After that the car was running great but I still havenít gotten to rip on it since the dyno so I decided to ďtestĒ out the new trans lol. Well at about 4K I was hitting some sort of safety cut so when I got home I plugged in my laptop and found out I was hitting fuel cut. It didnít make sense. After talking to a few people and some process of elimination I found out it was the pump that we replaced while on the dyno. I had a walbro 450 in there but the shop we were at didnít have one but had a hellcat pump (525) so we threw that in. Well either the new pump was too big for my lift pump or it was cavitating. I switched it back to a walbro 450 and we were back in business!!!! Sorry for all the run on sentences😂 that was a lot to remember lol
Joe814 is offline  
Old 11-29-2018, 09:30 PM
  #55  
Registered
Thread Starter
iTrader: (1)
 
Joe814's Avatar
 
Join Date: Jan 2013
Location: Manhattan,IL
Posts: 125
Thanks: 0
Thanked 4 Times in 4 Posts

Fresh paint!

Autoexe tower bar installed


Ganadors and autoexe rain guards on

Panspeed overs on!

Front fenders fitted

New trans going in
Joe814 is offline  
Old 11-29-2018, 09:43 PM
  #56  
Registered
Thread Starter
iTrader: (1)
 
Joe814's Avatar
 
Join Date: Jan 2013
Location: Manhattan,IL
Posts: 125
Thanks: 0
Thanked 4 Times in 4 Posts

I got to test out how the new truck towed!

On the dyno!

Elliot looking at my headache 😂

Baby flames 🔥

Switching out the pump
Joe814 is offline  
Old 11-30-2018, 11:33 AM
  #57  
Registered
 
Join Date: Sep 2005
Location: Tampa
Posts: 653
Thanked 55 Times in 52 Posts
Looking good. I have also had an issue with my Adaptronics internal MAP sensor, and I have sent messages to Elliot to get it repaired/buy another but he doesn't respond to me.

Luckily the sensor "drift" has seemed to stop and I have been able to tune that out. I also have a flat spot at 7-8 psi that appears to be from the MAP sensor, but it doesn't seem to effect much (just get a rich spike at that boost pressure).

Did you swap in a 5 speed tranny?
strokercharged95gt is offline  
Old 11-30-2018, 05:05 PM
  #58  
Registered
Thread Starter
iTrader: (1)
 
Joe814's Avatar
 
Join Date: Jan 2013
Location: Manhattan,IL
Posts: 125
Thanks: 0
Thanked 4 Times in 4 Posts
Yeah mine was completely fine then it was acting like the motor let go. The vacuum kept getting worse so we stopped. We decided to start checking vacuum lines and when I wiggled the map hose it went back to normal. Sometimes he is hard to get a hold of, I sometimes have to bug him a few times to respond but always gets back to me. Have you tried calling? Or instagram? Unfortunately my back up trans was a 6spd and I know itís gunna blow but Iíll make the swap to the 5spd once it does.
Joe814 is offline  
Old 01-10-2019, 08:27 AM
  #59  
New Member
 
Join Date: Jan 2019
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
When you used the adaptonic on the REW did you have to modify the RX8 harness much? Did you use the RX8 sensors. Was there an issue with not having the OMP hooked up? Did any check engine lights come on?

Any info would be greatly appreciated
BARNETT89 is offline  
Old 01-10-2019, 09:08 AM
  #60  
Registered
 
Join Date: Apr 2008
Location: E.Nopo, NY
Posts: 95
Thanks: 0
Thanked 2 Times in 2 Posts
Originally Posted by BARNETT89 View Post
When you used the adaptonic on the REW did you have to modify the RX8 harness much? Did you use the RX8 sensors. Was there an issue with not having the OMP hooked up? Did any check engine lights come on?

Any info would be greatly appreciated
i think youíre supposed to delete the omp with the rew cause the turbo wherever itís mounted will be in that vicinity and the heat wonít be great and premixing will be the way of life. I think the adaptronic if itís the plug and play one is just plug and play. The only lights I think that were on but now have been updated to be off are dsc and abs?
Rkesh88 is online now  
Old 01-19-2019, 12:39 AM
  #61  
Registered
Thread Starter
iTrader: (1)
 
Joe814's Avatar
 
Join Date: Jan 2013
Location: Manhattan,IL
Posts: 125
Thanks: 0
Thanked 4 Times in 4 Posts
You donít have to modify the rx8 harness, youíll end up haveing some unused plugs actually. And I have the modular adaptronic with my swap. No cel or anything. I also donít have my omp hooked up. You could run it if you really wanted to but I chose not to.
Joe814 is offline  
Old 01-23-2019, 11:02 PM
  #62  
Registered
Thread Starter
iTrader: (1)
 
Joe814's Avatar
 
Join Date: Jan 2013
Location: Manhattan,IL
Posts: 125
Thanks: 0
Thanked 4 Times in 4 Posts
Well things have been going slow since itís winter but Iíve decided to find some motivation and recover a lot of my interior bits.

No more cracked dash!
Joe814 is offline  
Old 01-28-2019, 06:07 PM
  #63  
Registered
iTrader: (11)
 
Warrior777's Avatar
 
Join Date: Mar 2010
Location: Oklahoma City
Posts: 179
Thanked 0 Times in 0 Posts
Interesting. Are you using air bags? You have any idea how that material behaves when the airbag opens up?
Warrior777 is offline  
Old 01-28-2019, 06:31 PM
  #64  
Registered
 
Join Date: Sep 2005
Location: Tampa
Posts: 653
Thanked 55 Times in 52 Posts
Looking at some pics of your differential, it looks like you put some new bushings in there. Getting ready to pull my differential and install some new whiteline bushings. How where your factory bushings? Did you notice much difference with the new stiffer ones? I am trying anything to get rid of wheelhop....
strokercharged95gt is offline  
Old 01-28-2019, 08:38 PM
  #65  
Registered
Thread Starter
iTrader: (1)
 
Joe814's Avatar
 
Join Date: Jan 2013
Location: Manhattan,IL
Posts: 125
Thanks: 0
Thanked 4 Times in 4 Posts
Originally Posted by Warrior777 View Post
Interesting. Are you using air bags? You have any idea how that material behaves when the airbag opens up?
The airbag is removed from there. I wouldnít recommend covering the dash and running the airbag
Joe814 is offline  
Old 01-28-2019, 09:08 PM
  #66  
Registered
Thread Starter
iTrader: (1)
 
Joe814's Avatar
 
Join Date: Jan 2013
Location: Manhattan,IL
Posts: 125
Thanks: 0
Thanked 4 Times in 4 Posts
Originally Posted by strokercharged95gt View Post
Looking at some pics of your differential, it looks like you put some new bushings in there. Getting ready to pull my differential and install some new whiteline bushings. How where your factory bushings? Did you notice much difference with the new stiffer ones? I am trying anything to get rid of wheelhop....

My stock bushings were in pretty bad shape/ripped in some spots. When I had them in it felt like the rear end was always ďlooseĒ. I never experienced wheel hop tho. After I threw the new bushings in it definitely tighten things up.
Joe814 is offline  
Old 02-02-2019, 04:37 AM
  #67  
New Member
 
Join Date: Feb 2019
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by Joe814 View Post
After that experience I decided to say screw it and tell work I was taking a few days off to go dyno the car in Minnesota. Before I went to the dyno me and Shawn talked about upgrading my coils from the D585s to the sakebomb garage smart coil kit. It was a no brainer to go with those, so I ordered them up. I installed them ASAP and sent them a new log. I also decided to put a bigger intercooler on. The one that I first put on just seemed to small and out of place. It probably wouldíve been fine but I replaced it anyway.


Sakebomb smart coil kit



Me and my pops decided to go to a lil car show after the new coils were installed.



Ended up taking home a trophy lol.



Old ic on left(21.5x10x3.375) vs new ic on right(24x12x4)



New intercooler on top vs old one on bottom
how did you hook up the coils did you use the rx8 harness or rew harness
Kidracer is offline  
Old 02-02-2019, 03:55 PM
  #68  
Registered
 
Join Date: Sep 2005
Location: Tampa
Posts: 653
Thanked 55 Times in 52 Posts
Thanks for the info. Just installed some new Whiteline bushings this morning in the differential mount. Feels more solid, but I really won't know if they work until I hit the track again...
strokercharged95gt is offline  
Old 02-04-2019, 05:37 PM
  #69  
Registered
Thread Starter
iTrader: (1)
 
Joe814's Avatar
 
Join Date: Jan 2013
Location: Manhattan,IL
Posts: 125
Thanks: 0
Thanked 4 Times in 4 Posts
Originally Posted by Kidracer View Post
how did you hook up the coils did you use the rx8 harness or rew harness
The car is using the stock rx8 harness. You donít need an ďrewĒ harness.
Joe814 is offline  
Old 02-04-2019, 05:39 PM
  #70  
Registered
Thread Starter
iTrader: (1)
 
Joe814's Avatar
 
Join Date: Jan 2013
Location: Manhattan,IL
Posts: 125
Thanks: 0
Thanked 4 Times in 4 Posts
Originally Posted by strokercharged95gt View Post
Thanks for the info. Just installed some new Whiteline bushings this morning in the differential mount. Feels more solid, but I really won't know if they work until I hit the track again...
No problem! Were your stock ones in bad shape? Hopefully it helps your wheel hop problem.
Joe814 is offline  
Old 02-04-2019, 05:48 PM
  #71  
Registered
 
Join Date: Sep 2005
Location: Tampa
Posts: 653
Thanked 55 Times in 52 Posts
Originally Posted by Joe814 View Post


No problem! Were your stock ones in bad shape? Hopefully it helps your wheel hop problem.
Actually there were in good shape, not torn or anything after 110k miles and 15 years of abuse. They are way more flexible than the urethane bushings I put in. Probably going to the track this weekend. Gonna try 18 psi in the rear tires with the new bushings. Going to snap and axle or cut a good 60 foot.
strokercharged95gt is offline  
Old 02-04-2019, 08:33 PM
  #72  
Registered
Thread Starter
iTrader: (1)
 
Joe814's Avatar
 
Join Date: Jan 2013
Location: Manhattan,IL
Posts: 125
Thanks: 0
Thanked 4 Times in 4 Posts
Originally Posted by strokercharged95gt View Post
Actually there were in good shape, not torn or anything after 110k miles and 15 years of abuse. They are way more flexible than the urethane bushings I put in. Probably going to the track this weekend. Gonna try 18 psi in the rear tires with the new bushings. Going to snap and axle or cut a good 60 foot.
Oh, Iím surprised they werenít in worse shape then lol. I think the axles will hold up and youíll get a good 60 ft. I like to stay positive!!!!
Joe814 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
joeroot9357
New Member Forum
0
04-04-2016 03:19 AM
sixgen3sgte
Series I Major Horsepower Upgrades
68
04-13-2007 03:40 PM
rx808boi
Series I Tech Garage
13
05-07-2006 09:28 AM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Joes Rew swap


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.