Go Back  RX8Club.com > General Topics > New Member Forum
Reload this Page >

Something bit my wiring to pieces under the hood, how screwed am I?

Notices
New Member Forum A place for new members to get their feet wet

Something bit my wiring to pieces under the hood, how screwed am I?

Old 05-15-2019, 03:24 AM
  #1  
Registered
Thread Starter
 
Zerg_Rush's Avatar
 
Join Date: Sep 2014
Location: Sacramento, CA
Posts: 20
Received 1 Like on 1 Post
Something bit my wiring to pieces under the hood, how screwed am I?

Just got back from a month long vacation, came back and the RX8 wouldn't start. I popped open the hood and found this along with my wiper fluid reservoir bitten to shreds. We have a squirrel problem here in Davis, CA. No idea where this goes to, I'm guessing wiring harness? I'm a total newb. Can anyone help me with some info? How screwed am I in terms of cost to repair this?

I'm really really sad that the squirrels had to do this to me.



Zerg_Rush is offline  
Old 05-15-2019, 05:55 AM
  #2  
Modulated Moderator
iTrader: (3)
 
dannobre's Avatar
 
Join Date: Feb 2004
Location: Smallville
Posts: 12,792
Received 96 Likes on 93 Posts
The good thing is that there isn't roo much there.

If you have insurance let them fix it.... otherwise the only critical wiring there is the baro sensor And the window washer pump
dannobre is offline  
Old 05-15-2019, 01:05 PM
  #3  
Registered
Thread Starter
 
Zerg_Rush's Avatar
 
Join Date: Sep 2014
Location: Sacramento, CA
Posts: 20
Received 1 Like on 1 Post
Originally Posted by dannobre View Post
The good thing is that there isn't roo much there.

If you have insurance let them fix it.... otherwise the only critical wiring there is the baro sensor And the window washer pump
I don't have comprehensive so this is not covered unfortunately. Do you think having just these wires chewed on is what's causing the car not to start or? Baro sensor doesn't seem to be very vital system to cause it not to start like that. So I'm wondering if something else was chewed on that I can't see.
Zerg_Rush is offline  
Old 05-15-2019, 01:26 PM
  #4  
^^^ Fluent in snark.
 
NotAPreppie's Avatar
 
Join Date: Mar 2006
Location: Chicago, IL, USA, North America, Earth, Sol System, Sector ZZ9 Plural Z Alpha, Milkyway, Universe
Posts: 3,249
Received 431 Likes on 352 Posts
All those wires being black make me think they are all grounds... Aside from the two on the grounding lug, where are the rest of the wires that connect to this bundle?
NotAPreppie is online now  
Old 05-15-2019, 01:49 PM
  #5  
Registered
Thread Starter
 
Zerg_Rush's Avatar
 
Join Date: Sep 2014
Location: Sacramento, CA
Posts: 20
Received 1 Like on 1 Post
Originally Posted by NotAPreppie View Post
All those wires being black make me think they are all grounds... Aside from the two on the grounding lug, where are the rest of the wires that connect to this bundle?
I think the squirrel carried off the rest of the bundle of wires there. And I think the bundle originally connected to the plastic white piece that's been mutilated and torn apart.
Zerg_Rush is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
silvermax2k2
Series I Aftermarket Performance Modifications
6
07-18-2011 03:52 AM
gotrx8
RX-8 Parts For Sale/Wanted
0
07-16-2011 09:07 PM
getdamafiaonyou
Series I Tech Garage
21
06-03-2009 10:25 PM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Something bit my wiring to pieces under the hood, how screwed am I?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.