RX8 Will not shut off - RX8Club.com

Go Back  RX8Club.com > General Topics > New Member Forum
Reload this Page >

RX8 Will not shut off

New Member Forum A place for new members to get their feet wet

RX8 Will not shut off

Reply

 
 
 
Old 09-10-2016, 10:22 PM
  #1  
New Member
Thread Starter
 
Join Date: Sep 2016
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
RX8 Will not shut off

Greetings All,

There are strange things afoot within my RX8. Most commonly, an RX8 typically won't turn on, mine has the odd behavior of not turning off! I thought possibly, a bad relay/contactor. I've tested and swapped to no avail. My next thought is maybe the key cylinder is defective?

Here are some more details:

I must shut off the RX8 by stalling it.
I can pull the keys out and the motor will still run.
with the keys removed, the main gauges are lit but i must use my key for the radio to turn on.

The AC will also run without they keys in the ignition (no compressor running of course)

If i purchase a key cylinder/key combo on ebay, will i run into issues with the security system?

Prior to this issue, i had to replace the reverse switch on the tranny and I did upgrade the coils to BHR.

Many thanks as if this is not resolved, I may set my RX8 ablaze lol.
jramos3001 is offline  
Reply With Quote
Old 09-10-2016, 10:35 PM
  #2  
Modulated Moderator
iTrader: (3)
 
dannobre's Avatar
 
Join Date: Feb 2004
Location: Smallville
Posts: 12,572
Thanked 69 Times in 66 Posts
What year?
dannobre is offline  
Reply With Quote
Old 09-10-2016, 10:37 PM
  #3  
New Member
Thread Starter
 
Join Date: Sep 2016
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
2004 gt
jramos3001 is offline  
Reply With Quote
Old 09-10-2016, 11:21 PM
  #4  
Put it in "H"!
iTrader: (1)
 
Loki's Avatar
 
Join Date: Jun 2009
Location: Montreal
Posts: 4,114
Thanked 251 Times in 222 Posts
Was it hotwired at some point? Sounds like the wiring has been messed with. A lot.
Loki is online now  
Reply With Quote
Old 09-11-2016, 09:29 PM
  #5  
New Member
Thread Starter
 
Join Date: Sep 2016
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Greetings again! The vehicle was never hot wired. Here is some additional information. When my reverse switch went defective, the ignition fuse was blowing. In order to get home, i added a 30 amp fuse (I know, bad idea) instead. Maybe that killed my ignition switch?
jramos3001 is offline  
Reply With Quote
Old 12-20-2016, 02:42 PM
  #6  
New Member
Thread Starter
 
Join Date: Sep 2016
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Another update, completed disconnected my key/ignition system and vehicle continues to encounter the issue. I can pull the ignition fuse to turn the car off. .... in order to turn the vehicle on, with the 15 amp ignition fuse out, put the keys in and turn to the on position. Go back to fuse box and insert 15 amp fuse ( you hear relays click). Now turn the key and voila car is on!
jramos3001 is offline  
Reply With Quote
Old 12-20-2016, 11:00 PM
  #7  
Registered
 
Join Date: Mar 2014
Posts: 141
Thanks: 0
Thanked 0 Times in 0 Posts
I had a similar issue when I wrecked my ignition relay. Expensive buggers.
Ber1n is offline  
Reply With Quote
Old 12-23-2016, 11:43 AM
  #8  
New Member
Thread Starter
 
Join Date: Sep 2016
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
I replaced the relay thinking maybe it was sticky or just acting strange but no bueno
jramos3001 is offline  
Reply With Quote
Old 12-23-2016, 10:28 PM
  #9  
New Member
 
Join Date: Dec 2016
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
That's strange.. new to me
ArtaNSX is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
puppet623
RX-8 Parts For Sale/Wanted
6
10-14-2016 11:04 AM
Mswgheat98
New Member Forum
6
09-03-2016 04:37 PM
Eddie1980
New Member Forum
1
09-02-2016 10:23 PM
zaxome
New Member Forum
3
08-28-2016 11:42 AM
Tweaked Tay
Series I Trouble Shooting
1
08-23-2016 10:12 AM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread: