RX8Club.com
Register Photo Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read RX8 Live!Used CarsVendor Directory

Go Back   RX8Club.com > Series I Tech & Performance > Series I Tech Garage
Sign in using an external account
Register Forgot Password?

Welcome to RX8Club.com!
Welcome to RX8Club.com,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join RX8Club.com today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 10-29-2010, 03:50 PM   #1
Registered
 
icemantbi's Avatar
 
Trader Score: (0)
Join Date: Jun 2009
Location: Sault Ste. Marie, Ontario
Posts: 43
RX-8 won't start, brake is stiff, and clicking sound

Hey guys

Today I tried to start my RX-8, and it won't crank... all I get is a constant clicking sound, the lights are all working, not dimming... another thing is the brake pedal is stiff. Anyways, it won't start.

Got new plugs and coils not too long ago, any idea what it could be?
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on RX8Club.com!
icemantbi is offline   Reply With Quote
Old 10-29-2010, 03:52 PM   #2
on his 3rd rx8
 
dozer's Avatar
 
Trader Score: (3)
Join Date: Dec 2006
Location: santa ana, ca
Posts: 6,810
Send a message via AIM to dozer
battery
dozer is offline   Reply With Quote
Old 10-29-2010, 03:53 PM   #3
Registered
 
icemantbi's Avatar
 
Trader Score: (0)
Join Date: Jun 2009
Location: Sault Ste. Marie, Ontario
Posts: 43
Phew! That's all? I was thinking that, but the lights come on. So, I guess I need a new one? I'm assuming the current battery is the original, it's old and the connectors are rusty.

Finally, what battery do you recommend?

Thanks for the very fast reply!
icemantbi is offline   Reply With Quote
Old 10-29-2010, 04:15 PM   #4
Resident Alien
 
York's Avatar
 
Trader Score: (0)
Join Date: Apr 2010
Location: Florida
Posts: 569
Make sure you clean those cable ends too if they're in bad shape.
York is offline   Reply With Quote
Old 10-29-2010, 04:29 PM   #5
Registered User
 
Trader Score: (0)
Join Date: Sep 2010
Posts: 161
I just got a redtop optima and LOVE it!
jdenman03 is offline   Reply With Quote
Old 12-02-2010, 04:28 PM   #6
Registered User
 
Trader Score: (0)
Join Date: Nov 2010
Posts: 1
Quote:
Originally Posted by York View Post
Make sure you clean those cable ends too if they're in bad shape.
Now I understand more about it, Thanks for your effort! It is just the solution for my problem, Nice writing.
wangyoslh is offline   Reply With Quote
Old 12-02-2010, 05:11 PM   #7
Resident Alien
 
York's Avatar
 
Trader Score: (0)
Join Date: Apr 2010
Location: Florida
Posts: 569
wut..
York is offline   Reply With Quote
Old 12-05-2010, 11:06 PM   #8
Registered
 
bren5279's Avatar
 
Trader Score: (15)
Join Date: Jul 2010
Location: Mooresville NC / Blacksburg VA
Posts: 201
How do you not know the answer to that? Have you never had a dead battery before? I fear for your car....

Yeah dead battery - not enough juice to turn it over so it ticks, brake is always stiff after you turn the engine off and push it once or twice cus of the brakes being hydr. so no engine to turn the hydr. pump means no brake assistance.
bren5279 is offline   Reply With Quote
Old 12-06-2010, 05:06 AM   #9
Love it when she whines
 
Trader Score: (0)
Join Date: Oct 2010
Location: Iowa City, Iowa
Posts: 182
haha i have never heard of a person not knowing what the clicking sound is. that should be a sure sign that you NEED to read through the owners manual, because chances are your car may run into a problem in the future that many people may catch right away but if you dont notice it or know how to diagnos it, it may turn "fatal" lol... if i remember correctly the ticking is the solenoid on the starter engaging and returning rapidly, i may very well be wrong though. if you go to any general automotive store they can tell you what battery you will need.

the lights probably work be cause they draw such a TINY amount of power that a near dead battery can power them with ease, your battery would have to be completely shot to not be able to power them.
9kBeep is offline   Reply With Quote
Old 12-06-2010, 05:32 AM   #10
Registered
 
Trader Score: (0)
Join Date: Nov 2008
Location: Long Beach, CA
Posts: 603
Quote:
Originally Posted by bren5279 View Post
How do you not know the answer to that? Have you never had a dead battery before? I fear for your car....

brake is always stiff after you turn the engine off and push it once or twice cus of the brakes being hydr. so no engine to turn the hydr. pump means no brake assistance.
Before being so quick to judge his car knowledge, you might want to do a little research on RX-8 power brakes.

"Turn the hydr. pump"???
PeteInLongBeach is offline   Reply With Quote
Old 12-06-2010, 02:19 PM   #11
Love it when she whines
 
Trader Score: (0)
Join Date: Oct 2010
Location: Iowa City, Iowa
Posts: 182
Quote:
Originally Posted by PeteInLongBeach View Post
Before being so quick to judge his car knowledge, you might want to do a little research on RX-8 power brakes.

"Turn the hydr. pump"???


I bet his power steering hydrolic pump wasnt working either!
9kBeep is offline   Reply With Quote
Old 12-06-2010, 03:28 PM   #12
Modulated Moderator
 
dannobre's Avatar
 
Trader Score: (3)
Join Date: Feb 2004
Location: Smallville
Posts: 10,191
Send a message via MSN to dannobre Send a message via Yahoo to dannobre
Vac assist Hydraulic brakes
dannobre is online now   Reply With Quote
Old 12-06-2010, 03:28 PM
RX8Club
Mazda RX8




Paid Advertisement


 
 
 
Reply

Tags
2005, battery, brake, break, car, click, clicking, full, noise, petal, rx8, sound, start, starting, stiff, wont

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rx8 clicking sound hackdss Canada Forum 7 07-31-2009 12:42 PM
Rx8 clicking sound hackdss Canada Forum 2 07-30-2009 10:43 PM
Clicking on start up. rx8speeddmon Series I Tech Garage 15 11-16-2007 02:29 AM
Clicking sound from Clutch rotary9k Series I Tech Garage 1 09-01-2005 12:14 PM
clicking sound Rx8bydocabe Series I Trouble Shooting 19 01-09-2005 04:08 PM


All times are GMT -5. The time now is 08:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2011, Crawlability, Inc.
All content Copyright 2007 by Internet Brands, Inc.
Emails Backup