Notices
Series II Technical and Trouble shooting Discuss technical details for the Series II RX-8 and any issues or problems you are facing

Power loss/cut

Old 05-28-2018, 04:41 PM
  #1  
Registered
Thread Starter
 
Join Date: Oct 2015
Posts: 32
Received 0 Likes on 0 Posts
Power loss/cut

Went out for some spirited driving today, and after a while the car began losing power and struggling to reach redline. A little while longer and it started to have a hard power cut at higher rpms.

Around the end of July last year I replaced the fuel pump to fix the same symptoms. In December I found a fuel leak at the injectors, which I think was part of my problem when I replaced the first pump.

I also found a thread where someone said a clogged charcoal canister caused similar problems, and I believe something in my evap system may be clogged because sometimes when I fill up the pump keeps shutting off unless I fill it slowly.

Could the pump have failed this quickly, or should I replace the pump resistor (I did not change it with the pump), and could the charcoal canister even cause problems like this?

Thanks in advance for any input.
Setsuna is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
kevino
Series I Trouble Shooting
5
06-22-2016 01:27 PM
asten1
Series I Trouble Shooting
9
03-03-2013 10:06 AM
MICKY 3
Series I Trouble Shooting
13
08-25-2008 07:02 AM
kanie12
Series I Trouble Shooting
17
05-25-2007 05:44 AM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Power loss/cut


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.