Notices
Series I Wheels, Tires, Brakes & Suspension
Sponsored by:
Sponsored by:

ABS question

Old 09-04-2015, 10:31 PM
  #1  
Unregistered User
Thread Starter
 
stickmantijuana's Avatar
 
Join Date: Apr 2006
Posts: 824
Likes: 0
Received 0 Likes on 0 Posts
ABS question

everything happens so slowly with my ABS.... say I'm going down the empty employee parking lot at 15mph, I lock up all 4 wheels on a patch of sand --> car slides for a second or two until the car's going near 5mph --> brake pedal goes in couple more inches and feel mushy --> maybe half second after that I can finally feel the ABS modulation with my foot for a split second until I'm at complete stop.

good news is that my ABS is working... but everything is in slow-motion. is it not supposed to work at low speeds? is it pretty instant for other rx8's when you lock your wheels at low speeds?

Last edited by stickmantijuana; 09-04-2015 at 11:12 PM.
stickmantijuana is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
NotAPreppie
Series I Tech Garage
12
09-24-2015 03:22 PM
stickmantijuana
Rotary Swaps
11
09-24-2015 12:47 AM
stickmantijuana
Non-Rotary Swaps
2
09-19-2015 03:15 PM
stickmantijuana
Series I Wheels, Tires, Brakes & Suspension
10
09-13-2015 11:28 PM
LMURailsplitter02
New Member Forum
1
09-06-2015 10:56 PM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: ABS question


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.