Notices
Series I Tech Garage The place to discuss anything technical about the RX-8 that doesn't fit into any of the categories below.

throwing codes :( p2096 and p0301

Old 05-31-2009, 08:53 PM
  #1  
Registered
Thread Starter
 
Join Date: Dec 2005
Posts: 26
Likes: 0
Received 0 Likes on 0 Posts
throwing codes :( p2096 and p0301

I just bought this car a few weeks ago, I took it to a dealer and they told me I had a cat problem (it was gutted). I just put in a stock cat with 10k and now im throwing 2 codes the p2096 and p0301. first is fuel trim 1 and the 2nd one is misfire detected. I did just have the lack of power flash done @ the mazda dealer at the same time they checked the code idk how that would matter. Any advice would be appricated.
mazdadude8 is offline  
Old 05-31-2009, 09:14 PM
  #2  
Grasshopper
iTrader: (1)
 
Jon316G's Avatar
 
Join Date: Dec 2006
Location: Streetsboro, OH
Posts: 6,779
Likes: 0
Received 11 Likes on 11 Posts
P2096= Target A/F feedback system too lean.
P0301= Front rotor misfire detected.

For the P2096, disconnect your battery for at least 15min so it clears the KAM.
P0301 codes usually mean that its time to replace the spark plugs, plug wires, and/or ignition coils.
Usually the spark plugs are the 1st place to start.
Also, check the plug wire boot where they attach to the spark plugs. They have been known to come loose.
Jon316G is online now  
Old 05-31-2009, 09:25 PM
  #3  
Registered
Thread Starter
 
Join Date: Dec 2005
Posts: 26
Likes: 0
Received 0 Likes on 0 Posts
new plugs from what I was told... but thanks for the quick response I am going to check everything you said.
mazdadude8 is offline  
Old 06-01-2009, 01:09 PM
  #4  
Registered
 
Sleepy-z's Avatar
 
Join Date: May 2008
Location: Virginia
Posts: 277
Likes: 0
Received 0 Likes on 0 Posts
FYI those codes show up on about 60-70% of bad engines, might be time for a rebuild. P0300, p0301, p2096 are always listed as codes when engines are bad. May want to take it to a dealer.
Sleepy-z is offline  
Old 06-01-2009, 02:56 PM
  #5  
Out of NYC
iTrader: (1)
 
nycgps's Avatar
 
Join Date: Jun 2005
Location: Planet Earth
Posts: 19,866
Received 12 Likes on 12 Posts
oh snap, I just got a P0300 -_-

...

time for another REman ?
nycgps is offline  
Old 06-01-2009, 06:10 PM
  #6  
Grasshopper
iTrader: (1)
 
Jon316G's Avatar
 
Join Date: Dec 2006
Location: Streetsboro, OH
Posts: 6,779
Likes: 0
Received 11 Likes on 11 Posts
Originally Posted by Sleepy-z View Post
FYI those codes show up on about 60-70% of bad engines, might be time for a rebuild. P0300, p0301, p2096 are always listed as codes when engines are bad. May want to take it to a dealer.
If misfire codes were signs of a bad engine, most people would have to get a new engine!
A lot of people get misfires, it just doesn't turn on the CEL because its still a pending code until another one occurs.
If it doesn't occur again by two drive cycles, it deletes the pending code and the cycle continues.
Don't worry about it mazdadude8, you'll know when the motor is truly shot!

Originally Posted by nycgps View Post
oh snap, I just got a P0300 -_-
time for another REman ?
Should get a spare! Might have to swap them out yearly!
Jon316G is online now  
Old 06-01-2009, 06:17 PM
  #7  
Out of NYC
iTrader: (1)
 
nycgps's Avatar
 
Join Date: Jun 2005
Location: Planet Earth
Posts: 19,866
Received 12 Likes on 12 Posts
Originally Posted by Jon316G View Post
Should get a spare! Might have to swap them out yearly!
...

I found the source of the problem, inside the intake box, there're 2 plastic plates, one of screw came off and the plastic plate was blocking more than 1/2 of the intake -_-

so I got p0170(system running lean) and p0300 (Random misfire detected)

After 2 days of driving, the P0170 is gone. P0300 still here. it will probably be gone in a day or 2 (I hope)
nycgps is offline  
Old 06-02-2009, 03:54 PM
  #8  
Registered
Thread Starter
 
Join Date: Dec 2005
Posts: 26
Likes: 0
Received 0 Likes on 0 Posts
im just wondering how I was driving it and its fine no check engine light. Then It throws one about 6 hours later (bought the car that day) and take to the dealer they say bad cat(it was gutted) and they also do the lack of power update and right after that the engine check light came on and it was flashing. So I am just trying to figure out how that could have happened. Thanks for all the advice so far
mazdadude8 is offline  
Old 07-09-2009, 10:52 PM
  #9  
Registered
Thread Starter
 
Join Date: Dec 2005
Posts: 26
Likes: 0
Received 0 Likes on 0 Posts
ok got it figured out it they bumped a wire on my coil pack and it wasnt making a good connection...
mazdadude8 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mdl0209
Series I Trouble Shooting
14
05-23-2019 05:46 PM
projectr13b
RX-8 Racing
20
05-14-2016 06:25 PM
TotalAutoPerformance
Vendor Classifieds
3
10-14-2015 12:29 PM
Eliseo Esquivel
RX-8 Discussion
2
09-30-2015 08:28 PM
alming1132
RX-8 Parts For Sale/Wanted
0
09-30-2015 11:30 AM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: throwing codes :( p2096 and p0301


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.