Wtb ff21-67-83y a - RX8Club.com



New Member Forum A place for new members to get their feet wet

Reply
 
 
 
Thread Tools Search this Thread Rate Thread
Old 03-13-2018, 06:00 PM   #1  
New Member
Thread Starter
 
Join Date: Mar 2018
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
blown cabin fuse

Fun times, probably should've created an account earlier. Anyways here goes, the cabin/room fuse is burning out instantly. Dealership says it's pulling 20-25 amps for a 15 amp fuse, says it's the FF21-67-83Y A that's malfunctioning, S2 door lock timer. Bought one off Ebay, dealership says doesn't work, doesn't give specifics. Buy another one off Ebay from a different seller, dealership says it's still instantly shorting out. Dealership insists it's the module, so either I've bought 2 faulty modules in a row, or something else up. Dealership's pretty insistent it's the module though. So if anyone have any insights or a working one to sell, send a reply or pm.

Thanks.

Last edited by sintri; 03-14-2018 at 01:22 PM.
sintri is offline   Reply With Quote
Old 03-13-2018, 06:10 PM   #2  
Put it in "H"!
iTrader: (1)
 
Loki's Avatar
 
Join Date: Jun 2009
Location: Montreal
Posts: 3,842
Thanked 196 Times in 172 Posts
25 amps sounds like a bare wire touching body metal. Especially if other modules haven't fixed the problem. Think you might need a different dealer more than a different module.
Loki is online now   Reply With Quote
Old 03-13-2018, 08:24 PM   #3  
Modulated Moderator
iTrader: (3)
 
dannobre's Avatar
 
Join Date: Feb 2004
Location: Smallville
Posts: 12,537
Thanked 60 Times in 57 Posts
Does it blow the fuse with the module disconnected? If it does it is not the module.

If you are electrically inclined open the module.... a 25A draw should be evident
dannobre is offline   Reply With Quote
Old 03-13-2018, 09:08 PM   #4  
New Member
Thread Starter
 
Join Date: Mar 2018
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Thought it might be a line since they were also replacing a motor regulator on the passenger side door, but they've said they rechecked their work and didn't find anything.
They said it's fine with the module disconnected and burns the moment they reconnect it. They've also talked with Mazda who apparently told em to try a new part, which isn't quite possible since it's no longer manufactured so not quite sure what hq was thinking.

They returned the car and said they disconnected the module. Power locks / keyless start is out as expected, gauges are back behaving normal as is the cabin lighting so pretty sure the fuse is back, will double check in the morning. Speakers and majority of the displays in the instrument cluster (temperature sensors, climate control settings, some others) are still offline so I'm assuming they've left some other things unplugged as well.

Last edited by sintri; 03-13-2018 at 09:15 PM.
sintri is offline   Reply With Quote
Old 03-14-2018, 12:22 PM   #5  
New Member
Thread Starter
 
Join Date: Mar 2018
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Fuse was plugged in, started today engine light was on. Went to work, came out for lunch noticed the fuse blown again so it's something else.

Dealership says they'll take another look at it with their rotary specialist as opposed to electrician. Probably hold off on buying till they take another look. Still if anyone's has any insight could be helpful, cars back in my hands till Monday.

Last edited by sintri; 03-14-2018 at 01:21 PM.
sintri is offline   Reply With Quote
Old 03-14-2018, 02:54 PM   #6  
Modulated Moderator
iTrader: (3)
 
dannobre's Avatar
 
Join Date: Feb 2004
Location: Smallville
Posts: 12,537
Thanked 60 Times in 57 Posts
Quote:
Originally Posted by sintri View Post
Fuse was plugged in, started today engine light was on. Went to work, came out for lunch noticed the fuse blown again so it's something else.

Dealership says they'll take another look at it with their rotary specialist as opposed to electrician. Probably hold off on buying till they take another look. Still if anyone's has any insight could be helpful, cars back in my hands till Monday.

Its definitely an electrical issue and not rotary related. Diagnosing electrical issues isn't difficult but you have to be very methodical and check everything. If they are intermittent they can be a PIA to find though. The car has never been wet has it? There are a lot of water flooded cars floating around and they are almost impossible to fix
dannobre is offline   Reply With Quote
Old 03-14-2018, 06:33 PM   #7  
转子之魂
 
UnknownJinX's Avatar
 
Join Date: Apr 2017
Location: Victoria, BC
Posts: 1,261
Thanked 169 Times in 158 Posts
You should grab an electrical diagram and start looking. It should be downloadable from somewhere on this site.
UnknownJinX is online now   Reply With Quote
Old 03-14-2018, 08:06 PM   #8  
New Member
Thread Starter
 
Join Date: Mar 2018
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Don't believe it's ever been in a flood, was fine for 2 years, then took it into the shop for low compression, they placed a new engine, passenger window motor also blew so they redid that as well. Just bit curious both time it started to happen was in the parking garage at work, maybe something got jostled loose going over a bump. Sort of want to take off the passenger door panel and see if there's anything that looks off there.
sintri is offline   Reply With Quote
Old 03-16-2018, 12:26 AM   #9  
Registered
 
MIGhunter's Avatar
 
Join Date: Apr 2015
Location: Bloomington, IN
Posts: 110
Thanks: 0
Thanked 3 Times in 3 Posts
So, my cabin fuse was blowing like this. Turned out the previous owner had an amp running and the blue wire that signals the car is on to give it juice had come lose from where he tucked it in. (he took the system out before selling it) It was hitting the metal of the trunk and blowing the fuse.
MIGhunter is offline   Reply With Quote
Old 03-29-2018, 02:38 AM   #10  
New Member
Thread Starter
 
Join Date: Mar 2018
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Update I suppose if anyone ever does a search, dealership took another look and assigned a new guy. They said the passenger door light was missing, socket and all and the wire was jury rigged to bypass it which failed. Not quite sure how that happened, though haven't any recollections either way on whether that light ever worked. Either way was a short in the wire, so end up having a spare FF21-67-83Y A from ebay presumably working, and a spare FF14 675 (dealership first said I needed this) also from ebay presumably working if anyone's around Northern Virginia and needs one. Would've had 2 spare FF21s but apparently they lost the first one I brought them. So hopefully ends this giant mess of a saga, well that and the first guy that looked at in the dealership unplugged my radio and they didn't plug it back in, so need to take it back in for that.
sintri is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
{WTB} WTB WTB - S2 Fuel Pump & BHR Ignition kit - WTB WTB NYC Drift King RX-8 Parts For Sale/Wanted 1 05-31-2013 04:25 PM
{WTB} WTB WTB WTB Rx8 Car Cover NYC Drift King RX-8 Parts For Sale/Wanted 1 01-31-2011 01:20 PM
{WTB} WTB WTB WTB ------- Coilover Suspension NYC Drift King RX-8 Parts For Sale/Wanted 13 10-12-2010 06:06 PM
WTB WTB Wtb ---- L + R Tail lights. NYC Drift King RX-8 Parts For Sale/Wanted 7 04-16-2010 06:45 AM
WTB WTB WTB --------------- Mazdaspeed FRONT bumper------- NYC Drift King RX-8 Parts For Sale/Wanted 10 03-11-2008 11:55 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 09:13 AM.


© 2018 MH Sub I, LLC dba Internet Brands
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.