RX8Club.com
Register Photo Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read RX8 Live!Used CarsVendor Directory

Go Back   RX8Club.com > Series I Tech & Performance > Series I Trouble Shooting
Sign in using an external account
Register Forgot Password?

Welcome to RX8Club.com!
Welcome to RX8Club.com,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join RX8Club.com today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 07-21-2012, 02:28 PM   #1
New Member
 
Trader Score: (0)
Join Date: Jul 2012
Location: Texas
Posts: 7
Unhappy My RX8 will not turn over...

Hello Everybody,
This is my very first post...I just recently purchased a used 2004 RX8 with 83K miles. Car is awesome, I just love the way it drives and it's killing me just watching it in the driveway not being able to drive. Anyway, yesterday I changed the oil on it, as I finished I turned the car on and was just letting it idle...I noticed the engine was a little bit more dirty than I like it to be so I tried to wash some of the dirt off with my water house. As I was putting the hose away, the car stalled...I tried to start it but nothing. I attempted it a couple more times (conscious of the flooding issue) and then it seemed like it wanted to start but it didn't. I decided to just leave it over night and not touch it..this morning I tried to start it and it turned over the first two times I tried, but now when I crank the ignition only the dash lights turn on and the car doesn't turn over. Can anybody suggest anything please. I even went as far as changing the spark plugs on it. I have also tried the flooding procedures, but even if it was flooded the engine should still turn, right? Help pleasee...
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on RX8Club.com!
magallcg is offline   Reply With Quote
Old 07-21-2012, 02:32 PM   #2
Modulated Moderator
 
dannobre's Avatar
 
Trader Score: (3)
Join Date: Feb 2004
Location: Smallville
Posts: 10,365
Send a message via MSN to dannobre Send a message via Yahoo to dannobre
Sounds like the battery may be down....and you got something wet...

Likely flooded now

Recharge battery, let it dry off....check fuses...and do the deflood procedure or pull start it
__________________


dannobre is online now   Reply With Quote
Old 07-21-2012, 02:57 PM   #3
I HATE SPEEDBUMPS!
 
monchie's Avatar
 
Trader Score: (0)
Join Date: Nov 2007
Location: Las Vegas, NV
Posts: 8,797
You may have wet some electrical components when your cleaning it, and now it's not starting.
__________________


U.S. Army Tanker 1994-1997
2004 Mazda 6i (Hellasunk)
2005 Mazda RX8 (Hellasunk)
monchie is offline   Reply With Quote
Old 07-21-2012, 04:23 PM   #4
New Member
 
Trader Score: (0)
Join Date: Jul 2012
Location: Texas
Posts: 7
I think it is something electrical...I really don't think it's flooded, bcus if it was flooded it would at least turn over, right? It just doesnt do anything...I turn the key to on for 5 seconds..then try to crank but it just doesn't do anything...I guess it's off to the dealer on Monday...gosh, I'm not going to sleep all weekend wondering how much that's going to be...
magallcg is offline   Reply With Quote
Old 07-21-2012, 04:27 PM   #5
New Member
 
Trader Score: (0)
Join Date: Jul 2012
Location: Texas
Posts: 7
Quote:
Originally Posted by dannobre View Post
Sounds like the battery may be down....and you got something wet...

Likely flooded now

Recharge battery, let it dry off....check fuses...and do the deflood procedure or pull start it
I was jumping it with another car when I was trying to start it this morning...wouldn't the car turn over if it was flooded? It just doesn't do anything, only the dash lights come on..
magallcg is offline   Reply With Quote
Old 07-21-2012, 04:33 PM   #6
#225 of 1000
 
EricB's Avatar
 
Trader Score: (7)
Join Date: Jul 2011
Location: Dirty Jerz
Posts: 2,131
http://www.facebook.com/f1gurin F1GURIN F1GURIN F1GURIN Agent_Mulder
Send a message via AIM to EricB Send a message via Skype™ to EricB
not the brightest idea to go guns (hose) a blazin' in the engine bay.
__________________

My install/Picture thread
EricB is offline   Reply With Quote
Old 02-02-2013, 08:36 AM   #7
Registered User
 
Trader Score: (0)
Join Date: Feb 2013
Posts: 3
i have a similar problem i have an 05 rx8 its drives fine but the other night i was backing into the drive way (tight squeeze) and i stalled it and tried to start it again a few times and it wouldnt start im guessing must likely flooded its happened once before and i fixed it but this time i connected the jump leads and tried to start it and nothing it wasnt cranking just one click when i turn the key i know its a vague description but im just wondering of any recommendations to my next step to fix this. it had no hot start issues but starter coils pulgs leads and battery are all original from 05.
rotarystu is offline   Reply With Quote
Old 02-02-2013, 11:03 AM   #8
Rockie Mountain Newbie
 
Trader Score: (0)
Join Date: Mar 2011
Location: Denver, CO
Posts: 1,349
Quote:
Originally Posted by rotarystu View Post
starter coils plugs leads and battery are all original from 05.
You might want to change those.

Also, remove the spark plugs, remove the fuel pump fuse, crank engine until no more crap gets spit out of the spark plug holes. Install new ignition components, and start engine.

BC.
Bladecutter is offline   Reply With Quote
Old 02-02-2013, 11:24 AM   #9
Modulated Moderator
 
dannobre's Avatar
 
Trader Score: (3)
Join Date: Feb 2004
Location: Smallville
Posts: 10,365
Send a message via MSN to dannobre Send a message via Yahoo to dannobre
Sounds like a battery, power, fuse issue if it isn't turning over. Likely need a new battery
dannobre is online now   Reply With Quote
Old 02-02-2013, 11:24 AM
RX8Club
Mazda RX8




Paid Advertisement


 
 
 
Reply

Tags
04, 2004, battery, car, crank, engine, mazda, rx, rx8, turn, turning, turnover, washing, water, wont

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
All content Copyright 2007 by Internet Brands, Inc.
Emails Backup