Introducing the Brand New Mobile App: Garage Talk! - RX8Club.com

Go Back  RX8Club.com > General Topics > Website-related Suggestions
Reload this Page >

Introducing the Brand New Mobile App: Garage Talk!

Notices
Website-related Suggestions Help us make this forum better.

Introducing the Brand New Mobile App: Garage Talk!

Reply

 
 
 
Old 06-01-2015, 05:58 PM
  #1  
IB Staff
Thread Starter
 
IB Jose's Avatar
 
Join Date: Dec 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Introducing the Brand New Mobile App: Garage Talk!

IB Jose is offline  
Reply With Quote
Old 04-20-2016, 04:29 PM
  #2  
New Member
 
Join Date: Apr 2016
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
i put in new coils and plugs and wires and still no spark what do i change next on a 2004 mazda rx8
larryd is offline  
Reply With Quote
Old 04-20-2016, 04:31 PM
  #3  
New Member
 
Join Date: Apr 2016
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
what controls the spark like is it one of those boxes under the computer
larryd is offline  
Reply With Quote
Old 04-20-2016, 04:58 PM
  #4  
New Member
 
Join Date: Apr 2016
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
HI no spark wtf

i put in new coils and plugs and wires and still no spark what do i change next on a 2004 mazda rx8

what can i do to get it running again
larryd is offline  
Reply With Quote
Old 04-20-2016, 06:05 PM
  #5  
Jedi Master
iTrader: (7)
 
Jedi54's Avatar
 
Join Date: Mar 2004
Location: The Dark Side
Posts: 21,112
Thanked 458 Times in 300 Posts
larryd: try posting your issue in the New Members section and I'm sure we'll be able to help you out a bit more there. New Member Forum - RX8Club.com
Jedi54 is offline  
Reply With Quote
Old 07-06-2016, 02:27 AM
  #6  
New Member
 
Join Date: Jul 2016
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Hi guys
I've just purchased a 2004 RX8 that won't start.
It's had a flat battery, which was disconnected for charging.
The owner said it was running fine, stopped then when he came back and tried starting it, it had turnover but no start.
Replaced TDC sensor, erased code, which still recurs,
The fob doesn't work, "new battery, and programed", nothing!
Checked all fuses in engine bay,
There is a lot for oil around the Engine?
What have I missed??
C
Diablo-Rx8 is offline  
Reply With Quote
Old 07-06-2016, 08:11 AM
  #7  
Registered
 
Join Date: May 2014
Location: Salem, CT
Posts: 424
Thanked 5 Times in 5 Posts
Originally Posted by Diablo-Rx8 View Post
Hi guys
I've just purchased a 2004 RX8 that won't start.
It's had a flat battery, which was disconnected for charging.
The owner said it was running fine, stopped then when he came back and tried starting it, it had turnover but no start.
Replaced TDC sensor, erased code, which still recurs,
The fob doesn't work, "new battery, and programed", nothing!
Checked all fuses in engine bay,
There is a lot for oil around the Engine?
What have I missed??
C
Make your own thread in the New Member section about your issues and what you've tried. Additionally, read the stickies/announcements in the New Member section.
Love_Hounds is offline  
Reply With Quote
Old 09-11-2016, 11:00 PM
  #8  
Junior Member
 
Join Date: Sep 2016
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Rx8 key fob

Big problem here!! I don't have the actual key to my car but I have the key fob my key fob has been working and all of a sudden it won't work to start my car. It still unlocks and locks the car but not to start the car how do I fix this problem please help me
Scott Barton is offline  
Reply With Quote
Old 11-08-2016, 11:20 PM
  #9  
New Member
 
Join Date: Nov 2016
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Premix

I need help. I tried going to auto zone asking what is the best for premixing my 2004 rx8 and he told me its a 4 stroke and that premixing would do more harm than good. Is that true or should I actually premix?
lovingmyrx8 is offline  
Reply With Quote
Old 11-08-2016, 11:22 PM
  #10  
New Member
 
Join Date: Nov 2016
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by Diablo-Rx8 View Post
Hi guys
I've just purchased a 2004 RX8 that won't start.
It's had a flat battery, which was disconnected for charging.
The owner said it was running fine, stopped then when he came back and tried starting it, it had turnover but no start.
Replaced TDC sensor, erased code, which still recurs,
The fob doesn't work, "new battery, and programed", nothing!
Checked all fuses in engine bay,
There is a lot for oil around the Engine?
What have I missed??
C
your engine is probably flooded man try looking at a video to unflood it its easier than trying to explain
lovingmyrx8 is offline  
Reply With Quote
Old 11-10-2016, 12:25 AM
  #11  
Scrappy
iTrader: (1)
 
Legot's Avatar
 
Join Date: Jun 2014
Location: Gilbert, AZ
Posts: 1,181
Thanked 3 Times in 3 Posts
This is now officially my favorite thread.
Legot is offline  
Reply With Quote
The Following User Says Thank You to Legot For This Useful Post:
bluetii (08-16-2017)
Old 11-10-2016, 04:14 AM
  #12  
You gonna eat that?
iTrader: (1)
 
BigCajun's Avatar
 
Join Date: Jan 2013
Location: Kansas City, Mo.
Posts: 4,373
Thanks: 0
Thanked 619 Times in 486 Posts
I don't understand why troubleshooting questions are being asked in a thread announcing a mobile app.
BigCajun is offline  
Reply With Quote
The Following User Says Thank You to BigCajun For This Useful Post:
bluetii (08-16-2017)
Old 11-20-2016, 08:21 PM
  #13  
New Member
 
Join Date: Nov 2016
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Clutch

I put a stage 3 clutch in my 2006 rx8 and it seems like it's not engaging. Slave cylinder seems be working and I bleed the system. Anyone have any other ideas?
Dannyandhis8 is offline  
Reply With Quote
Old 11-22-2016, 05:48 PM
  #14  
Registered
iTrader: (1)
 
Join Date: May 2016
Location: Colo'freakin'rado
Posts: 542
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by Dannyandhis8 View Post
I put a stage 3 clutch in my 2006 rx8 and it seems like it's not engaging. Slave cylinder seems be working and I bleed the system. Anyone have any other ideas?
This is a thread dedicated to a new mobile app for forum browsing.
CelestialGryphon is offline  
Reply With Quote
Old 11-26-2016, 10:29 PM
  #15  
New Member
 
Join Date: Nov 2016
Location: Florida
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by lovingmyrx8
your engine is probably flooded man try looking at a video to unflood it its easier than trying to explain
Try talking your spark plugs out, leave em out over night an put em back in in morning. Worked for me when mine flooded
Bree is offline  
Reply With Quote
Old 11-26-2016, 10:43 PM
  #16  
New Member
 
Join Date: Nov 2016
Location: Florida
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts

Last edited by Bree; 11-26-2016 at 11:13 PM.
Bree is offline  
Reply With Quote
Old 04-07-2017, 02:52 PM
  #17  
New Member
 
Join Date: Apr 2017
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
hi
i was wondering if anyone can give advise, i let my mazda rx8 2007 sitting for the last 2 months without starting as she ran out of fuel and i went on holiday .came back put fuel and now she is cranking but not starting any advice welcome.
thanks in advance.
magsrroku is offline  
Reply With Quote
Old 05-10-2017, 04:40 AM
  #18  
New Member
 
hennievz's Avatar
 
Join Date: May 2017
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
flywheel

hey everyone, i have a 08 rx8 , i want to take my flywheel to engineering so that they can make it lightweight for me.. does anyone have engineering specs for me..and i want to know if i need to change or adjust any counter weights , do i need to light weight the front weight and with how much ? i need engineering specs plz..
hennievz is offline  
Reply With Quote
Old 05-10-2017, 04:50 AM
  #19  
New Member
 
hennievz's Avatar
 
Join Date: May 2017
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by magsrroku View Post
hi
i was wondering if anyone can give advise, i let my mazda rx8 2007 sitting for the last 2 months without starting as she ran out of fuel and i went on holiday .came back put fuel and now she is cranking but not starting any advice welcome.
thanks in advance.
hey..i had the same problem once, try loosening the fuel lines in the front by the engine switch ign on and see if fuel is coming thru, check battery volts , check spark, if all is correct try to reset. then try again
hennievz is offline  
Reply With Quote
Old 05-11-2017, 01:37 PM
  #20  
^^^ Fluent in snark.
 
NotAPreppie's Avatar
 
Join Date: Mar 2006
Location: Chicago, IL, USA, North America, Earth, Sol System, Sector ZZ9 Plural Z Alpha, Milkyway, Universe
Posts: 2,944
Thanked 360 Times in 292 Posts
I just discovered this thread and I have to say...

It is MAGICAL!
NotAPreppie is online now  
Reply With Quote
The Following User Says Thank You to NotAPreppie For This Useful Post:
bluetii (08-16-2017)
Old 05-12-2017, 02:02 PM
  #21  
Sicker than your average
 
Nisaja's Avatar
 
Join Date: Nov 2012
Location: Colombo, Sri Lanka
Posts: 991
Thanks: 0
Thanked 6 Times in 5 Posts
Why hasn't this app been updated in years? The iOS version is still made for the iPhone 5s screen! Everything looks so blown up on a 7/7+. Honestly, the mobile website is better lol.
Nisaja is offline  
Reply With Quote
Old 06-26-2017, 01:06 PM
  #22  
Registered
 
Join Date: Oct 2007
Location: So. Cal
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Is it worth it to get the app? The reviews in the past store are pretty bad.
sk8rg2000 is offline  
Reply With Quote
Old 07-01-2017, 08:06 PM
  #23  
Koi no Ousama
iTrader: (25)
 
TeamRX8's Avatar
 
Join Date: Apr 2005
Posts: 20,547
Thanks: 0
Thanked 276 Times in 228 Posts
Why even bother? All mobile sites and apps suck imo. Just go to the bottom of the website page and click the "view full site" (desktop) button
TeamRX8 is offline  
Reply With Quote
Old 07-02-2017, 01:59 AM
  #24  
Sicker than your average
 
Nisaja's Avatar
 
Join Date: Nov 2012
Location: Colombo, Sri Lanka
Posts: 991
Thanks: 0
Thanked 6 Times in 5 Posts
Yeah I'm on iOS and this app is awful. It hasn't been updated in 4 years!
Nisaja is offline  
Reply With Quote
Old 08-11-2017, 10:42 AM
  #25  
New Member
 
Join Date: Aug 2017
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
UK Cat converter failure

Dear RX8 owners

Our garage is asking us to change the cat and the 4 coils of our RX8 although we have never experienced any misfires in the 13 years we had our car and had an MOT carried-out 5 months ago which spotted no engine issue.

We brought our low mileage car for a technical maintenance check at this garage and as we were going to pick up the car we got a call last Friday from the garage saying that there was a problem with the engine as the car would no longer start. We suspect that the garage flooded the engine by switching on and off the engine on their parking space immediately and did only partial cleaning. They changed a faulty spark plug and said that it was all sorted. When I picked up the car on Tuesday it stopped abruptly on the road after driving less than a mile. The garage is now saying that the cat and 4 coils need changing. This diagnostic feels suspicious as it happened after their maintenance check and spark replacement and also because we never had misfires on the past.

What would you suggest for us to ask to our garage to test their honesty? Also could you possibly let us know whether coils can be extracted from the car to allow us to see us In what state they are? What price should we be quoted for that repair? Thank you in advance for your support.

Olly
ASL2017 is offline  
Reply With Quote

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Introducing the Brand New Mobile App: Garage Talk!


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.