Notices
Series I Trouble Shooting This is the place to learn more about or discuss any issues you're having with your RX-8

Rough idle, popping/sputtering exhaust, sounds and feels off...

Old 01-30-2012, 08:26 PM
  #1  
Registered User
Thread Starter
 
Join Date: Aug 2011
Location: Victoria, BC
Posts: 61
Likes: 0
Received 0 Likes on 0 Posts
BC Rough idle, popping/sputtering exhaust, sounds and feels off...

Ok, so Please dont jump down my throat about searching. I have been on this site for 6 months and read so much stuff my head is going to explode.

Ive had my 2007 MT6 since september of this year, and only put about 2500km's on it. I stored it for about two months while I sold my other car.
Its got just shy of 68,000KM's on it, stock everything except plugs and an upper o2 sensor.

The car has been running fine all along, but it seems every day this is a new or different issue that comes and goes.

Recently its been doing a bit of chugging under consistant rpm around 55-6500. Does this when still warming up so temperature about half the way to normal. Some times it also does this when its already warm. Yes I know not to rev it when its not fully warmed.
-when this happens, it feels similar to clogged injectors on a conventional engine, where the power comes and goes rapidly.

Also, yesterday it started making a funny new exhaust note that almost sounds grindy in a way, also has a bit of a duality to it that wasnt there before. I have noticed that when this started, the idle has gotten rougher and can bounce around a few hundred rpm either way. if you sit and listen, you can hear and feel a bit of a popping in the exhaust, but I am confident that this is not the same thing that people keep saying is normal for our cars. When ever it makes these sounds, the car shudders, and the tach bouncing stated above occurs.

both of these issues seemed to start or get worse a few weeks ago when we had a pretty decent snowfall. It was enough that a fair amount of snow found its way into the air dam. I did my best to keep this clear, but the car does have the mazdaspeed CAI.

I have in the past done all of the regular things like cleaning the MAF, resetting the ecu/fuel trims and most of the regular checks, but I havent done them again since the last issues have showed up as I have been lacking daylight.

There have been no CEL's thrown, but the TCS was giving me a bit of trouble and grief well after the snow left. I dont have an OBDII reader.

Again, stock 2007 6MT, mazdaspeed CAI
67,700KM's
always 94 octane (except for one recent 91 fillup)
Obsidian is offline  
Old 01-30-2012, 08:40 PM
  #2  
Time for boost...
iTrader: (24)
 
RX8Soldier's Avatar
 
Join Date: Jun 2010
Location: Canada
Posts: 5,414
Likes: 0
Received 14 Likes on 13 Posts
How recent was your fill-up? Maybe bad gas?

Check things like:
Plugs/coils
eccentric shaft position sensor (commonly called "ess" sensor)
MAF sensor (water/snow could have come into contact)
RX8Soldier is offline  
Old 01-30-2012, 09:47 PM
  #3  
Registered User
Thread Starter
 
Join Date: Aug 2011
Location: Victoria, BC
Posts: 61
Likes: 0
Received 0 Likes on 0 Posts
Thanks for the quick reply.
The plugs and upper o2 sensor were replaced less than 1000kms ago, and I fill it up once a week.

I do need to check the MAF again; I just havent had enough daylight time to check it.

I want to get the BHR coils at some point, but its a pain getting anything shipped to Canada with all of the heavy duties applied to a sale.

I did a bit of searching, but are there any simple ways to test your coils without a voltage testor?
Obsidian is offline  
Old 01-30-2012, 10:01 PM
  #4  
Time for boost...
iTrader: (24)
 
RX8Soldier's Avatar
 
Join Date: Jun 2010
Location: Canada
Posts: 5,414
Likes: 0
Received 14 Likes on 13 Posts
You don't need day light to clean MAF sensor. Unscrew, unplug, bring inside, spray with electrical contact cleaner, air-dry, replace.

Do you have any access to get across the boarder? If it's not a hassle, find a place to ship south of the boarder, then pick up when you get a chance. Or, visit your local car forums and see what options members offer.

check this DIY for coils https://www.rx8club.com/series-i-do-yourself-forum-73/diy-testing-all-rx-8-coils-gm-ls2-yukon-coils-sparkplug-wires-222641/
RX8Soldier is offline  
Old 01-30-2012, 10:13 PM
  #5  
Registered User
Thread Starter
 
Join Date: Aug 2011
Location: Victoria, BC
Posts: 61
Likes: 0
Received 0 Likes on 0 Posts
Thing is, I live on Vancouver island, off the coast of BC. Its the capital of BC here in victoria, but to get to the mainland on the ferry and back is $140, and that doesnt even include gas. Kind of defeats the purpose.
I have joined the Vancouver RX8 Club, some of them have cross border mailboxes, but still its a ferry ride away, ive never met most of them, and here in victoria there is only a pretty cliquey import scene as were only around 350000 people, mostly starving students or seniors, lol.

EDIT: I just went out and did the MAF clean... Bit tricky when your landlord hasnt returned your toolbox yet and my socket set doesnt have allen keys.... The intake and the sensor are spotless however. Not so much as a grain of dust inside the CAI tube. Cleaned anyways.

Last edited by Obsidian; 01-30-2012 at 10:41 PM. Reason: see edit
Obsidian is offline  
Old 01-30-2012, 10:42 PM
  #6  
Time for boost...
iTrader: (24)
 
RX8Soldier's Avatar
 
Join Date: Jun 2010
Location: Canada
Posts: 5,414
Likes: 0
Received 14 Likes on 13 Posts
haha I know full well where Victoria is :P I see your point.
Dig through the club to see how people deal with companies like USPS/FED EX/UPS.

Here in Winnipeg, MB, I don't accept delivery of an item from the driver. I then go to the depot and get a few signatures. Voila! No duties/brokerage fees!
RX8Soldier is offline  
Old 01-30-2012, 10:48 PM
  #7  
Registered User
Thread Starter
 
Join Date: Aug 2011
Location: Victoria, BC
Posts: 61
Likes: 0
Received 0 Likes on 0 Posts
what do you mean you go to the depot and get a few signatures? You mean give?

I have dealt a fair bit with shipping in the past. I tend to avoid UPS the most, fedex is hit and miss, and we all know USPS.
Ive done a bit of reading on how best to avoid these things but nothings ever consistant it seems.
Obsidian is offline  
Old 01-30-2012, 11:04 PM
  #8  
Time for boost...
iTrader: (24)
 
RX8Soldier's Avatar
 
Join Date: Jun 2010
Location: Canada
Posts: 5,414
Likes: 0
Received 14 Likes on 13 Posts
yeah, sorry- give a few signatures.

However, I think that BHR ignition is worth even the fees. It pays for itself in no time, as you only need to worry about changing plugs when they go bad
RX8Soldier is offline  
Old 01-30-2012, 11:17 PM
  #9  
Registered User
Thread Starter
 
Join Date: Aug 2011
Location: Victoria, BC
Posts: 61
Likes: 0
Received 0 Likes on 0 Posts
to be honest, It would be cheaper to get the BHR kit then to stay stock. I could order the coils from a third party; but I let the stealership do it, they want over $200 per coil! (*cough*heartattack*cough*)


Anyway, I just did the MAF clean, did the NVRAM and the KAM reset and took it for a 20 minute drive. Feels exactly the same, still making the noises and as before is a bit down on power..
Obsidian is offline  
Old 01-30-2012, 11:19 PM
  #10  
Time for boost...
iTrader: (24)
 
RX8Soldier's Avatar
 
Join Date: Jun 2010
Location: Canada
Posts: 5,414
Likes: 0
Received 14 Likes on 13 Posts
have you checked your CAT? Check for glowing around the O2 sensor
RX8Soldier is offline  
Old 01-30-2012, 11:22 PM
  #11  
Registered User
Thread Starter
 
Join Date: Aug 2011
Location: Victoria, BC
Posts: 61
Likes: 0
Received 0 Likes on 0 Posts
No I haven't checked the cat yet. I'll try and check tomorrow morning on the way to work though. I doubt it's hot enough to glow right now.
Thanks for your input man, I'll get back to you tomorrow. Have a good night!
Obsidian is offline  
Old 01-31-2012, 06:43 PM
  #12  
Registered User
Thread Starter
 
Join Date: Aug 2011
Location: Victoria, BC
Posts: 61
Likes: 0
Received 0 Likes on 0 Posts
Still doing the same thing today. I managed to get a look at the cat this morning. 25 minute commute, so not a particularly hard drive, but I noticed at least that the lower o2 bung was glowing a bit. Does that help?
Obsidian is offline  
Old 01-31-2012, 08:20 PM
  #13  
Registered User
Thread Starter
 
Join Date: Aug 2011
Location: Victoria, BC
Posts: 61
Likes: 0
Received 0 Likes on 0 Posts
I am wondering, if on further reading that the cat is bad, and probably caused by bad coils. It definitely feels like a slight misfire, though not enough to cause a CEL. I do notice the sulfury smell on occasion, sometimes inside the car.

With less than 68000k on the car, the cat should still be covered by warranty, no?
Also, if I wasn't ready to drop $600 on the BHR kit, where is a cheap place in Canada to get the stock coils? I am not paying the stealership $200+ per coil...
Obsidian is offline  
Old 02-01-2012, 08:48 PM
  #14  
Registered User
Thread Starter
 
Join Date: Aug 2011
Location: Victoria, BC
Posts: 61
Likes: 0
Received 0 Likes on 0 Posts
Still waiting for a response...
Obsidian is offline  
Old 02-01-2012, 10:38 PM
  #15  
Time for boost...
iTrader: (24)
 
RX8Soldier's Avatar
 
Join Date: Jun 2010
Location: Canada
Posts: 5,414
Likes: 0
Received 14 Likes on 13 Posts
Glowing by the O2 bung is "usually" bad CAT. If you can, pull it down and visually inspect. Or, take it to the dealer. We also have the 8year/80k mile warranty (I think that equates to 120k km's) and have them inspect and replace.
However, if the CAT is not the issue, you will be charged for your service...

Sorry, I didn't read the rest of the thread- Did you ever get a chance to check plugs/coils/ess?
RX8Soldier is offline  
Old 02-01-2012, 10:48 PM
  #16  
Registered
iTrader: (3)
 
wahkupup's Avatar
 
Join Date: Nov 2011
Location: Northern Frozen wasteland
Posts: 70
Likes: 0
Received 0 Likes on 0 Posts
I would Clean your air filter, the salt on the road will clog it very fast. Then I'd pull your spark plugs and see what they have to say. By the way I am up in the Comox Valley, shoot me a pm if your ever up this way.
wahkupup is offline  
Old 02-02-2012, 12:15 AM
  #17  
Registered User
Thread Starter
 
Join Date: Aug 2011
Location: Victoria, BC
Posts: 61
Likes: 0
Received 0 Likes on 0 Posts
The plugs as I said up above are new. I made an appointment for monday morning to have some stuff looked at, but I will try and do some stuff myself this weekend. I got a really nice floor jack for christmas I have yet to use...

If I pull down the cat, am I going to break any gaskets?

When I talked to the service guy on the phone this morning, I got treated like an idiot as soon as I said ive been reading up on it. I should know better than to even mention that, lol.
If the cat was failing, should I not be getting a CEL showing inconsistencies between the two o2 sensors?

Anyway, been working 12 hours every day so havent been able to do anything serious yet.

I will take the air filter off again, but its in a mesh bag; when I looked at it before, it looked pretty spotless compared to when I last cleaned it; also not so much as a speck of dust in the CAI tube by the MAF
Obsidian is offline  
Old 02-02-2012, 01:34 AM
  #18  
Mod is as Mod does.
iTrader: (1)
 
StealthTL's Avatar
 
Join Date: Mar 2003
Location: A Pacific Island.
Posts: 7,153
Received 33 Likes on 29 Posts
I have a code reader, and I'm on the Island, but not much use if there are no codes.....

When you cleaned the MAF, did you get the spray right up inside? the MAF wires are in the head of the sensor.

Doesn't sound like coils - no misfire codes, but could be.
StealthTL is offline  
Old 02-02-2012, 06:49 AM
  #19  
Registered User
Thread Starter
 
Join Date: Aug 2011
Location: Victoria, BC
Posts: 61
Likes: 0
Received 0 Likes on 0 Posts
Yes, I was pretty thorough. The maf is spotless.

Man, there are a few islanders on here!
Obsidian is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Dokuji
Series I Trouble Shooting
8
11-01-2016 02:51 PM
harithac
New Member Forum
15
08-26-2015 09:24 AM
ladnarf1
New Member Forum
3
08-08-2015 06:59 AM
dbarber
Series I Trouble Shooting
14
07-25-2015 01:34 PM
netrovers
New Member Forum
6
07-20-2015 03:32 AM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Rough idle, popping/sputtering exhaust, sounds and feels off...


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.