Oil light on after hard driving/track use. - RX8Club.com

Go Back  RX8Club.com > Series I Tech & Performance > Series I Trouble Shooting
Reload this Page >

Oil light on after hard driving/track use.

Notices
Series I Trouble Shooting This is the place to learn more about or discuss any issues you're having with your RX-8

Oil light on after hard driving/track use.

Old 03-16-2019, 09:58 AM
  #1  
Registered
Thread Starter
 
thebubbadog's Avatar
 
Join Date: Sep 2014
Location: North carolina
Posts: 167
Thanked 13 Times in 13 Posts
Question Oil light on after hard driving/track use.

I think I remember seeing something about this a while ago but after looking I couldn't really find any good details about it, so I'm sure someone can give some good details about it. I do some hard road driving comparable to track driving and sometimes once I get close to the end or about 1/2 thought my oil light will come on and it will stay on for sometime or until I turn my car off it always make me a little worried that maybe it's oil starving from oil moving around in the oil pan and it sucks some air into it or something, or does the oil sensor just not see oil for 1 or 2 second's then does that cause the oil light to come on? I just want to make sure that I'm not oil starving my car, yes it's full of oil and not low.
thebubbadog is offline  
Old 03-16-2019, 10:54 AM
  #2  
Chief Meteobraptologist
iTrader: (1)
 
Loki's Avatar
 
Join Date: Jun 2009
Location: Montreal
Posts: 4,437
Thanked 283 Times in 251 Posts
Is it coming on or flashing on? I guess an obvious question is how is your oil level?

Mine does this too after a track day (like, on the way home), but not at the track itself. There is a known issue that can arise with oil level sensors with age where they do this, possible the heat agitates it somehow.
Loki is offline  
Old 03-16-2019, 11:07 AM
  #3  
Registered
Thread Starter
 
thebubbadog's Avatar
 
Join Date: Sep 2014
Location: North carolina
Posts: 167
Thanked 13 Times in 13 Posts
It just come's on and stays on. it doesn't flash or anything like that from what I remember. The oil level's are fine.
thebubbadog is offline  
Old 03-16-2019, 08:35 PM
  #4  
^^^ Fluent in snark.
 
NotAPreppie's Avatar
 
Join Date: Mar 2006
Location: Chicago, IL, USA, North America, Earth, Sol System, Sector ZZ9 Plural Z Alpha, Milkyway, Universe
Posts: 3,132
Thanked 398 Times in 325 Posts
There's a TSB for 2004 and (I think) early 2005 cars for this issue.
NotAPreppie is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bsteimel
Series I Trouble Shooting
26
07-18-2012 07:44 PM
tofu_box
Series I Tech Garage
27
02-11-2012 07:54 AM
mateo
Series I Tech Garage
102
06-26-2010 09:01 AM
Loki
Series I Trouble Shooting
8
09-05-2009 07:55 PM
MADRX8
RX-8 Discussion
5
10-27-2004 07:56 AM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Oil light on after hard driving/track use.


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.