Notices

Rx8 Key fob not being transmitted to car.

Old 07-11-2019, 05:06 PM
  #1  
Registered
Thread Starter
 
thebubbadog's Avatar
 
Join Date: Sep 2014
Location: North carolina
Posts: 221
Received 25 Likes on 24 Posts
Rx8 Key fob not being transmitted to car.

I had my key fob in my 04 rx8 stop working on me, I thought it was the remote battery. So I replaced the battery still didnít work tried programming the key to the car again by turning it on/off 3 times and opening/closing the door 3 times still nothing. Bought a replacement key fob tried programming it to the car nothing.

Old key fob
visteon model: 41848
fcc id: kpu41805
ic: 4238a-12076

New key fob
fcc id: 2aovx-mz1
model: 2aovx-4b
part #: 41848

vin: JM1FE173240130191

Possible problem's:
#1 New key fob might not be for the right car but Iím unsure, There seemed to be several reviews on it and they all seemed to work on there 04.
https://www.amazon.com/gp/product/B06Y2DHB6P/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1 https://www.amazon.com/gp/product/B06Y2DHB6P/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1
#2 Since the old key fob didnít work after battery replacement it leads me to believe its what ever receives the key fob, But I don't know were it's located at?

But any help that you could give me on this would be great!
thebubbadog is online now  
Old 07-11-2019, 05:40 PM
  #2  
You gonna eat that?
iTrader: (1)
 
BigCajun's Avatar
 
Join Date: Jan 2013
Location: Kansas City, Mo.
Posts: 4,579
Received 804 Likes on 627 Posts
Wrong keyfob.
I went through it too, it's a '04 issue.
It's a switchblade, I had the key cut for manual opening jic, but I bought it mainly for the fob.
Visteon 41525 I think.
I got mine from the Remote Superstore, $85.
BigCajun is offline  
Old 07-11-2019, 05:44 PM
  #3  
You gonna eat that?
iTrader: (1)
 
BigCajun's Avatar
 
Join Date: Jan 2013
Location: Kansas City, Mo.
Posts: 4,579
Received 804 Likes on 627 Posts
Originally Posted by BigCajun View Post
Wrong keyfob.
I went through it too, it's a '04 issue.
It's a switchblade, I had the key cut for manual opening jic, but I bought it mainly for the fob.
Visteon 41525 I think.
I got mine from the Remote Superstore, $85.
Yeah, post #42.

https://www.rx8club.com/series-i-tro...-214555/page2/
BigCajun is offline  
Old 07-11-2019, 05:50 PM
  #4  
You gonna eat that?
iTrader: (1)
 
BigCajun's Avatar
 
Join Date: Jan 2013
Location: Kansas City, Mo.
Posts: 4,579
Received 804 Likes on 627 Posts
You are talking about the immobilizer antenna receiving the signal from the fob I think, it's in the back bumper.
(I could be wrong, but seems like I read that once)
You can do a diagnostic check to see if it's working.
Look up the immobilizer section in this thread.

https://www.rx8club.com/series-i-do-...utputs-155947/
BigCajun is offline  
Old 07-11-2019, 06:04 PM
  #5  
Registered
Thread Starter
 
thebubbadog's Avatar
 
Join Date: Sep 2014
Location: North carolina
Posts: 221
Received 25 Likes on 24 Posts
Read thought this form https://www.rx8club.com/series-i-tro...-165856/page3/
There were several people talking about a a black box under the rear bumper but that looks like it only applies to the 06 and up with the key cards since they have a button on there door handle to open the car.
Also going to be taking my remotes to auto zone and make sure there working with there tester's.
I guess I'll try locating the black box in the trunk and cleaning that off and the connectors. apparently there are 6 antennas total. 6630A - BODY RELAYS & UNIT. Fits: Mazda Jim Ellis Mazda
There were several people saying if one antenna didn't work then the whole system wouldn't work but I'm not sure if there talking about the key cards or not?
When I'm messing around with the black box in the trunk and get done cleaning it I will also disconnect the battery and reconnect it since some people reported that working for them.

Last edited by thebubbadog; 07-11-2019 at 06:29 PM.
thebubbadog is online now  
Old 07-11-2019, 06:09 PM
  #6  
Registered
Thread Starter
 
thebubbadog's Avatar
 
Join Date: Sep 2014
Location: North carolina
Posts: 221
Received 25 Likes on 24 Posts
Originally Posted by BigCajun View Post
You are talking about the immobilizer antenna receiving the signal from the fob I think, it's in the back bumper.
(I could be wrong, but seems like I read that once)
You can do a diagnostic check to see if it's working.
Look up the immobilizer section in this thread.

https://www.rx8club.com/series-i-do-...utputs-155947/
I'm not having this problem. The car can read the chip in the key fine since there is no red key and I'm able to start the car.
Thank you for all the replies I found an older form where you were talking about you're problems with you're key fob as well

Last edited by thebubbadog; 07-11-2019 at 06:32 PM.
thebubbadog is online now  
Old 07-11-2019, 06:14 PM
  #7  
Registered
Thread Starter
 
thebubbadog's Avatar
 
Join Date: Sep 2014
Location: North carolina
Posts: 221
Received 25 Likes on 24 Posts
Originally Posted by BigCajun View Post
Wrong keyfob.
I went through it too, it's a '04 issue.
It's a switchblade, I had the key cut for manual opening jic, but I bought it mainly for the fob.
Visteon 41525 I think.
I got mine from the Remote Superstore, $85.
I have a key fob from an 06 I believe laying around I might try programming that fob to the car and see what happens. But if all else fails I guess I'll be buying a new switchblade Visteon 41525
thebubbadog is online now  
Old 07-11-2019, 06:20 PM
  #8  
Registered
Thread Starter
 
thebubbadog's Avatar
 
Join Date: Sep 2014
Location: North carolina
Posts: 221
Received 25 Likes on 24 Posts
Do you happen to know if the FCC ID and Visteon # of the (New) switch blade will have to match the key fob perfectly to the fob that worked with the car originally?
thebubbadog is online now  
Old 07-11-2019, 08:34 PM
  #9  
You gonna eat that?
iTrader: (1)
 
BigCajun's Avatar
 
Join Date: Jan 2013
Location: Kansas City, Mo.
Posts: 4,579
Received 804 Likes on 627 Posts
Originally Posted by thebubbadog View Post
Do you happen to know if the FCC ID and Visteon # of the (New) switch blade will have to match the key fob perfectly to the fob that worked with the car originally?
It's the FCC # and Visteon # I got from GraceExcel.
He's the one I heard it from.
I think it's for the switchblade, not sure if it relates to the OEM.
I think he mentioned it or linked another thread with it in the one I linked.
BigCajun is offline  
Old 07-13-2019, 06:03 PM
  #10  
Registered
Thread Starter
 
thebubbadog's Avatar
 
Join Date: Sep 2014
Location: North carolina
Posts: 221
Received 25 Likes on 24 Posts
My 06 key was broken.
I'm going to be buying this switch blade:
https://northcoastkeyless.com/shop/m...-gp7a-67-5ryb/

This was just what I was needing: https://www.rx8club.com/interior-aud...6/#post4370939
Quote:
Originally Posted by Grace_Excel
Make sure you have the right Model.

Old 2004 FOB:
Visteon Model: 41848
FCC ID: KPU41805
IC: 4238A-12076

What you need to buy:
Visteon Model: 41525
FCC ID: KPU41788
IC: 4238A-41525
thebubbadog is online now  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
CELR-8
New Member Forum
4
11-11-2018 01:57 PM
Charioteer
New Member Forum
11
10-29-2017 05:26 AM
DR. Victor Wankel
RX-8 Discussion
15
02-28-2017 01:19 PM
Digitz0070
Series I Trouble Shooting
2
01-16-2017 10:39 AM
Imidazole
Series I Trouble Shooting
19
06-05-2013 04:29 PM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Rx8 Key fob not being transmitted to car.


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.