Go Back  RX8Club.com > General Topics > RX-8 Discussion
Reload this Page >

HELP! Car advanced key light turns green and won't turn.

Notices
RX-8 Discussion General discussion about the RX-8 that doesn't fit in one of the specialty forums.

HELP! Car advanced key light turns green and won't turn.

Old 08-22-2009, 10:48 AM
  #1  
Nice Rotors
Thread Starter
iTrader: (1)
 
Are-Ex-Eight's Avatar
 
Join Date: Apr 2008
Posts: 1,058
Likes: 0
Received 4 Likes on 3 Posts
HELP! Car advanced key light turns green and won't turn.

I've searched dozens of posts and it seems like this is a PCM issue but I am really confused. I did install a footwell kit yesterday but I started the car once after I was completely finished.

Then later that night it won't turn at all, not even to ACC. The green key light blinks on the instrument panel and beeps.

I checked the fuses and all look fine. Any other ideas before I call the dealer?

Thanks guys.
Are-Ex-Eight is offline  
Old 08-22-2009, 11:18 AM
  #2  
silent assasin
iTrader: (6)
 
rodjonathan's Avatar
 
Join Date: May 2008
Location: Houston
Posts: 3,398
Likes: 0
Received 0 Likes on 0 Posts
its an 09 call the dealer and make em fix it ive never heard of this before

did you check the fuses inside the cabin?
rodjonathan is offline  
Old 08-22-2009, 11:36 AM
  #3  
Bang Bang
iTrader: (5)
 
Join Date: Apr 2009
Location: Morgantown, WV
Posts: 779
Likes: 0
Received 1 Like on 1 Post
This happened with my car after footwell lights as well. Tow it to the dealer and they'll fix it under warranty.

Try the valet key, that should be able to turn the power on.
EMart11b is offline  
Old 08-22-2009, 11:44 AM
  #4  
Nice Rotors
Thread Starter
iTrader: (1)
 
Are-Ex-Eight's Avatar
 
Join Date: Apr 2008
Posts: 1,058
Likes: 0
Received 4 Likes on 3 Posts
Checked all the fuses. The valet key won't even get the little green light to light up on the instrument panel. I can't turn it to ACC, it barely moves then locks up.


Edit - No dealer help until Monday. So frustrated.
Are-Ex-Eight is offline  
Old 08-22-2009, 11:49 AM
  #5  
Bang Bang
iTrader: (5)
 
Join Date: Apr 2009
Location: Morgantown, WV
Posts: 779
Likes: 0
Received 1 Like on 1 Post
That's weird that the valet key won't even turn it. Drive the Sky until Monday? I'm out of ideas.
EMart11b is offline  
Old 08-22-2009, 11:51 AM
  #6  
Nice Rotors
Thread Starter
iTrader: (1)
 
Are-Ex-Eight's Avatar
 
Join Date: Apr 2008
Posts: 1,058
Likes: 0
Received 4 Likes on 3 Posts
Originally Posted by EMart11b View Post
That's weird that the valet key won't even turn it. Drive the Sky until Monday? I'm out of ideas.
Yeah I was really hoping to avoid having the car towed. Sounds like exterior damage waiting to happen.
I wonder if this is all because I removed the negative post on the battery while doing the LED work. Seems kinda dumb if it is. I should have just left it all connected.
Are-Ex-Eight is offline  
Old 08-22-2009, 12:22 PM
  #7  
Nice Rotors
Thread Starter
iTrader: (1)
 
Are-Ex-Eight's Avatar
 
Join Date: Apr 2008
Posts: 1,058
Likes: 0
Received 4 Likes on 3 Posts
I don't understand why it's showing green key light but not allowing me to turn the key any further. It just locks up.
Are-Ex-Eight is offline  
Old 08-22-2009, 12:27 PM
  #8  
Bang Bang
iTrader: (5)
 
Join Date: Apr 2009
Location: Morgantown, WV
Posts: 779
Likes: 0
Received 1 Like on 1 Post
Originally Posted by Are-Ex-Eight View Post
Yeah I was really hoping to avoid having the car towed. Sounds like exterior damage waiting to happen.
I wonder if this is all because I removed the negative post on the battery while doing the LED work. Seems kinda dumb if it is. I should have just left it all connected.
Disconnecting the battery is definitely necessary. Risking grounding **** out and blowing fuses or frying things is a bad idea. When you call roadside assistance request a flatbed for towing.
EMart11b is offline  
Old 08-22-2009, 12:37 PM
  #9  
Nice Rotors
Thread Starter
iTrader: (1)
 
Are-Ex-Eight's Avatar
 
Join Date: Apr 2008
Posts: 1,058
Likes: 0
Received 4 Likes on 3 Posts
LOL sorry I am a newb. I forgot the last thing I did was reset the DSC so I had turned the wheel completely clockwise then counter then shut it off. A quick wiggle and she purred back to me.

THANK YOU to everyone offering ideas though.

Last edited by Are-Ex-Eight; 08-22-2009 at 12:40 PM.
Are-Ex-Eight is offline  
Old 08-22-2009, 12:43 PM
  #10  
Bang Bang
iTrader: (5)
 
Join Date: Apr 2009
Location: Morgantown, WV
Posts: 779
Likes: 0
Received 1 Like on 1 Post
I was going to suggest that but I figured you'd already done it LOL.
EMart11b is offline  
Old 08-22-2009, 12:47 PM
  #11  
Nice Rotors
Thread Starter
iTrader: (1)
 
Are-Ex-Eight's Avatar
 
Join Date: Apr 2008
Posts: 1,058
Likes: 0
Received 4 Likes on 3 Posts
Originally Posted by EMart11b View Post
I was going to suggest that but I figured you'd already done it LOL.
I overlooked the simple things because I just had it in my head I fried something while doing my wiring for the footwells.
Are-Ex-Eight is offline  
Old 08-22-2009, 12:53 PM
  #12  
Bang Bang
iTrader: (5)
 
Join Date: Apr 2009
Location: Morgantown, WV
Posts: 779
Likes: 0
Received 1 Like on 1 Post
I hear ya. When I did mine I was so pissed off and annoyed from laying upside down under the steering wheel in 90 degree weather that I couldn't even enjoy them when I was done :p
EMart11b is offline  
Old 08-22-2009, 01:07 PM
  #13  
Registered User
 
Join Date: Jul 2009
Location: santa cruz CALIFORNIA
Posts: 384
Likes: 0
Received 0 Likes on 0 Posts
lol. thats happend to me but i knew what it was. sometimes it looks to tight!
cidvicious831 is offline  
Old 08-22-2009, 02:59 PM
  #14  
Nice Rotors
Thread Starter
iTrader: (1)
 
Are-Ex-Eight's Avatar
 
Join Date: Apr 2008
Posts: 1,058
Likes: 0
Received 4 Likes on 3 Posts
Originally Posted by EMart11b View Post
I hear ya. When I did mine I was so pissed off and annoyed from laying upside down under the steering wheel in 90 degree weather that I couldn't even enjoy them when I was done :p
You took the seats out do yours?
I had my head in upside down and my neck is still stiff. Thank god it was raining and a little cooler.
Are-Ex-Eight is offline  
Old 08-22-2009, 03:29 PM
  #15  
Bang Bang
iTrader: (5)
 
Join Date: Apr 2009
Location: Morgantown, WV
Posts: 779
Likes: 0
Received 1 Like on 1 Post
I reclined the seat all the way back and laid down on my back with my head under the dash. There's no way to get those things in without looking foolish.
EMart11b is offline  
Old 08-22-2009, 03:46 PM
  #16  
silent assasin
iTrader: (6)
 
rodjonathan's Avatar
 
Join Date: May 2008
Location: Houston
Posts: 3,398
Likes: 0
Received 0 Likes on 0 Posts
LOL yea there really isnt! just curious what did youll wore youlls to? i took a shortcut but it worked fine (KNOCK ON WOOD) so far
rodjonathan is offline  
Old 08-22-2009, 04:32 PM
  #17  
Registered User
 
Join Date: Apr 2009
Location: Bronx (Throgs Neck), NY
Posts: 40
Likes: 0
Received 0 Likes on 0 Posts
Dude, this **** happen to me, I have a 04 rx8 and I don't have my car under warranty, apparantly my computer either got fried or resetted completely, it took the shop like three weeks to figure it out and reset the computer and enter the codes, if you take it too the deal though they should be able to fix it pretty quick, all they have to do is talk to the dealer
Azam1030 is offline  
Old 08-22-2009, 07:48 PM
  #18  
Nice Rotors
Thread Starter
iTrader: (1)
 
Are-Ex-Eight's Avatar
 
Join Date: Apr 2008
Posts: 1,058
Likes: 0
Received 4 Likes on 3 Posts
Originally Posted by rodjonathan View Post
LOL yea there really isnt! just curious what did youll wore youlls to? i took a shortcut but it worked fine (KNOCK ON WOOD) so far
Sorry but this post confuses me??? Wire it to? I used the green with black stripe and blue with red stripe using wire splicers. Then zip tied it under the dash to some metal crap.
Are-Ex-Eight is offline  
Old 08-22-2009, 09:01 PM
  #19  
Registered
iTrader: (1)
 
Join Date: Jan 2009
Location: Wantagh, Long Island
Posts: 226
Likes: 0
Received 0 Likes on 0 Posts
Haha, one time I was on the phone calling a tow truck because my car wouldn't start (before my 8). Right after I got off the phone I realized I had it in Drive. DOH!
DubbsLuvs8s is offline  
Old 06-23-2014, 10:21 AM
  #20  
New Member
 
Join Date: Aug 2013
Location: Austin tx
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
haha this just happened to me

Posted From RX8Club.com Android App
Prelude2rx8 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
delicious_dallan
New Member Forum
6
11-10-2016 06:38 PM
MarkX
New Member Forum
3
07-31-2015 07:50 AM
digitalmonkey79
New Member Forum
5
07-29-2015 12:09 AM
Peanutbuttertruffle
New Member Forum
6
07-24-2015 07:49 AM
ironj221
Series I Trouble Shooting
2
07-16-2015 10:16 PM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: HELP! Car advanced key light turns green and won't turn.


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.