Go Back  RX8Club.com > General Topics > New Member Forum
Reload this Page >

No cruise control Manual Transmission 2007 GT No CEL

Notices
New Member Forum A place for new members to get their feet wet

No cruise control Manual Transmission 2007 GT No CEL

Old 12-17-2018, 09:54 AM
  #1  
Registered
Thread Starter
 
Join Date: Sep 2018
Posts: 44
Thanked 0 Times in 0 Posts
No cruise control Manual Transmission 2007 GT No CEL

Tried to use cruise control at 65 MPH, turned it on and the cruise light comes on. I hit set and then nothing. Tried several times doesn't work. No CEL either for anything.

I was reading the the clutch has two switches one of which may affect the cruise control. Also the switch on the transmission can affect cruise control or just the switch on the steering wheel is no good.

Because there is no CEL I don't want to start removing things unnecessarily. Please advise.
Kakashi is offline  
Old 12-17-2018, 01:58 PM
  #2  
转子之魂
 
UnknownJinX's Avatar
 
Join Date: Apr 2017
Location: Victoria, BC
Posts: 2,017
Thanked 283 Times in 261 Posts
One somewhat stupid, but easy and free thing to try first is just try prying out the brake pedal with your shoe as you try engaging the CC.

Happened on my old automatic Accord. The CC wouldn't engage unless I give the brake pedal a light pry first. Eventually it didn't need the pry anymore.
UnknownJinX is offline  
Old 12-17-2018, 02:12 PM
  #3  
Chief Meteobraptologist
iTrader: (1)
 
Loki's Avatar
 
Join Date: Jun 2009
Location: Montreal
Posts: 4,459
Thanked 284 Times in 252 Posts
^^ that's a good idea. See if you the clutch safety switch (on the pedal) has full freedom of movement and try prying the clutch pedal up while trying to engage CC. See if it makes any difference.

If the cruise master switch on the steering works, I would consider it unlikely that the CC activate switch is broken. Usually those kinds of things fail at the shared harness connection, not the button itself.
Loki is offline  
Old 12-19-2018, 08:27 PM
  #4  
Registered
Thread Starter
 
Join Date: Sep 2018
Posts: 44
Thanked 0 Times in 0 Posts
I finally got around to trying what you guys said with the brake and the clutch pedal but the cruise control still doesn't set.

I took a picture underneath to show you guys how mine was set up by the previous owner.

I played with the switch with the black plastic rod and it looks like the rod will go further in a bit more but the silver bolt stops it from going in more. I was thinking about putting a shim of tape on the green part to see if that fixes it.

Also noticed I was missing a nut where the clutch bolts down anybody know the type and size?







Kakashi is offline  
Old 12-29-2018, 01:42 AM
  #5  
Registered
Thread Starter
 
Join Date: Sep 2018
Posts: 44
Thanked 0 Times in 0 Posts
I tried to shim the green button but the cruise control still won't set.

I noticed that my car won't start in neutral unless I press the clutch and brake.

Is it possible to start the car in neutral without pressing the brake or clutch? I ask because my motorcycle starts in neutral with no clutch input.
Kakashi is offline  
Old 12-29-2018, 02:41 AM
  #6  
转子之魂
 
UnknownJinX's Avatar
 
Join Date: Apr 2017
Location: Victoria, BC
Posts: 2,017
Thanked 283 Times in 261 Posts
Most manual trans cars, be it a 1999 Corolla 5-speed or an RX-8, will require you to press the clutch all the way in to crank the engine. Exceptions are pretty rare nowadays in cars.

So it looks like your neutral safety switch is fine then.

Have you looked at the brake switch yet?
UnknownJinX is offline  
Old 12-29-2018, 05:40 PM
  #7  
Registered
Thread Starter
 
Join Date: Sep 2018
Posts: 44
Thanked 0 Times in 0 Posts
Originally Posted by UnknownJinX View Post
Most manual trans cars, be it a 1999 Corolla 5-speed or an RX-8, will require you to press the clutch all the way in to crank the engine. Exceptions are pretty rare nowadays in cars.

So it looks like your neutral safety switch is fine then.

Have you looked at the brake switch yet?
No, I have not looked at the brake switch yet. I'll check later but I'm not sure what I would be looking for.
Kakashi is offline  
Old 12-31-2018, 12:11 AM
  #8  
Zoom-Freakin'-Zoom
iTrader: (5)
 
swoope's Avatar
 
Join Date: Jan 2004
Location: orlando, fl
Posts: 14,585
Thanked 23 Times in 20 Posts
had the issue a long time ago. it was a sticky neutral pos switch.

beers
swoope is offline  
Old 12-31-2018, 10:34 AM
  #9  
Registered
Thread Starter
 
Join Date: Sep 2018
Posts: 44
Thanked 0 Times in 0 Posts
Originally Posted by swoope View Post
had the issue a long time ago. it was a sticky neutral pos switch.

beers
That is the one on the transmission, right? Did you just take it off and clean it or replace it? Did you have a CEL, cause I don't.
Kakashi is offline  
Old 01-01-2019, 12:43 AM
  #10  
Zoom-Freakin'-Zoom
iTrader: (5)
 
swoope's Avatar
 
Join Date: Jan 2004
Location: orlando, fl
Posts: 14,585
Thanked 23 Times in 20 Posts
Originally Posted by Kakashi View Post
That is the one on the transmission, right? Did you just take it off and clean it or replace it? Did you have a CEL, cause I don't.
no cel. kinda found it via other issue. yes on transmission. dont recall if it is the switch towards the front or the back. they are the same switch. i think i have a new spare if you need it. shoot me a pm.

beers
swoope is offline  
Old 01-01-2019, 09:27 PM
  #11  
Registered
Thread Starter
 
Join Date: Sep 2018
Posts: 44
Thanked 0 Times in 0 Posts
I may have cracked the brake light switch forcing it off, then figured out it rotates, haha.

When installing it back, I noticed that my brake pedal is set quite low such that the brake light now stays on without touching the pedal.

Is it possible to adjust the height of the brake pedal so it will push the rod on the switch more in. The way it is right now, I have placed a layer of duct tape squares so the light will stay turned off at rest.
Kakashi is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
felipeGTx
RX-8 Parts For Sale/Wanted
6
10-07-2011 03:45 AM
Agkelos
Series I Trouble Shooting
1
09-21-2010 07:15 PM
delta31tr
Series I Trouble Shooting
19
09-20-2010 09:27 AM
Shippy
Series I Trouble Shooting
1
11-04-2009 10:21 PM
TurboII
RX-8 Discussion
13
12-20-2004 06:33 PM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: No cruise control Manual Transmission 2007 GT No CEL


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.