Go Back  RX8Club.com > Regional Forums > Mountain Forum
Reload this Page >

Had my RX-8 for 1 year - already getting a new engine!?!?!

Notices
Mountain Forum Serving MT, WY, UT, CO, NM

Had my RX-8 for 1 year - already getting a new engine!?!?!

Old 07-22-2005, 09:30 PM
  #1  
Registered User
Thread Starter
 
Join Date: Jul 2004
Location: Littleton, CO
Posts: 4
Likes: 0
Liked 0 Times in 0 Posts
Unhappy Had my RX-8 for 1 year - already getting a new engine!?!?!

I've had my 8 since May 2004 and it's been nothing short of great. That is, until last Wednesday, July 13th. I'm driving along Santa Fe in front of Arapahoe Community College northbound. Check engine light flashes three times, and the car dies completely in mid drive - at 50 mph! I coast to a stop in the middle turn lane, car will not re-start. I thought, vapor lock, hot day, no big deal. Call a tow truck, tow it to McDonald on Broadway. I call them on Saturday July 16th to pick it up. Service tech tells me they have ordered me a new engine, fully covered under warranty. My engine lost total compression in one of the rotary chambers, irreparable. So, after one year I'm getting a new engine and I'm RX-8less for the next few weeks.

Anyone else hear of this happening? The guy at McDonald said this is the second 8 this has happened to through their shop.
corockies is offline  
Old 07-23-2005, 12:34 PM
  #2  
Registered User
Thread Starter
 
Join Date: Jul 2004
Location: Littleton, CO
Posts: 4
Likes: 0
Liked 0 Times in 0 Posts
Angry Update to my RX-8 status - not good!

I just got off the phone with McDonald - they now have a full recall issued on all RX-8s due to a fuel tank issue and the car catching fire! They can't sell any more RX-8s from their lot. Worst thing is that there are no parts for a fix yet so my car is going to just sit there until they figure out how to fix this problem!

Not only am I getting a new engine, but now I cannot get my car back until they fix the fuel tank! Sheesh, I'm gonna be RX-8less for months it seems!
corockies is offline  
Old 11-15-2005, 04:57 PM
  #3  
New Member
 
Join Date: Aug 2004
Posts: 4
Likes: 0
Liked 0 Times in 0 Posts
Angry New Engine - no compression

I've got 21,000 miles on my RX8. Last year at this time, I couldn't start the car. Towed her in and it was flooded. Yesterday, it wouldn't start. I thought the same thing - flooded. I talked to the dealership today and the engine had no compression and they have to replace the engine. It sure seems like people are having a lot a problems with this car.
sneakers is offline  
Old 11-21-2005, 11:57 AM
  #4  
Lurker
 
AndyV's Avatar
 
Join Date: May 2004
Location: Denver, CO
Posts: 58
Likes: 0
Liked 0 Times in 0 Posts
Wow, that sucks. Other than the flooding / hard starts, did you notice anything else wrong with the car? Power loss?

It think I read somewhere that flooding could clog up the cat and that compression tests wouldn't be accurate somewhere, but I don't really know too much about this.

Is it a common thing to take a car in just for a compression test? I wonder if I should get mine checked just to know...
AndyV is offline  
Old 11-21-2005, 12:03 PM
  #5  
Mulligan User
iTrader: (1)
 
ZoomZoomH's Avatar
 
Join Date: Jan 2003
Location: caddyshack
Posts: 4,612
Likes: 0
Liked 0 Times in 0 Posts
if you're not feeling power loss when driving, there's no need to compression test....
ZoomZoomH is offline  
Old 11-21-2005, 12:25 PM
  #7  
Lurker
 
AndyV's Avatar
 
Join Date: May 2004
Location: Denver, CO
Posts: 58
Likes: 0
Liked 0 Times in 0 Posts
Thanks for clearing that up for me
AndyV is offline  
Old 12-06-2005, 02:39 PM
  #8  
Registered User
 
Join Date: Jun 2005
Posts: 28
Likes: 0
Liked 0 Times in 0 Posts
Originally Posted by corockies
I've had my 8 since May 2004 and it's been nothing short of great. That is, until last Wednesday, July 13th. I'm ..... So, after one year I'm getting a new engine and I'm RX-8less for the next few weeks.

Anyone else hear of this happening? The guy at McDonald said this is the second 8 this has happened to through their shop.
Out of curiosity, what engine oil were you using?
vortarian is offline  
Old 12-06-2005, 02:50 PM
  #9  
Jedi Master
iTrader: (7)
 
Jedi54's Avatar
 
Join Date: Mar 2004
Location: The Dark Side
Posts: 21,192
Liked 561 Times in 380 Posts
Originally Posted by vortarian
Out of curiosity, what engine oil were you using?
I think I know where you're going with this...

As long as it's 5w20, it should have been alright. (YES, this includes synthetic)
Jedi54 is offline  
Old 12-07-2005, 12:32 PM
  #11  
my rx8 will eat your 350z
 
Join Date: Oct 2005
Posts: 6
Likes: 0
Liked 0 Times in 0 Posts
my rx8 is the best. It's been nothing but great. I kicked a 350z *** last week!
rx8forlife is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
BigMikeATL
RX-8's For Sale/Wanted
12
05-26-2016 12:31 AM
rotorocks
Series I Tech Garage
47
05-11-2016 03:23 PM
vapor2
West For Sale/Wanted
1
09-15-2015 06:38 PM
Pelleilee
New Member Forum
5
08-02-2015 02:44 PM
marc2820
New Member Forum
6
07-26-2015 10:47 PM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: Had my RX-8 for 1 year - already getting a new engine!?!?!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.