Notices
Gulf RX-8 Forum Serving TX, OK, AR, LA, MS

Just got one possibly needing help

Old 04-06-2017, 08:04 AM
  #1  
New Member
Thread Starter
 
Join Date: Apr 2017
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Just got one possibly needing help

I just got my first rx8 yesterday.. everything seemed ok but I have this weird idol after driving.. and it shakes when I take off. Once out of first it's good. Not sure what it is
Garrett West is offline  
Old 04-06-2017, 08:18 AM
  #2  
Registered
 
Join Date: May 2014
Location: Salem, CT
Posts: 424
Received 6 Likes on 6 Posts
Originally Posted by Garrett West View Post
I just got my first rx8 yesterday.. everything seemed ok but I have this weird idol after driving.. and it shakes when I take off. Once out of first it's good. Not sure what it is
Model year? Auto/manual? Aftermarket parts or modifications? Mileage?
Love_Hounds is offline  
Old 04-06-2017, 08:21 AM
  #3  
New Member
Thread Starter
 
Join Date: Apr 2017
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
It's a 2005 manual with 120k miles new motor and what I can tell just a cone filter and a cat back.
Garrett West is offline  
Old 04-06-2017, 08:31 AM
  #4  
New Member
Thread Starter
 
Join Date: Apr 2017
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
I'm at the dealer in town getting a compression test and a good insection over the car. Hope I didn't rush into this car lol
Garrett West is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.