Notices
Gulf RX-8 Forum Serving TX, OK, AR, LA, MS

Help need mechanic

Old 12-01-2010, 05:56 PM
  #1  
Registered User
Thread Starter
 
Join Date: Dec 2010
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Help need mechanic

Looking for a mechanic in Houston area. He used to work for Gillman Mazda of Rosenberg. I believe his name is Brent (?Brett) and is around 50 y.o. He has 2 RX7s and knows the cars.

I have a 2006 Shinka that I let sit for 8 days over Thanksgiving and now it has problems. It will start and idle around 2200, but will not respond to throttle input. The CEL and TSC/DSC light are both on full time. After it warms up the low coolant light comes on (been doing that for a while) even though the level is fine.

If anyone has an idea of where he is I'd sure love to know so I can try and get my car to him.

If not, any recommendations for the Houston or Victoria dealerships?
cleanbore is offline  
Old 12-02-2010, 04:30 AM
  #2  
PHREN PHUN!!
iTrader: (6)
 
phrenetiK's Avatar
 
Join Date: Jul 2010
Location: Pasadena, TX
Posts: 908
Likes: 0
Received 2 Likes on 2 Posts
I'd try calling gillman mazda.
phrenetiK is offline  
Old 12-02-2010, 07:46 AM
  #3  
Registered User
Thread Starter
 
Join Date: Dec 2010
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
I would but they closed down in '07. I tried the Honda guys there to see if anyone knew where he went, but no luck.
cleanbore is offline  
Old 12-02-2010, 08:18 AM
  #4  
#50
 
bse50's Avatar
 
Join Date: Nov 2007
Location: Caput Mundi
Posts: 7,525
Received 1 Like on 1 Post
You could give rx7club.com a try, maybe he posts there!
bse50 is offline  
Old 12-03-2010, 05:29 PM
  #5  
Registered
 
Join Date: Aug 2008
Posts: 122
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by cleanbore View Post
Looking for a mechanic in Houston area. He used to work for Gillman Mazda of Rosenberg. I believe his name is Brent (?Brett) and is around 50 y.o. He has 2 RX7s and knows the cars.

I have a 2006 Shinka that I let sit for 8 days over Thanksgiving and now it has problems. It will start and idle around 2200, but will not respond to throttle input. The CEL and TSC/DSC light are both on full time. After it warms up the low coolant light comes on (been doing that for a while) even though the level is fine.

If anyone has an idea of where he is I'd sure love to know so I can try and get my car to him.

If not, any recommendations for the Houston or Victoria dealerships?
The coolant sensor is probably having issues. When Mazda replaced my engine they told me I'd need to replace to fix it, but if not, my car'd be fine. Now the other issue, I've had that happen like 4 times already. When I was in the ARMY, The 3rd ID LOVES to do training. I had no one else to drive it when I was gone, so I'd have that problem EVERYTIME I got back. I don't know how, or why it happens, but I do know that I fixed it everytime, by Putting it in first, and letting off the clutch carefully, until it gets to speed to shift into second, and so on and so forth. After you drive it a couple of miles, park it, and turn it off. When you turn it back on, You should have proper use of the gas pedal. O.o It's kind of weird to drive it like this, but It's worked everytime for me. Let me know how it works for you?
cody205 is offline  
Old 12-04-2010, 03:21 PM
  #6  
Registered User
Thread Starter
 
Join Date: Dec 2010
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Thanks for the feedback. Today is Saturday and on Thursday I went out to wiggle connectors on the chance that some moisture/corrosion may be in play. Started it up and no change, so let it come up to temperature with the engine cover on, then shut it down. For grins/giggles I fired it up again and about 20 seconds later the TSC/DSC light went out, the RPMs dropped down to 1K and I had throttle controls. So I took it down the street and filled 'er up w/ gas. Then the CEL went out and everything seems normal again. The exhaust smells right again, the engine runs like a rocket. Three days in a row everything is good again. Seems strange 'cause it a first time event for me, but then I've never gone more than 3 days w/o driving her.

Maybe she was pouting because I didn't take her to Denver for Thanksgiving? Thanks again for sharing you experience. I didn't find any others that fit what I had. I was worried I was gonna have to trailer 80+ miles to a dealership and I don't have someone I know to shoot straight w/ me on her. Appreciate your advice and will try that next time before I worry too much.
cleanbore is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
galognu
Rotary Swaps
126
05-29-2018 05:00 AM
Patricia Odell
SE RX-8 Forum
12
11-14-2016 02:40 AM
Shankapotamus3
Series I Trouble Shooting
26
11-06-2016 08:26 AM
nferguson88
RX-8 Parts For Sale/Wanted
1
10-06-2015 12:45 PM
jasonrxeight
RX-8's For Sale/Wanted
2
09-30-2015 01:53 PM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Help need mechanic


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.