RX8Club.com
Register Photo Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read RX8 Live!Used CarsVendor Directory

Go Back   RX8Club.com > Series I Tech & Performance > Series I Tech Garage
Sign in using an external account
Register Forgot Password?

Welcome to RX8Club.com!
Welcome to RX8Club.com,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join RX8Club.com today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 04-22-2008, 12:29 PM   #1
Registered User
 
MADIZM's Avatar
 
Trader Score: (0)
Join Date: Sep 2004
Posts: 54
Engine trouble *white smoke*

Have an 04 Rx8 6 speed with 64000 miles on it car is stock had basic maintenance done and had coils replaced under warranty at around 40k miles. Last august I drove the car to vegas and back and no problems what so ever until I got back. Was driving the car and the power cut out and when I restarted it, it would not rev over 2k rpms or something. Restarted again and it was fine but with a CEL.

Continued to drive it with no problems then after a couple months it started taking much longer than normal to start. And it would smoke and and the CEL would flash. But after it warmed up it drove normally. So a friend talked me into taking it to his mechanic friend who said he discovered it had 3 trailing plugs and one leading plug and they were fouled. So replaced with the proper plugs, no CEL started the car fine no smoke. But as soon as I got home the CEL came back on and now the car is smoking again. The mechanic said he did a compression test and it was ok.

So I take it Mazda is pretty strict on that 60k cutoff on the powertrain warranty?




Ok went to Checkers today cause it was just down the block and the code that showed up was "Misfire on cylinder 1" so the guy said it's probably the spark plug but they were all just replaced. Anyone here able to help? I was talkin to a guy and he said maybe to switch around the spark plug wires or somethin to see if it's a problem with the wire or the cylinder or coil I dunno...



Update - took out all 4 coil packs and bought a cheap digital multimeter and one of the coils read way low on the meter than the other 3 so i bought a new coil pack from the dealer and put it in. Car started right up and now CEL or flashing CEL on startup. Drove it around and definately can feel an increase in power that was lost. When I get more money I'll replace the other 3 coils.

Other problem is not fixed car still smokes at startup and it's leaking coolant out of somewhere...after parking somewhere there's a small puddle of coolant say about the size of a cookie after being parked for hours. So if it was just leaking like that and not smoking out of the engine I wouldn't be worried but since it's smoking white that could mean one of the engine seals is leaking coolant right?

Been reading around and some people said they had water pump failures, if it was the pump would that cause white smoke?



***thread had been copy / pasted from another forum which is not as active as this one
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on RX8Club.com!
MADIZM is offline   Reply With Quote
Old 04-22-2008, 05:41 PM   #2
Compression Tester Man
 
Go48's Avatar
 
Trader Score: (0)
Join Date: Jul 2004
Location: Mont Alto, PA
Posts: 2,594
Does the car continue to smoke after it's warmed up? What does it smell like? If it smells sweetish, that is likely burning coolant and you probably are in deep kimchi. Are you adding coolant to the radiator on a regular basis?

If not, it is unlikely there is a leak. If the smoke goes away after a brief "burst", not to worry. Just an over rich, start-up, fuel-oil mixture burning off.

To the leak. Locate the origin of the leak. Like put a piece of cardboard under the car overnight and let us know where in the car the leak is coming from. If it seems to be coming from the front of the engine, it may be from the water pump weep hole. You will need to replace the water pump in that case. If it is not from that area, then where? BTW, A leaking water pump will not cause smoking at the tail pipe.

About the compression test. What kind of a tester did he use and was this done by someone who knows rotary engines? If not, disregard the results and have it done by a rotary tech.
Go48 is offline   Reply With Quote
Old 04-22-2008, 07:53 PM   #3
Lubricious
 
Nubo's Avatar
 
Trader Score: (0)
Join Date: Oct 2003
Location: SF Bay Area, California
Posts: 3,434
When you say "smoking out of the engine", where exactly are you seeing the smoke? Is it coming out of the tail pipe, or from the vacinity of the engine itself?
Nubo is offline   Reply With Quote
Old 04-22-2008, 10:35 PM   #4
Registered User
 
MADIZM's Avatar
 
Trader Score: (0)
Join Date: Sep 2004
Posts: 54
White smoke comes out of the tail pipe and only when the car is cold not after startup. But yeah I am having to add coolant to the resevoir. The smoke is definatley white but it doesn't smell sweet to me it just makes me cough lol. I will try the cardboard thing. And the mech was not a rotary mechanic so I guess I'd have to get that re-checked.

I was wondering it would be be worth it to just take it to a dealer and pay them to diagnose the problem and if the engine needs to be rebuilt / replaced then send a letter to to Mazda NA I've heard of some getting the engine replaced even after warranty is up.
MADIZM is offline   Reply With Quote
Old 04-23-2008, 05:47 AM   #5
Compression Tester Man
 
Go48's Avatar
 
Trader Score: (0)
Join Date: Jul 2004
Location: Mont Alto, PA
Posts: 2,594
Quote:
Originally Posted by MADIZM View Post
White smoke comes out of the tail pipe and only when the car is cold not after startup. But yeah I am having to add coolant to the resevoir. The smoke is definatley white but it doesn't smell sweet to me it just makes me cough lol. I will try the cardboard thing. And the mech was not a rotary mechanic so I guess I'd have to get that re-checked.
If you are adding coolant frequently, you almost certainly have a leak--either internal or external to the engine. However, based on what you say about the smoke, it sounds like fuel-oil vs. coolant. Your coolant loss may be due to the leak you mention and not to an internal engine coolant "leak" problem.

Quote:
Originally Posted by MADIZM View Post
I was wondering it would be be worth it to just take it to a dealer and pay them to diagnose the problem and if the engine needs to be rebuilt / replaced then send a letter to to Mazda NA I've heard of some getting the engine replaced even after warranty is up.
If you have had dealings with a reasonable Mazda service department, I would recommend you do that. If you need an engine replacement, probably the best you can hope for is to negotiate a cost sharing arrangement with Mazda. Something like you pay the labor and they supply the engine.
Good luck!
Go48 is offline   Reply With Quote
Old 04-23-2008, 05:47 AM
RX8Club
Mazda RX8




Paid Advertisement


 
 
 
Reply

Tags
car, cold, cuts, engine, motor, normal, pipe, replaced, rotary, rotery, rx8, smoke, tail, tailpipe, white

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
CEL + White Smoke = ? laythor RX-8 Discussion 6 03-28-2008 06:24 PM
White Smoke... Dealer Replaced Engine. PSUGreySreet RX-8 Discussion 7 11-23-2007 11:00 AM
Help! White smoke from engine. rkamath Series I Trouble Shooting 11 09-26-2007 01:25 PM
RB Catback installed and white smoke GTSimmo Series I Aftermarket Performance Modifications 3 12-22-2006 01:11 PM
White Smoke ... RX8Z Series I Tech Garage 16 02-04-2004 12:16 PM


All times are GMT -5. The time now is 07:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
All content Copyright 2007 by Internet Brands, Inc.
Emails Backup