Notices
Series I Trouble Shooting This is the place to learn more about or discuss any issues you're having with your RX-8

help please! cel p0300 and p0171

Old 01-11-2010, 07:12 PM
  #1  
Im a greenhorn
Thread Starter
 
Join Date: Jan 2008
Location: Charleston,SC
Posts: 18
Likes: 0
Liked 0 Times in 0 Posts
help please! cel p0300 and p0171

Yesterday I was driving in second gear and about to shift up to third. Next thing I hear is a loud grumbling noise which was very deep. My power went down dramatically and a blinking cel came on. I tried to slighlty accelerate to a safe spot on the road and the car was unresponsive. I begane to roll down a hill and my breaks were extremely resistent and tough to depress. I shut the car off and waited for a little while then tried to refire. It sounded like it was misfiring and when the car started it would not properly idle at the normal level and did not sound anywhere near how it should. I had my car towed to the AAA a block away and they informed me that they read out the cel for p0300 and p0171. They informed me of rattling, a slight crackling or popping sound, and also said that my car was supposed to have been recalled for pcm reprogramming.

Has anyone ever dealt with this. I'm really worried that this may be a fatal problem. My car has 64k miles and is an 04.
DLASH15 is offline  
Old 01-11-2010, 07:17 PM
  #2  
Grasshopper
iTrader: (1)
 
Jon316G's Avatar
 
Join Date: Dec 2006
Location: Streetsboro, OH
Posts: 6,778
Likes: 0
Liked 11 Times in 11 Posts
Those are misfire and system running lean codes.
I had the same loud grumbling sound when my MAF got hit with water.
I would start with cleaning that first.

Also, when was the last time you changed the spark plugs and coils?
Jon316G is offline  
Old 01-11-2010, 07:33 PM
  #3  
Im a greenhorn
Thread Starter
 
Join Date: Jan 2008
Location: Charleston,SC
Posts: 18
Likes: 0
Liked 0 Times in 0 Posts
jon,
My spark plugs were replace about 1.5 years ago. am not sure the last time the coils were.
As far as the grumbling, I do not know where water would have came from for me. I contacted the mazda dealership and they said that it was most likely my Cat. Would a cat problem cause all of those symptoms? I am still under the emission warranty but wonder if a intake would be enough to void that.
DLASH15 is offline  
Old 01-11-2010, 07:39 PM
  #4  
Grasshopper
iTrader: (1)
 
Jon316G's Avatar
 
Join Date: Dec 2006
Location: Streetsboro, OH
Posts: 6,778
Likes: 0
Liked 11 Times in 11 Posts
It can possibly be the cat.
If they replace it under warranty, thats good for you weather or not it was the culprit.

Not saying water got in your intake and hit the MAF, I'm just saying that an inaccurate reading from the MAF could cause that kind of sound.
This is why I suggested cleaning it. Plus its simple to do.
Plus with you having an '04, that year has its oil filler neck routed to the intake.
So its possible that oil residue could have built-up on the wires.

Last edited by Jon316G; 01-11-2010 at 08:06 PM.
Jon316G is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mdl0209
Series I Trouble Shooting
10
03-21-2019 11:17 PM
Shankapotamus3
Series I Trouble Shooting
26
11-06-2016 08:26 AM
fistofmeat
Series I Trouble Shooting
8
10-07-2016 12:15 PM
Evan Gray
Series I Trouble Shooting
0
09-26-2015 12:30 PM
Forevermore
Series I Trouble Shooting
6
09-20-2015 01:04 PM


Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: help please! cel p0300 and p0171


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.