RX8Club.com - View Profile: DarthRX8



DarthRX8 DarthRX8 is offline

Force User

Visitor Messages

Showing Visitor Messages 1 to 5 of 5
  1. xobbas
    11-29-2015 04:07 PM - permalink
    xobbas
    Hi,

    How are you?
    I've seen that you solved your 8's problem of not starting.

    Mine is a 04 6MT, and it was parked along with other vehicles.
    Someone took out the battery to jump start another car and when he put back the battery he put it in the wrong position.

    Now the engine does not crank or turn, neither the starter.
    I simply hear a clicking sound from the engine compartment.

    Do you have an Idea of what could it be?
    I've checked fuses, but I'll have them checked again. Where is the MAIN fuse located?

    Thanks in advance,
    Xobbas
  2. Jedi54
    07-30-2009 04:26 PM - permalink
    Jedi54
    thanks for the heads up.
    I'm all over it...
  3. DarthRX8
    05-04-2009 05:21 PM - permalink
    DarthRX8
    The OP is an idiot! Brice is a lot of things but I have never heard of him not communicating.
  4. DarthRX8
    05-04-2009 05:17 PM - permalink
    DarthRX8
    yeah, who would have thought! As soon as I saw ripped off and Brice in the same thread. I was hoping for an all out battle to keep me busy at work!
  5. Jedi54
    05-04-2009 04:53 PM - permalink
    Jedi54
    I'm almost ready to throw out the BS flag with that guy claiming fluid ripped him off.
    Crazy world we live in when I'M defending Brice...

About Me

  • About DarthRX8
    Location
    D.C.
    Occupation
    US Army
  • Signature
    2005 Touring, 6MT, AEM CAI, AFE Short Shifter, BHR Ignition, Racing Beat Exhaust, AccessPort tuned by MazdaManiac and Clear Corners.

Statistics

Total Posts
Visitor Messages
Total Thanks
General Information
  • Last Activity: 09-15-2017 03:04 PM
  • Join Date: 01-31-2008

Friends

Showing Friends 1 to 1 of 1

All times are GMT -5. The time now is 09:31 AM.


All content Copyright 2017 by Internet Brands, Inc.