RX8Club.com - View Profile: 1.3_LittersOfFurry

Notices

1.3_LittersOfFurry 1.3_LittersOfFurry is offline

Flame On!

About Me

  • About 1.3_LittersOfFurry
    Location
    New Orleans, La
    Occupation
    Rouses Seafood Specialist
  • Signature
    RB EndLinks / CarTablet / KOYORAD / FAL 490's / Cobb AccessPORT / GOODbox / BHR Ignition / Tokico Dspecs / Tein S.Tec

Statistics

Total Posts
Albums
Visitor Messages
Total Likes
General Information
  • Last Activity: 09-29-2017 05:53 PM
  • Join Date: 01-03-2011

Social Profiles

Instant Messaging
Send an Instant Message to 1.3_LittersOfFurry Using...
This Page
https://www.rx8club.com/members/1-3_littersoffurry-72452/

Friends

Showing Friends 1 to 8 of 8

Visitor Messages

Showing Visitor Messages 1 to 6 of 6
  1. 12-27-2017 03:10 PM - permalink
    Merry Christmas
    . Let me ask you. What is the rims on your RX 8?
  2. 12-06-2017 09:40 AM - permalink
    hey man sorry to PM you but I been trying to get answers here with not much luck. I see your DIY on the nav screen its a great write-up and very nice. I did same thing an it all went well however I came across an issue. So after I calibrate the screen by removing the sensor and all that if I disconnect it from power for more than 30 sec it loses the calibration again. have you had this problem also is there a fix that you know of?
  3. 12-02-2015 05:55 AM - permalink
    Hi, I have been seeing your old post regarding hard starts. I have 07 model with N3HI-A Starter.. i serviced it and there was lot of carbon in it.. Will servicing it bring it back to life or i just need a new starter like N3R3?
    My car crank speed after servicing the starter at cold is between 160 to 180rpms and at warm is 220 to 250rpms . My car starts cold and hot everytime but the problem im facing is that a little long cold start just like the first start in the video at the end.


    Please keep in mind that my hot starts are fine and it starts within 1.5 seconds everytime when hot. Its the cold one that im worrying about and should the new starter fix that? im sure the compression is fine as there is no stalling, no hot start,idle is great, no powerloss in all bands of rpms. I just want your opinion to buy the new starter and battery for cold start issue just like the first one in the video. Thanks

  4. BigGunz
    11-18-2013 03:51 AM - permalink
    Well everything is back together and it's doing great! Thanks for the advice!
  5. 05-13-2013 11:17 PM - permalink
    hey can u help me i bougth the original navigation hood im trying to install a galaxy tab just like u now the problem im runing to is how to power the whole thing where would i weld the power to it would be a big help
  6. 09-30-2012 06:32 PM - permalink
    hey mate, can I please ask where you bought the rx8 Nav hood with the motor etc. from?

    thanks

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.