RX8Club.com
Register Photo Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read RX8 Live!Used CarsVendor Directory

Go Back   RX8Club.com > Series I Tech & Performance > Series I Trouble Shooting
Sign in using an external account
Register Forgot Password?

Welcome to RX8Club.com!
Welcome to RX8Club.com,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join RX8Club.com today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 12-17-2004, 07:56 AM   #1
Realtor1
 
subduedracer's Avatar
 
Trader Score: (0)
Join Date: Aug 2004
Location: Bristow, VA
Posts: 204
No heater/no radio controls/no amp temp/no mode a/c heater controls, WTF?

I get out to my car this morning. I started her up as normally I do. I then notice that the radio buttons don't work. The a/c heater control doesn't work, the amp temp display doesn't work. However, the radio buttons on the steering wheel work. I checked the fuses and nothing blown. WTF?
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on RX8Club.com!
subduedracer is offline   Reply With Quote
Old 12-17-2004, 08:27 AM   #2
Turbo'd 5
 
Spyder_doo's Avatar
 
Trader Score: (0)
Join Date: Jun 2004
Location: Dalton, GA
Posts: 531
Send a message via MSN to Spyder_doo Send a message via Yahoo to Spyder_doo
I know I got in my 8 the other morning when it hit below freezing and the lcd display kinda of hesitated. The changing from one letter or number was very slow. I dont know what was wrong, but it cleared up and was normal as soon as it became warm in the car.

Jamie
Spyder_doo is offline   Reply With Quote
Old 12-17-2004, 08:49 AM   #3
black RX-8 6 speed
 
Trader Score: (0)
Join Date: Aug 2004
Location: Tampa, FL
Posts: 191
Send a message via Yahoo to bigblockbeater
oh no! not you too! first question i have to ask, did you alter the stereo in any way? install any aftermarket parts to it? i put a line rca adapter on mine and now only the fan and hazards work. mazda told me i broke it so i am screwed. mine is the basic stereo. if you didn't touch the stereo then take it to your dealer and have them replace it. there are no fuses burned. the unit itself is the problem. good luck
bigblockbeater is offline   Reply With Quote
Old 12-17-2004, 09:34 AM   #4
czr
RX8 RX8!
 
czr's Avatar
 
Trader Score: (1)
Join Date: Aug 2004
Location: Tampa Bay, FL
Posts: 1,187
It's probably a loose connection in the rear that controls both radio/ac etc. If you didn't change anything, you can take it to the dealer or try to check the connections yourself as it doesn't take more than 45 mins but that gold screw is a pain.
czr is offline   Reply With Quote
Old 12-17-2004, 10:45 AM   #5
Registered User
 
buzzardsluck's Avatar
 
Trader Score: (0)
Join Date: Sep 2004
Location: san antonio TX
Posts: 273
i dont know if this is right but the same problem happened on my truck. on my truck the problem was the modules that the ***** are attached to. i had this problem after i had replaced a cd player. if this is the problem they are an ez fix. if this sounds dumb just ignore me lol
buzzardsluck is offline   Reply With Quote
Old 12-17-2004, 04:18 PM   #6
Realtor1
 
subduedracer's Avatar
 
Trader Score: (0)
Join Date: Aug 2004
Location: Bristow, VA
Posts: 204
I went out to my car later today, and its working. I think this is going to be an intermentant problem.
subduedracer is offline   Reply With Quote
Old 02-28-2010, 02:51 AM   #7
Registered User
 
Trader Score: (0)
Join Date: Jan 2009
Posts: 10
My radio won't come on, aswell as the heater controls, just the fan and temp will work. How do I fix the problem.
04-Rx8 is offline   Reply With Quote
Old 03-15-2013, 08:23 PM   #8
Real Racing 3 fan
 
Strata-R's Avatar
 
Trader Score: (0)
Join Date: Jun 2010
Posts: 102
gaudeamus_xy
Quote:
Originally Posted by subduedracer View Post
I went out to my car later today, and its working. I think this is going to be an intermentant problem.
mine started intermittent but a few months later totally failed.
1. half of my lcd display is gone
2. heat is stuck on on mode therefore no A/C
3. the center air selector button cluster, (the one that lets you pick air direction and defrosters) don't work.
4. audio system and fan speed selector work
__________________
2003 Ford Focus ST Silver
1990 Toyota Celica ST Red
2004 Mazda RX-8 GT Velocity Red <current
2014 BMW M4 Black <dream

Vision is the art of seeing things invisible
~Jonathan Swift
Strata-R is offline   Reply With Quote
Old 03-16-2013, 09:14 AM   #9
Registered
 
Trader Score: (3)
Join Date: Apr 2004
Location: macon, georgia
Posts: 10,752
do a search--i believe the answer in the in the interior section? Something to do with the console soldering?
Some poeple jusy bang the heck out of the center console and it starts working correctly.....IDKb
__________________
no signature anymore
olddragger is offline   Reply With Quote
Old 03-18-2013, 07:21 PM   #10
Registered
 
Trader Score: (2)
Join Date: Dec 2012
Posts: 138
Do you have interior lights? If not I would recheck the bottom fuse in your interior fuse box. (steering wheel controls, heated seats & glove box light run off a different fuse)
Mr.Mango is offline   Reply With Quote
Old 03-22-2013, 05:23 PM   #11
Real Racing 3 fan
 
Strata-R's Avatar
 
Trader Score: (0)
Join Date: Jun 2010
Posts: 102
gaudeamus_xy
Quote:
Originally Posted by Mr.Mango View Post
Do you have interior lights? If not I would recheck the bottom fuse in your interior fuse box. (steering wheel controls, heated seats & glove box light run off a different fuse)
I have lights everywhere, even on the air mode cluster of which the buttons don't work. I'm pretty sure it's a bad Heater Control Module/ECU.
__________________
2003 Ford Focus ST Silver
1990 Toyota Celica ST Red
2004 Mazda RX-8 GT Velocity Red <current
2014 BMW M4 Black <dream

Vision is the art of seeing things invisible
~Jonathan Swift
Strata-R is offline   Reply With Quote
Old 05-06-2013, 03:17 PM   #12
Real Racing 3 fan
 
Strata-R's Avatar
 
Trader Score: (0)
Join Date: Jun 2010
Posts: 102
gaudeamus_xy
Quote:
Originally Posted by Strata-R View Post
I have lights everywhere, even on the air mode cluster of which the buttons don't work. I'm pretty sure it's a bad Heater Control Module/ECU.
I finally took the car in to get the issue fixed. It turns out there were multiple parts that failed: A/C Amplifier, Heater Control, Display Panel, and another part that the Display Panel is connected to.
__________________
2003 Ford Focus ST Silver
1990 Toyota Celica ST Red
2004 Mazda RX-8 GT Velocity Red <current
2014 BMW M4 Black <dream

Vision is the art of seeing things invisible
~Jonathan Swift
Strata-R is offline   Reply With Quote
Old 05-06-2013, 03:17 PM
RX8Club
Mazda RX8




Paid Advertisement


 
 
 
Reply

Tags
2004, ac, buttons, controller, controls, doesnt, hazards, heater, mazda, radio, rx, rx8, temp, work, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
All content Copyright 2007 by Internet Brands, Inc.
Emails Backup