RX8Club.com
Register Photo Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read RX8 Live!Used CarsVendor Directory

Go Back   RX8Club.com > Series I Tech & Performance > Series I Trouble Shooting
Sign in using an external account
Register Forgot Password?

Welcome to RX8Club.com!
Welcome to RX8Club.com,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join RX8Club.com today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 09-06-2008, 06:07 PM   #1
Registered User
 
simplyphp's Avatar
 
Trader Score: (0)
Join Date: Feb 2007
Location: Dallas, TX
Posts: 375
Send a message via AIM to simplyphp
I have a few Trouble Codes, anyone know how to fix them?

Other than the Cobb AccessPort from MM, I haven't done any true mods to my car yet, just a body kit & aesthetics that wouldn't do anything to how the car actually works. I have the default v1.0 flash and my STFT is at 0/1 so that's fine. Problem is, my TPMS monitoring light has been flashing for about a year and a half now, so I plugged in the AccessPort today and lo & behold there were these errors (all information is from a DTC manual, Mazda may deviate some from these values but their raw entry is also correlated in case its of use to anyone):

CAN Bus faults:
IC U1900, RAW: D900, Meaning: CAN Communication Bus Fault - Receive Error
EPS U1900, RAW: D900, Meaning: CAN Communication Bus Fault - Receive Error
RKE U1900, RAW: D900, Meaning: CAN Communication Bus Fault - Receive Error

TPMS Errors:
TPMS U2616, RAW: E616, Meaning: Left front tire pressure sensor is Not Responding
TPMS U2617, RAW: E617, Meaning: Right front tire pressure sensor is Not Responding
TPMS U2618, RAW: E618, Meaning: Left rear tire pressure sensor is Not Responding

TCM Error:
TCM U0100, RAW: C100, Meaning: Lost Communication With ECM / PCM A


So I cleared the errors, waited, restarted car, drove around some, checked for errors, and lo & behold:
RKE P0039, RAW: 0039, Meaning: Turbo/Super Charger Bypass Valve Control Circuit Range/Performance

TPMS U2616, RAW: E616, Meaning: Left front tire pressure sensor is Not Responding

So I know that my TPMS sensors, likely in all 4 wheels not just 3, are either broken or were taken out or something... I'm not 100% certain. Discount Tire Co told me to take it to Mazda as they didn't have anything to check it with, but of course I prefer to check on the forums first before giving the stealership my car.

My main concern are the IC/EPS/RKE/TCM errors because I don't know what those pertain to. My initial thought was the U1900 error was in some way associated or caused by the U261x errors, i.e. the tire pressure monitoring system was not communicating with the CAN Communication Bus because they senors are either broke or non-existent (removed by prior owner or an idiot changing the tires out).

The other possibility is that the CAN Comm. bus errors were caused by me swapping out my tail brake lights & turn signals with LED lights, and of course inserting them backwards both times, so maybe the computer registered an error with the electrical bus, I know that my wife's old 97 Camry had a light come on when her back left brake light went out, so maybe my RX-8 registered some sort of problem as well, I am not certain.

The lost communication with ECM/PCM error, TCM U0100, I don't really have a good clue.

And, for the RKE P0039, it supposedly has to do with "Turbo/Super Charger Bypass Valve Control Circuit Range/Performance", but I do not have a turbo (yet) nor any bypass valve.. so, taking the next few words and making a meaning of them: "circuit range/performance", I might be able to explain that one as well but again am not sure. Since I replaced the back turn lights with LEDs, my lights all blink faster. I mean, when I go to signal left or right, my turn arrows on my dash go 90 to nothing and my front lights do the same, and my back LEDs look normal. My guess here is that the bus which carries the electrical signal hits the LEDs and it registers that it hit, hit hit hit hit, but the front ones are like, hit... pause.. hit... pause.. hit, so maybe it's the systems way of adjusting itself, sending the signal faster to the front lights & the cluster panel, but it also stores an error message that the performance is different - although honestly I feel that may be stretching it because it doesn't have **** to do with a turbo/super charger bypass valve so I'm just looking for a reason anywhere I can.

Any help?
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on RX8Club.com!
__________________
My Ol' RX-8
simplyphp is offline   Reply With Quote
Old 09-06-2008, 06:43 PM   #2
Registered User
 
simplyphp's Avatar
 
Trader Score: (0)
Join Date: Feb 2007
Location: Dallas, TX
Posts: 375
Send a message via AIM to simplyphp
It's an 04 Automatic, I'll probably just be taking it to the stealership so they can *** rape me.
__________________
My Ol' RX-8
simplyphp is offline   Reply With Quote
Old 12-01-2008, 10:56 AM   #3
Registered User
 
Trader Score: (0)
Join Date: May 2006
Location: Naperville,IL; West Lafayette, IN
Posts: 124
Send a message via AIM to AlTitaniumCar
Did the dealership ever tell you what they did to resolve the P0039 code? I just had this one rear its ugly head on me...
__________________
Alec Cervenka
AlTitaniumCar is offline   Reply With Quote
Old 04-15-2009, 03:43 PM   #4
Registered User
 
Trader Score: (0)
Join Date: Sep 2008
Posts: 10
I also have this RKE P0039 code show up on my Cobb AP.

Anyone have any idea what it means?

The car is an 05 auto, N/A.

Thanks!
dandan is offline   Reply With Quote
Old 04-15-2009, 03:51 PM   #5
Mu ha.. ha...
 
Razz1's Avatar
 
Trader Score: (0)
Join Date: Aug 2004
Location: Cali
Posts: 14,293
MM said that code means nothing.

We have yet to find out what it means.
__________________


Boy... am I beautiful!
Razz1 is offline   Reply With Quote
Old 04-15-2009, 03:51 PM
RX8Club
Mazda RX8




Paid Advertisement


 
 
 
Reply

Tags
bus, code, communication, dealer, fault, left, lost, mazda, meaning, p0039, rx8, tcm, trouble, u0100, u1900, u2616

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
RX-8 paint codes my10ae MedCenterMazda 32 08-19-2013 09:58 PM
airbag codes RotaryResurrection Series I Tech Garage 5 04-19-2012 05:35 AM
Codes Drizzt8 Series I Trouble Shooting 0 03-25-2008 04:00 PM
Help! What do all these trouble codes mean? JohnO Series I Trouble Shooting 34 06-21-2005 03:52 PM


All times are GMT -5. The time now is 05:10 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
All content Copyright 2007 by Internet Brands, Inc.
Emails Backup