fixed pinging sound - RX8Club.com
RX8Club.com

Go Back   RX8Club.com > Series I Tech & Performance > Series I Tech Garage




Reply
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread
Old 11-30-2005, 08:00 AM   #1
Registered User
 
rudy8's Avatar
 
Join Date: Feb 2004
Location: michigan
Posts: 295
fixed pinging sound

I have been having pinging sounds coming from the engine at around 4-5 rpms...especially when cold. I have tried everything including fuel/engine cleaners, new plugs, dealer visits, etc.
Last week I took car in for oil change and also had all my gear/tranny oils changed (30K mi).
PINGING COMPLETELY GONE. I dont know why.
I have been told that it was coming from intake "flutter" to dirty carbon build up, and many others. Changing tranny oils seemed to cure the problem
rudy8 is offline   Reply With Quote


 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
{WTB} Stock or Aftermarket Cat Back Exhaust - Dayton, OH fc2se NE For Sale/Wanted 2 06-01-2016 08:55 PM
Clunking noise when on throttle/off throttle in 2nd and 3rd gear nowakm99 Series II Technical and Trouble shooting 1 10-09-2015 07:10 AM
My Rx8, strange Noice (Whistle) no Belt. tommy26Germany Series I Trouble Shooting 11 09-29-2015 10:33 AM
{ FS } 2005 RX-8 Grand Tour - clean w/history drlubell RX-8's For Sale/Wanted 0 09-26-2015 11:58 PM
HELP...Trouble Shooting Amp/Radio just1jack New Member Forum 3 09-09-2015 04:45 PM


Tags
fixed, pinging

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:20 AM.

 

All content Copyright 2007 by Internet Brands, Inc.