Messed up Interior Electrics - Help - RX8Club.com



Reply
 
 
 
Thread Tools Search this Thread Rate Thread
Old 07-28-2015, 09:51 AM   #1
9K All Day
Thread Starter
 
Crazy.8's Avatar
 
Join Date: Jul 2011
Location: Houston, Texas
Posts: 306
Messed up Interior Electrics - Help

So my passenger side sun visor broke a bit and has been hanging down from mount, so I tried to remove the wires from the visor (the red and black ones that control the little light near the mirror). I got the black one out perfectly fine but the had some issues getting the red one off and it broke.

When it broke, my radio immediately went off and the only thing on my head unit that works is my ac. Additionally, none of the interior lights work, my door locks do not work, and my cobb accessport is unresponsive when I plug it into the OBD port.

I'm guessing I just blew a fuse when I snapped the wire but I can't figure out which fuse would have blown because those are all on different fuses. My power side view mirrors still work.

Could it have been like a master fuse or something of the sort?

Thanks
Crazy.8 is offline   Reply With Quote
Old 07-28-2015, 12:15 PM   #2
Put it in "H"!
 
Loki's Avatar
 
Join Date: Jun 2009
Location: Montreal
Posts: 2,429
The "room" fuse could definitely be it. One way to find out, it's inside the cabin in the fusebox under the driver's side dash. May as well check them all.
Loki is offline   Reply With Quote
Old 07-29-2015, 02:46 PM   #3
Registered
 
Join Date: Aug 2012
Location: Chicago, IL
Posts: 433
Next time please do not do "electronics" stuff without having the car off and battery unplugged.. but yes, a fuse is probably blown. Check where Loki said.
JamesD31 is offline   Reply With Quote
Old 04-18-2017, 03:17 PM   #4
Registered
 
Join Date: Oct 2013
Posts: 28
Smile

Quote:
Originally Posted by Crazy.8 View Post
So my passenger side sun visor broke a bit and has been hanging down from mount, so I tried to remove the wires from the visor (the red and black ones that control the little light near the mirror). I got the black one out perfectly fine but the had some issues getting the red one off and it broke.

When it broke, my radio immediately went off and the only thing on my head unit that works is my ac. Additionally, none of the interior lights work, my door locks do not work, and my cobb accessport is unresponsive when I plug it into the OBD port.

I'm guessing I just blew a fuse when I snapped the wire but I can't figure out which fuse would have blown because those are all on different fuses. My power side view mirrors still work.

Could it have been like a master fuse or something of the sort?

Thanks
Hi. I want to know if you find the problem at the "room fuse". I made the same mistake with same results. Thanks!
Xcess is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
{ FS } Door panel, window switch, Bose speakers Jst4fun RX-8 Parts For Sale/Wanted 4 09-01-2016 04:53 PM
Bolt-In AutoPower Bar for Future STX Car projectr13b RX-8 Racing 20 05-14-2016 06:25 PM
2004 RX-8, where does this solenoid go? Evan Gray Series I Trouble Shooting 4 11-24-2015 01:00 AM
{ FS } RX 8 Spare Interior Parts for Sale nferguson88 RX-8 Parts For Sale/Wanted 1 10-06-2015 12:45 PM
{ FS } 2005 Mazda RX8 Shinka Automatic "Bad Apex Seals" Tgiolitto100 RX-8's For Sale/Wanted 1 09-29-2015 10:52 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 06:00 AM.


All content Copyright 2007 by Internet Brands, Inc.