Did they ever fix the K&N + CZ unit problem? - RX8Club.com



Reply
 
 
 
Thread Tools Search this Thread Rate Thread
Old 10-19-2004, 12:04 PM   #1
"I'm Just That Good"
Thread Starter
 
Join Date: Jan 2004
Location: Miami, FL
Posts: 652
Did they ever fix the K&N + CZ unit problem?

Did they ever fix the K&N intake + CZ unit problem or can that be solved by tuning the unit?
Horse is offline   Reply With Quote
Old 10-19-2004, 12:08 PM   #2
⎝⏠⏝⏠⎠
 
mysql101's Avatar
 
Join Date: Apr 2004
Location: USA
Posts: 8,621
What problem is that? Far as I know, the K&N unit itself causes issues because the intake tube is too long.
mysql101 is offline   Reply With Quote
Old 10-19-2004, 06:16 PM   #3
"I'm Just That Good"
Thread Starter
 
Join Date: Jan 2004
Location: Miami, FL
Posts: 652
I remember when the CZ unit first started to get attention some people said it would not work with the K&N intake.
Horse is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
REPLACE YOUR PURGE VALVE SOLENOID ASAP...Drives like new xAgyex Series I Trouble Shooting 8 03-13-2016 04:37 PM
Clutch acting weird! HELP!! GARCIAC951 Series I Tech Garage 8 09-10-2015 07:17 PM
I dont know whats wrong with my manual rx8 ed0128 New Member Forum 7 09-09-2015 04:50 PM
Audio System Woes mattymack New Member Forum 2 09-06-2015 10:33 PM
Newbie Buying Question Octomus New Member Forum 2 09-03-2015 11:40 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 12:25 PM.


All content Copyright 2007 by Internet Brands, Inc.