RX8Club.com
Register Photo Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read RX8 Live!Used CarsVendor Directory

Go Back   RX8Club.com > General Topics > RX-8 Discussion
Sign in using an external account
Register Forgot Password?

Welcome to RX8Club.com!
Welcome to RX8Club.com,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join RX8Club.com today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Rate Thread Display Modes
Old 01-25-2009, 07:40 PM   #1
Registered User
 
Trader Score: (0)
Join Date: Jan 2009
Location: Fredericksburg, VA
Posts: 33
VA Rough Idle - Temporary Flashing CEL

So this is the 2nd time this has happened. I started up the car this morning it was about 30 degrees. I revved the engine for a second and noticed fumes out the back were pretty heavy. The check engine light flashed for a minute and then stopped. Sometimes the car seems to idle pretty rough even after its warmed up. What could these problems be from? Do I need to spark plugs? Coils?
This ad is not displayed to registered and logged-in members.
Register your free account today and become a member on RX8Club.com!
jhoyt12788 is offline   Reply With Quote
Old 01-25-2009, 07:48 PM   #2
Surf Hard, Drive Hard
 
Mazurfer's Avatar
 
Trader Score: (0)
Join Date: Feb 2007
Location: Indialantic, Florida
Posts: 7,829
Need more data..............year, mileage, etc.

But..................don't rev or drive much over 3k until you're up to operating temp.

I would change coils, plugs, and wires all at one time. One or two of these is the likely cause.

For grins, you could make sure all your plug wires are on good(on both ends), but it's still likely you will be changing them.
__________________


05 TiGray, 6MT...GT.
Mods..........too many to list, so.......
View my garage
Mazurfer is offline   Reply With Quote
Old 01-25-2009, 07:58 PM   #3
Vtak just kicked in yo!!
 
Renesis07's Avatar
 
Trader Score: (1)
Join Date: Jun 2007
Location: Lake County IL
Posts: 4,090
did the light 'blink' or stay illuminated for one minute. Blinking means a misfire which is typically plugs, coils, or wires.
__________________
SOLD 2004 RX8 Grand Touring
K&N Typhoon V2 - Rotary Performance Gutted Cat (Midpipe) - 350Z Carbon Fiber Duct - TEIN Stechs - Tint - Tinted Fogs - Debadged - Black Painted Trunk - Greddy Shift Knob - Footwell Lights - Painted Interior Trim - JL/Rockford Fosgate Audio-MSD Dashhawk 81,XXX miles - Orig Engine (5W-20 User)
Replacement- 2011 Black Honda Civic Si Coupe
Renesis07 is offline   Reply With Quote
Old 01-25-2009, 07:58 PM   #4
Registered User
 
Trader Score: (0)
Join Date: Jan 2009
Location: Fredericksburg, VA
Posts: 33
2004, 28,000 miles , previous owner said he babied it. ( I met the guy after buying from dealership). My problem is I have no idea how to check the wires coils, or plugs...and mazda keeps telling me that it is normal for a rough idle.
jhoyt12788 is offline   Reply With Quote
Old 01-25-2009, 08:08 PM   #5
Vtak just kicked in yo!!
 
Renesis07's Avatar
 
Trader Score: (1)
Join Date: Jun 2007
Location: Lake County IL
Posts: 4,090
Quote:
Originally Posted by jhoyt12788 View Post
2004, 28,000 miles , previous owner said he babied it. ( I met the guy after buying from dealership). My problem is I have no idea how to check the wires coils, or plugs...and mazda keeps telling me that it is normal for a rough idle.
That might be your problem.......

Do you redline often, may be carbon build up.
__________________
SOLD 2004 RX8 Grand Touring
K&N Typhoon V2 - Rotary Performance Gutted Cat (Midpipe) - 350Z Carbon Fiber Duct - TEIN Stechs - Tint - Tinted Fogs - Debadged - Black Painted Trunk - Greddy Shift Knob - Footwell Lights - Painted Interior Trim - JL/Rockford Fosgate Audio-MSD Dashhawk 81,XXX miles - Orig Engine (5W-20 User)
Replacement- 2011 Black Honda Civic Si Coupe
Renesis07 is offline   Reply With Quote
Old 01-25-2009, 08:17 PM   #6
Registered User
 
Trader Score: (0)
Join Date: Jan 2009
Location: Fredericksburg, VA
Posts: 33
Oh I redline. I know all about the daily requirement. I meet/exceed that. It was blinking...not even for a minute.
jhoyt12788 is offline   Reply With Quote
Old 01-25-2009, 08:21 PM   #7
Registered User
 
Trader Score: (0)
Join Date: Jan 2009
Location: Fredericksburg, VA
Posts: 33
Im reading about how this could be the CAT? How do I get mazda to look at all this? It's still under warrenty until the end of March.
jhoyt12788 is offline   Reply With Quote
Old 01-25-2009, 08:22 PM   #8
Zoom-Freakin'-Zoom
 
swoope's Avatar
 
Trader Score: (5)
Join Date: Jan 2004
Location: orlando, fl
Posts: 14,359
when it is cold. dont free rev it let it settle into what ever rpm it wants.

at that temp i would let it idle for a bit then drive slowly..

beers
__________________
Thanks, Mr. moody sardonic expert on so many things. Potentiated 09 Banned

All the stuff???? All I need is rum dude; everything else takes care of itself! Kane 09
swoope is offline   Reply With Quote
Old 01-25-2009, 08:23 PM   #9
Zoom-Freakin'-Zoom
 
swoope's Avatar
 
Trader Score: (5)
Join Date: Jan 2004
Location: orlando, fl
Posts: 14,359
Quote:
Originally Posted by jhoyt12788 View Post
Im reading about how this could be the CAT? How do I get mazda to look at all this? It's still under warrenty until the end of March.
it is very unlikely the cat.

flashing cel as mention before is a misfire. plugs, wires, coils. most of the time.

but free reving when cold should not be done.

beers
__________________
Thanks, Mr. moody sardonic expert on so many things. Potentiated 09 Banned

All the stuff???? All I need is rum dude; everything else takes care of itself! Kane 09
swoope is offline   Reply With Quote
Old 01-25-2009, 09:29 PM   #10
Registered User
 
Trader Score: (0)
Join Date: May 2008
Location: MURFREESBORO, TN
Posts: 65
TN

My 2005 A/T with 32,000 miles did something similar. My CEL flashed for a few seconds and then went off and nothing really changed as far as how it ran. I read in the manual that ment it misfired. About 1,000 miles later my CEL came on and stayed on and I could still tell no difference in the way it ran. . . I took it in to the dealership and they said it was misfiring and they replaced all 4 coils and one plug wire that had shorted out. . . I still could tell no difference in the way it ran after but no more CEL. AND IT WAS UNDER WARRANTY!!!

I did have a question about if I should change the plugs as well after this happened??? Not to hijack the thread though
__________________
New car smell is overated. . . I prefer the smell of burnt rubber!!!!
Red71Chevelle is offline   Reply With Quote
Old 01-26-2009, 12:20 AM   #11
sold the 8... :(
 
Trader Score: (7)
Join Date: Feb 2008
Posts: 4,940
Quote:
Originally Posted by Red71Chevelle View Post
My 2005 A/T with 32,000 miles did something similar. My CEL flashed for a few seconds and then went off and nothing really changed as far as how it ran. I read in the manual that ment it misfired. About 1,000 miles later my CEL came on and stayed on and I could still tell no difference in the way it ran. . . I took it in to the dealership and they said it was misfiring and they replaced all 4 coils and one plug wire that had shorted out. . . I still could tell no difference in the way it ran after but no more CEL. AND IT WAS UNDER WARRANTY!!!

I did have a question about if I should change the plugs as well after this happened??? Not to hijack the thread though
with that mileage, yes. I would recommend doing plugs, coils, wires all at once. Might as well, since you are working in that area anyways.
__________________


05rex8 is offline   Reply With Quote
Old 10-18-2010, 10:36 AM   #12
Registered
 
Trader Score: (0)
Join Date: Aug 2007
Location: Fort Lauderdale, FL
Posts: 33
Post DIY, power steering fix flashing CEL and problem idling

Sorry to resurrect this thread. I did the DIY to bypass the coolant line from the throttle body, and cleaned my power steering connectors since I was getting the intermittent power steering failure so common among these parts. Well, everything worked and I was a happy camper until the CEL lit up and the car won't stay on while idling. The CEL flashes once or twice. I can restart the car but I need to keep the gas going a bit to prevent idling. While doing the DIY stuff I disconnected the accordion hose and the 3 small hoses including the MAP sensor. I think there is a leak somewhere, right? I don't want to go to the dealer because since the car went out of warranty I've spent over $3K in motor mounts, a radiator and coolant tank, water pump, belts and other stuff that obviously is not worth the dealer markup. Do any of you know of a good rotary guy or Mazda mechanic in the South FL, Fort Lauderdale area? Thanks in advance, this site rocks. Also, do you know if Autozone will loan me the scanner to get the CEL codes?
PR_RX-8 is offline   Reply With Quote
Old 10-18-2010, 10:47 AM   #13
SARXgroup.com
 
9krpmrx8's Avatar
 
Trader Score: (34)
Join Date: Jan 2007
Location: San Antonio, Texas
Posts: 27,451
sarxgroup
Autozone to get the codes read is teh first bet. But a flashing CEL indicates a misfire. When was the last time the plugs, coils, and wires were replaced?
__________________


"Clean is the new cool, so letís keep it that way."

9krpmrx8 is online now   Reply With Quote
Old 10-18-2010, 10:55 AM   #14
Registered
 
Trader Score: (0)
Join Date: Aug 2007
Location: Fort Lauderdale, FL
Posts: 33
Thanks for your reply.

About 3 years ago under warranty. Since then my water pump and radiator went and splashed coolant all over. I know some wires and connectors were replaced but this weekend I noticed a lot of brittle connector, and the clip for one of the intake sensors snapped but no big deal. I need to get the codes but I'm afraid to drive the 2.5 miles to get to the Autozone store, could they loan one to me with a deposit? Also, if I indeed have to replace everything, is it a big deal to DIY? I'm sick of the dealer raping me, thus my question to the forum if someone knows a good mechanic in South FL.
PR_RX-8 is offline   Reply With Quote
Old 10-18-2010, 10:00 PM   #15
Registered
 
Trader Score: (0)
Join Date: Aug 2007
Location: Fort Lauderdale, FL
Posts: 33
Update: Got code P0506 and drove around and problem went away. I wanted to be sure and found this thread so all is good.

Stalling at idle
PR_RX-8 is offline   Reply With Quote
Old 10-18-2010, 10:00 PM
RX8Club
Mazda RX8




Paid Advertisement


 
 
 
Reply

Tags
2011, 350z, blinking, cel, civic, flashing, idle, light, noisy, power, redline, rough, rx8, si, temporary, typhoon

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
rough idle, rough ride sivanes_81 Series I Tech Garage 11 09-17-2013 06:14 PM
rough idle brianmill64 Series I Tech Garage 1 08-05-2008 09:17 PM
CEL light blinking and rough idle (long read/background) SideOfBacon RX-8 Discussion 10 06-04-2008 02:38 PM
Rough Idle sixthgear151 RX-8 Discussion 5 10-17-2005 11:41 PM
So you think You have a rough idle? therm8 Lounge 2 04-17-2005 05:00 AM


All times are GMT -5. The time now is 10:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2011, Crawlability, Inc.
All content Copyright © 2007 by Internet Brands, Inc.
Emails Backup